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A
bout This D

ocum
entation

Thank you for purchasing our SWDraw3 Software for Laser Scanning System for 
Welding.
Please read this manual carefully to ensure correct use of the product. Keep the 
manual handy after reading for future reference.
This documentation covers instructions for welding control using the SWDraw3 
application for laser scanning system for welding. For installation, maintenance, and 
specifications of the laser scanning system for welding, refer to the manual for CL-
E100A.

1. Note

• Microsoft and Windows are either registered trademarks or trademarks of 
Microsoft Corporation in the United States and other countries.

• Company and product names in this manual are trademarks or registered 
trademarks of their respective owners.

• Unauthorized reproduction of this manual in whole or part is prohibited.
• The contents of this manual are subject to change without notice.
• Every effort has been made to ensure the accuracy of this information. If you come 

across oversights or errors, please notify your dealer.
• Be sure to read the user's manuals for any equipment used in conjunction with the 

system (e.g., documentation for computer systems).
• Graphics rendering support (for importing DXF data) is CADBuilderOCX 

developed by Knack SoftWare Inc.
• Image processing and pattern matching supports are Matrox Imaging Library 

(MIL) developed by Matrox.

About This Documentation
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2. Symbols Used in this Manual

Indicates instructions that must be followed to prevent hardware or software 
damage or operating errors.

Indicates additional information on a particular topic.

Menus, icons, buttons, 
windows, tabs

Enclosed in brackets.
Example: Click the [OK] button.

Keyboard keys Enclosed in angle brackets.
Example: Press the <Tab> key.

References Enclosed in quotes.
Example: Refer to “Chapter 8-3.2 Changing Passwords” (page 5).

CAUTION

�
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1. Features

By combining SWDraw3 with CL-E100A, consistent, high-quality, high-speed multi-
spot welding can be achieved.

• Operation on Windows operating system
Easy operation using the mouse. Drawings created using plotting software (such as 
CAD software) can be registered easily.

• Large, easy-to-read graphic screen
The screen uses a similar layout to Windows and is large and easy-to-read for easy 
operation.

• Full range of plotting functions

• Auto-backup function
The time interval or number of operations can be specified for automatically 
backing up data.

• Easy device setting and management
The laser equipment and scanner can be set and monitored from the computer.

Chapter 1 SWDraw3 Overview
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2. Installation

2.1. Installing SWDraw3, the Welding Application

The SWDraw3 application must be installed to control the laser equipment from a
computer. For the corresponding operating system, refer to the manual for CL-E100A.

Images and texts used in this section are for the standard setting of a desktop per-
sonal computer. They may differ depending on the installed service pack or patch.
SWDraw3 is not intended for the touch panel operation with Windows 10 (including
tablet). Operations with keyboard and mouse are explained.

Follow steps given below to install this application. The UAC (User Account Control)
dialog box asking whether you want to install it may appear during installation.
Select [Yes] or [Allow] to continue installations unless otherwise canceled purposely.
1 Close all applications.

2 Load the included DVD into the computer.

3 After you insert the DVD, the launcher (Autorun.exe) starts and the following screen 
is displayed.

SWDraw3 operates on Windows 10. Use Windows 10 with a build version of 
1607 or later.

You must have Administrators rights to install and use SWDraw3.
Only a user with Administrators rights can operate SWDraw3.

If SWDraw3 is already installed on your computer, uninstall it according to the 
following procedure by selecting [Control Panel] from the Start menu.
Right-click [SWDraw3] from [Programs and Features], and select [Uninstall].
Do not start SWDraw3 before uninstalling after booting the computer. Additionally, 
back up the work folder (the folder created by selecting [Settings] -> [Preferences] 
-> [Folders]).
When uninstalling is complete, reboot the computer and reinstall SWDraw3.

When starting installation, do not connect a new USB device such as a USB 
memory and a USB hard disk other than this equipment. The wrong driver might 
be installed.

CAUTION

CAUTION

CAUTION

CAUTION
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If the above screen is not displayed, open the DVD drive using the Explorer and double-click the Auto-
run.exe.

4 Click the [Install Program] button in the SWDraw field of the launcher (Autorun.exe).

The operating system on your computer is automatically detected to install a proper installer. Also, 
the language (Japanese or English) is automatically selected. The language to be selected depends on 
that when the operating system of the computer installed on the computer is set up for the first time 
(installation of operating system and activation). When the language is Japanese, the Japanese ver-
sion is installed. When the language is not Japanese, the English version is installed.

There are radio buttons for selecting language, and the program with the selected language is 
installed. If the Japanese version is installed on the English operating system and appropriate fonts 
are not installed on your computer, however, the characters are garbled and the application does not 
operate normally.

5 Immediately after starting installation, the screen which prompts you to install the 
Microsoft Visual C++2017 Redistributable Package(x86) is displayed. Click the 
[Install] button to install it.

Do not double-click the [Install Program] button. You may fail to install it if more 
than one installer is launched at a time.

CAUTION
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6 Click the [Next] button.

7 Read the precautions. Select [I accept the terms in the license agreement] to accept, 
then click the [Next] button.

8 Click the [Install] button.

File copying will begin.
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9 When the confirmation screen is displayed, click [Install this driver software anyway] 
to install it. (The screen display may differ.)

10 The following screen is displayed after SWDraw3 is installed. Click the [Finish] button 
to close the screen.

11 The screen which prompts you to reboot the computer is displayed. First, eject the 
DVD from the computer. Next, click the [Yes] button to reboot the computer.

SWDraw3 is now installed.
When starting SWDraw3 for the first time and there is no information on the con-
nected model in the installation folder, a message which prompts you to reboot
SWDraw3 is displayed.
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2.2. Computer Network Settings

To set schedules by the SWDraw3 laser equipment application, set the same network
group as the laser equipment. Follow steps given below to set the appropriate
computer network.
1 From the start menu, select [Windows System] -> [Control Panel].

You will see the [Control Panel] screen.

2 Click [Network and Sharing Center] in Classic View or [View network status and 
tasks] in Category View.
You will see the [Network and Sharing Center] screen.

3 Choose [Change adapter settings] on the [Network and Sharing Center] screen.
You will see the [Network Connections] screen.

4 Right-click [Local Area Connection] for the adapter to use and select the Properties.
You will see the [Ethernet Properties] screen.

5 Choose [Internet Protocol Version 4 (TCP/IPv4)] and select the Properties.

You will see the [Internet Protocol Version 4 (TCP/IPv4) Properties] screen.

6 Set the IP address and the Subnet mask.

7 Click the [OK] button to close the Control Panel.

You have finished setting up the computer network.

IP address: 192.168.1.100 (example)
* Anything except 70 since the laser 

equipment is [192.168.1.70].

Subnet mask: 255.255.255.0
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2.3. Computer Environment Settings

Before using the SWDraw3 laser equipment application, follow steps given below to
set the appropriate computer environment.
1 After starting the computer, adjust the energy management settings.

1) From the start menu, select [Windows System] -> [Control Panel].
You will see the [Control Panel] screen.

2) Choose [Power Options].
You will see the [Power Options] screen.

3) Choose [Balanced] and click [Change plan settings].
You will see the [Change plan settings] screen.

4) Choose [Change advanced power settings].
You will see the [Power Options (Advanced)] screen.

5) Complete the settings as shown below. For items not shown, leave them as the standard 
settings.

Hard disk, Turn off hard disk after: Never (or 0)

USB settings, USB selective suspend setting: Disabled

Display, Turn off display after: Never (or 0)

6) Click the [Apply] button and then click the [OK] button.
You will return to the [Power Options] screen.

7) Click the [Cancel] button.

You will return to the [Power Options] screen.

8) Click the [x] button to close the screen.

2 Adjust the display settings.

1) Press <Windows logo> key and <X> key simultaneously.

2) Click the Control panel from a pop-up shortcut menu.

The [Control Panel] screen will be displayed.

3) Choose [Screen Saver] from [Personalization] in Classic view or [Screen Saver] from 
[Change the theme] in Category View.
The [Screen Saver Settings] screen will be displayed.
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4) Choose [None] from a drop-down list of Screen saver.

5) Click the [Apply] button and then click the [OK] button.
You will return to the [Personalization] screen.

3 Click the [x] button to close the screen.

You have finished setting up the computer environment.

Choose [None].
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2.4. Installing the Camera Driver for the Gridwork

To connect the camera for the Gridwork, follow steps given below to install the camera
driver.
1 Click the [Install Program] button in the Camera Driver field of the launcher (Auto-

run.exe). When not starting the launcher, perform steps 1 to 3 of “2.1. Installing 
SWDraw3, the Welding Application.”

2 Follow the instructions on the screen to perform installation. Click the [Next] button 
when there is no instruction.

3 The screen for selecting the setup method is displayed in the middle of setup. Click 
the [Complete] button.

4 Click the [Install] button to start installation.

After a several seconds, you will see the screen confirming that the driver installation is complete.

5 Click the [Finish] button.

You have finished installing the camera driver.

When using the USB camera, connect the USB cable to the USB3.0 port of the com-
puter. When using the GigE (LAN) camera, refer to section 2.5.
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2.5. LAN Connection and Camera Driver Communication Settings

Perform the communication settings of LAN connection with a computer and the cam-
era driver installed in section 2.4. Before setting, confirm that LAN connection is
made as follows.

2.5.1. IP Address and Jumbo Frame Settings of LAN Connection

Follow steps given below to set the IP address and the jumbo frame of LAN
connection.
1 From the start menu, select [Setting] -> [Network and Internet], and click [Change 

adapter options] in Change your network settings on the displayed screen.

You will see the [Network Connections] screen. (Connection example)

2 Select the connected Ethernet from the [Network Connections] screen and right-click 
it. Select [Properties] from the pop-up menu and click it.

You will see the [Ethernet Properties] screen.
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3 Set the jumbo frame. Click the [Configure] button on the [Ethernet Properties] screen.

You will see the [“connected Ethernet name” Properties] screen.

4 Select the [Advanced] tab and select [Jumbo Frame (or Jumbo Packet)] from Prop-
erty and [9KB MTU (or 9014 Bytes)] from a drop-down list of Value. After selection, 
click the [OK] button to close the screen. The jumbo frame setting is complete.
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5 Set the IP address. Select [Internet Protocol Version 4 (TCP/IP)] in the [Ethernet 
Properties] screen and click the [Properties] button.

You will see the [Internet Protocol Version 4 (TCP/IP) Properties] screen.

6 Select [Use the following IP address] and specify “192.168.0.50” for the IP address 
not used for CL-E100A and “255.255.255.0” for the Subnet mask.

7 Click the [OK] button to close the screen.

You have finished setting up the LAN adapter.
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2.5.2. IP Address Setting by the Camera Driver

Set the IP address by using the application (GigECamaeraIPConfig) in the Sentech
SDK installed in section 2.4.

Follow steps given below to perform settings by using GigECamaeraIPConfig.
1 Select [Sentech SDK / GigECamaeraIPConfig] in the start program to start the GigE-

CamaeraIPConfig or start the GigECameraIPConfig_VC120_Win32.exe from the 
folder which the Sentech SDK has been installed (C:\Program Files\OMRON_SEN-
TECH\Sentech SDK\Application).

You will see the [Device Selection] screen.

2 Select the connected camera from the [Device Selection] screen and click the [Set IP 
Address...] button at the lower left portion.
You will see the [Set IP Address] screen.

3 Input “192.168.0.10” which is not the same as the IP address set at the time of LAN 
connection with CL-E100A in [IP Address], and the value set for LAN connection in 
[Subnet mask]. When the input values are not wrong, the [OK] button can be clicked. 
Click the [OK] button to close the screen.
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4 After setting the IP address, click the [OK] button to close the [Device Selection] 
screen. The [GigE Camera IP Config] screen for recording the IP address into the 
camera side appears automatically. Set the same IP address in the screen.

Follow steps given below to perform settings in the [GigE Camera IP Config] 
screen.

1) Uncheck [DHCP] if checked.

2) Check [Persistent IP].

3) Click the [Copy current IP setting] button to acquire the IP address set in step 3.

4) Click the [Apply] button to record the IP address into the camera side.

5 Click the [x] button to close the screen.

You have finished setting up the camera.
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2.6. Installing the Matrox Imaging Library

To use the Auto position alignment, follow steps given below to install the Matrox
Imaging Library (MIL).
1 Click the [Install Program] button in the Matrox DLL field of the launcher (Auto-

run.exe). When not starting the launcher, perform steps 1 to 3 of “2.1. Installing 
SWDraw3, the Welding Application.”

2 Select the folder where the Matrox Imaging Library is installed. Leave it unchanged 
and click the [Next] button if there is not special reason to change it.

3 The license agreement screen is displayed. Click the [I AGREE] button to accept the 
contents. If you do not agree, click the [DO NOT AGREE] button. In that case, the 
Auto position alignment function cannot be used.



2. Installation

24

SWDraw3

4 The installation setting screen for the Matrox Imaging Library (MIL) is displayed. Click 
the [Next] button without making any changes.

5 After installation, click the [Finish] button.

The Matrox Imaging Library (MIL) is now installed.
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1. Overview

The following settings are necessary after installing SWDraw3 referring to “Chapter 1
SWDraw3 Overview.”

2. Basic Settings

1 After starting SWDraw3, select [Setting] -> [Preferences] from the menu.
The [Preferences] screen. is displayed. For details of the [Preferences] screen, refer to "Chapter 15-1. 
Preferences" (page 248) .

2 Select “LAN” for [Connection to Controller] and click the [OK] button after confirming 
that the IP address is “192.168.1.70.”

3 Perform the following procedure. After setting, a message which prompts you to 
reboot SWDraw3 is displayed. After being rebooted, SWDraw3 operates under the 
model detected online.

Chapter 2 Basic Settings of SWDraw3
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3. Camera Monitor Selection

1 From the menu, select [Laser Control] -> [System Parameters].

2 Select “Yes” from [Camera] under Camera monitor.

• Perform this operation only when the Camera Unit (option) is connected.
• Perform this operation when communicating with CL-E100A for the first time 

and changing the Camera Unit.CAUTION
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3 Click the [Transfer] button. On success, the message “System parameters trans-
ferred” appears. Click the [OK] button to close the screen.

4 Click the [Close] button to close the screen.

The camera monitor is now selected.



4. Scanner Setting Check

28

SWDraw3

4. Scanner Setting Check

1 From the menu, select [Laser Control] -> [Adjust].

2 Input the password on the [Enter Password] screen and click the [OK] button to dis-
play the [Scanner adjust] screen. (When no password is set, leave it blank and click 
the [OK] button.)

3 Confirm that [Lens] of Scanner 1 is the same as the fθ lens mounted on the scanner 
head unit.

• Perform this operation only when the scanner head unit CL-H series is con-
nected.

• Perform this operation with online to CL-E100A.
• Perform this operation when communicating with CL-E100A for the first time 

and changing the fθ lens.
CAUTION
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4 Click the [OK] button.

The scanner setting is now checked.
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Welding Workflow

This section outlines computer-based welding using the following conditions.
Example:
• Material to be welded: SUS
• Layout filename: SAMPLE
• Figure to be welded: Rectangle

The basic welding workflow is as follows.

Chapter 3 [Quick Reference] 
Computer-based Welding

Before following these procedures, make sure the equipment has been installed 
and connected.
If not, refer to the manual for CL-E100A for instructions on installation and 
connection.

(4) Transferring layout files

(2) Setting the schedule

(3) Creating welding figures (Creating a layout file)

(5) Welding

(1) Starting the equipment

(6) Stopping system operations

CAUTION
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(1) Starting the equipment

Before startup, confirm the following points.

• The laser equipment, laser control unit, and computer are off.
• The laser equipment, laser control unit, and computer are connected with the LAN cable.

1 Turn on the laser equipment.

2 Turn on the laser equipment Control key 
switch.

3 Turn on the laser control unit. “INITIAL” is 
displayed for Status on LCD and self-
diagnosis begins.

4 After self-diagnosis is complete, “READY” 
is displayed for Status on LCD. After 
confirming it is displayed, go to the next 
step.

5 Start the computer.
After confirming that the computer is 
running, go to the next step.

6 Double-click the [SWDraw3] icon on the 
desktop to start the SWDraw3 
application.
After SWDraw3 starts, the Drawing 
screen is displayed.

7 Confirm that the equipment is connected 
correctly by checking the status display 
field on the Drawing screen.
“Online” displayed in the title bar indicates 
that the laser control unit is online.

Equipment startup is now complete.

When reversing the order of steps 2 
and 3, the error No. 1030 may 
occur. Execute the reset operation.CAUTION
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(2) Setting the schedule

Before starting welding, the waveform creation method, the laser emission time, and laser output
parameters must first be set. The output parameters for this system are referred to as a schedule.
Here, the waveform is created using the FIX method. For details, refer to "Chapter 6-3. Schedule"
(page 74) .

1 From the menu, select [Laser Control] -> 
[Schedule].

The [SCHEDULE INPUT] screen 
appears.

2 Set the desired schedule number in the 
[SCHEDULE] box (e.g. “0”), and then 
select “FIX” in the [FORM] box.

The FIX form screen appears.

3 Set the laser output peak value in [SET 
POWER], the number of laser outputs per 
second in [REPEAT], and the number of 
laser outputs in [SHOT] as shown below.

4 Set the laser output time and laser output 
value in [ ↑ SLOPE] to [ ↓ SLOPE] as 
shown below. Note that [ ↑ SLOPE] 
cannot be entered after [FLASH1] has 
been entered.

Schedule setting is now complete.

The [SCHEDULE INPUT] screen 
appears only when the laser 
equipment is online.

SET 
POWER

REPEAT SHOT

50 10 100

↑ SLOPE FLASH1 COOL1 FLASH2 COOL2 FLASH3 ↓ SLOPE

TIME 1.0 2.0 1.0 1.0 1.0 2.0 1.0

POWER – 100.00 – 50.00 – 25.00 –

CAUTION

[SCHEDULE]
[FORM]

[SHOT]

[SET POWER]

[REPEAT]

Set the laser output time and laser output value.
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(3)Creating welding figures (Creating a layout file)

Arrange the figures to be welded and save them as a layout file.
The following example shows how to create a layout file consisting of rectangles.

1 To create a new layout, you will need a 
new layout file.

Click the [New Layout] button.

The Drawing screen displays a blank 
layout area.

2 Click the [Square] button.

3 Position a rectangle.

Click the desired location, move the 
mouse to alter the size, and then click for 
the desired size.
The [Square] screen appears.

4 Enter the value, and click the [OK] button.

[Square] button

[New Layout] button

Move the mouse to determine the rectangle size.

[OK] button
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5 Save the layout file after arranging the 
rectangle.

From the menu, select [File] -> 
[Save Layout As].
The [Save Layout As] dialog is displayed.

6 Enter the filename in [Filename] (e.g. 
SAMPLE), and click the [OK] button.

7 The confirmation message on the right is 
displayed after the file is saved. Click the 
[OK] button to close.

The layout file of the rectangle to be welded
is now saved in the computer work folder.

Enter the filename.

[OK] button
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(4) Transferring layout files

This step transfers the created layout file to the laser control unit. The laser control unit manages
layout files by file numbers. You must assign a number to the file.

1 The confirmation screen appears.

2 Click the [Yes] button.

The [Batch Transfer] screen appears. The 
layout created in (3) is highlighted (red 
frame in thumbnail display or gray/blue 
background in list display).

You will return to the Drawing screen 
without transferring by clicking the [No] 
button.

3 In [Layouts Available For Transfer] on the 
left, select a layout file to be transferred 
(e.g. SAMPLE), and double-click on a 
layout number (e.g. 1) in [Transferred 
Layouts] on the right.

The layout filename is displayed on 
[Layouts Available For Transfer] and a 
check mark is put in [Transferred 
Layouts].

4 The confirmation message on the right is 
displayed following file transfer. Click the 
[OK] button to close.

When the layout number is not changed, 
the confirmation message on the right is 
displayed. Click the [OK] button to close.

The layout file has now been transferred to
the laser control unit and the layout number
(active layout) is set.

[Yes] button

Double-click the layout file 
to be transferred.

[Upload] button

Select the layout number.

[OK] button

[OK] button
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(5) Welding

Commence welding.

1 The confirmation screen appears.

2 Click the [Yes] button to display the 
[Control] screen.

You will return to the Drawing screen by 
clicking the [No] button.

3 Mount the workpiece to be welded.

4 Confirm that the layout created in (3) is 
displayed in [Scanner] (e.g. “110”).

This step identifies the layout file for 
welding.

5 Confirm that the laser control unit is 
controlled locally. The laser control unit is 
controlled locally if [Control Mode] 
appears as [Local]. If not controlled 
locally, click the [Local] button for [Laser 
Control].

6 The laser control unit is running if [LD] 
appears as [ON]. If not running, click the 
[LD ON] button for [Laser Control].

7 Click the [Shutter Open] button of the 
shutter to be used to open the shutter.

Always wear protective eyewear when emitting the laser beam.

When the layout file cannot be 
transferred or the transferred layout 
number is not displayed, the USB 
communication may be offline or 
[Control Mode] is [Remote].

CAUTION

[Yes] button

[Scanner]

CAUTION

[Start Scan] button

[LD ON] button

[Local]

[Shutter 1] button
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8 Click the [Start Scan] button.

The [Laser Scanning Ready] screen 
appears.

9 Click the [Start] button.

Welding starts.

When 5 seconds has passed while the mouse cursor is placed over the [Start] 
button on the [Laser Scanning Ready] screen or immediately after completion of 
laser scanning, the screen is locked for safety and the following screen appears. 
Click the [OK] button to return to the [Laser Scanning Ready] screen.

When the [Start Scan] button is clicked with the <Enter> key or the <Space> key 
on your keyboard pressed, the following screen appears. To start welding from a 
keyboard, press the <Enter> key or the <Space> key with pressing the <Shift> 
key and click the [Start Scan] button.

[Start] button

�

�
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(6) Stopping system operations

1 From the menu, select [Laser Control] -> 
[Control].
The [Control] screen appears.

2 When the [LD] is ON, click the [LD OFF] 
button.

3 The "Cooling down" message is 
displayed on the Drawing screen while 
operation is stopped.

4 The "Cooling down" message disappears 
on the Drawing screen after the LD has 
finished shutting down.

Do not turn off the power switch while 
the Drawing screen displays the 
“Cooling down” message.
Shutting off the power switch while 
the system is stopped will 
significantly reduce the life of the 
laser equipment.

Do not shut off the power while 
“Online” is displayed in the title bar. 
Shutting off the power switch while 
[Online] is displayed may result in the 
loss of data on memory card, 
preventing the system from 
restarting.

[LD OFF] button

CAUTION

CAUTION
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5 Click the [Offline] button on the [Control] 
screen.

6 Click the [Close] button to close the 
[Control] screen.

7 To exit SWDraw3, select [File] -> [Exit] 
from the menu or click the Close box ([x] 
button) in the top-right corner of the 
screen.

8 Turn off the power of laser control unit.

9 Turn off the laser equipment Control key 
switch.

10 Turn off the laser equipment.

System shutdown is now complete.

[Offline] button

[Close] button

Close box ([x] button)



1. Drawing Screen Structure

40

SWDraw3

1. Drawing Screen Structure

(1) Menu bar and toolbar
The menu bar and toolbar offer functions used in preparing layout files. (Refer to 
"Chapter 4-2. Drawing Screen Functions" (page 42) .)

(2) Drawing commands
These buttons are used for common drawing functions. (Refer to "Chapter 4-2. 
Drawing Screen Functions" (page 42) .)

(3) Layout area
This area is used for drawing. The area within this circle corresponds to the 
actual welding area. For drawing, figure selection, and other actions, you will use 
the crosshair cursor (hereafter, “cursor”) or enter coordinates. The cursor can be 
freely moved using the mouse.

Chapter 4 Drawing Screen

(1)

(2)

(3)

(4)

(5)

(6)

(7)

(8)
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(4) Message display
Displays messages regarding operations.

(5) History display
Displays a record of operations.

(6) Properties field
Displays figure properties. You can change the properties here as needed.

(7) Command field
For entry of single-byte numbers for coordinates, angles, radii, etc.

(8) Status bar
Displays the current cursor position and ON/OFF status for the laser equipment.

Clicking the background of the layout area will display [Overwrite All], [Fixed 
Wobbling] and [Wobbling] properties in the properties field.
[Overwrite All] allows you to specify the number of times of repeating the overall 
layout (1 to 5000).
[Fixed Wobbling] allows you to repeat the overall layout until the laser scanning 
stops. To apply the [Fixed Wobbling] function, the layout should consist of a single 
part and be a single closed figure. When the layout includes multiple images, the 
[Fixed Wobbling] function may not function.
It may not work as set depending on the combination of the set values (scanning 
speed and specified distance).
[Fixed Wobbling] cannot be used together with [Overwrite All] and overlap. To 
enable a function you select, click the [Update] button after inputting the number 
for [Overwrite All] or putting a check mark for [Fixed Wobbling].
In the [Default] setting of Mode of [Wobbling], the [Wobbling] function in the [Sys-
tem Parameters] screen becomes enabled. Also, when both [Wobbling] in the 
Drawing screen and [Wobbling] in the [System Parameters] screen are selected, 
the [Wobbling] setting in the Drawing screen becomes enabled. (Refer to 
"Chapter 6-7. System Parameters  (Setting Laser Equipment Operating 
Conditions)" (page 101) .)

Elements of the Status Bar

Item Function

Coordinate value Displays cursor coordinates.

LD ON/OFF Displays ON when the laser equipment is running; OFF when stop-
ping.

GUIDE ON/OFF Displays ON when the guide beam of the laser equipment is turned 
on; OFF when turned off.

MSHU ON/OFF Displays ON when the safety shutter 1 of the laser equipment is 
open; OFF when closed.

SHU1 ON/OFF Displays ON when the branch shutter 1 of the laser equipment is 
open; OFF when closed.

SHU2 ON/OFF Displays ON when the branch shutter 2 of the laser equipment is 
open; OFF when closed.

SHU3 ON/OFF Displays ON when the branch shutter 3 of the laser equipment is 
open; OFF when closed.

Hard Error
ERROR NONE

Displays the error status. Hard Error is displayed when an error 
occurs. ERROR NONE is displayed when no error occurs.

�
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2. Drawing Screen Functions

The following table lists the Drawing Screen menus and the corresponding functions.
Drawing Screen Functions (1 / 6)

Menu Submenu Button Function

File New Displays a new layout screen.
(See "Chapter 5-1.1. New (Creating New Layout Files)" (page 
48) .)

Open Opens a layout file.
(See "Chapter 5-1.2. Open (Editing an Existing Layout File)" 
(page 49) .)

Save Saves the open layout file under the same name.
(See "Chapter 5-1.3. Save (Saving Layout Files)" (page 50) .)

Save As
－

Saves the open layout file under a different name.
(See "Chapter 5-1.4. Save As (Saving Layout Files under a New 
Name)" (page 51) .)

Save Layout 
PrevVer

－

Saves the open layout file in the format of the previous version 
to load the file in the version without hatching or repetition 
functions (V00-02A and earlier of SWDraw2 or SWDraw). 
Hatching is converted into polylines or deleted. Repetition is 
initialized (fixed to 1).
(See "Chapter 5-1.5. Save Layout PrevVer  (Saving Layout Files 
in the Format of the Previous Version)" (page 52) .)

Import -> 
Import DXF －

Imports a DXF file created in CAD software.
(See "Chapter 5-2.1. Import DXF (Importing DXF Files)" (page 
56) .)

Import -> 
Import GWH －

Imports a file created on the GWH-□□-□□.
(See "Chapter 5-2.2. Import GWH (Importing GWH Files)" 
(page 57) .)

Merge Layout
－

Imports a plurality of existing layout files to newly create a 
merged layout.
(See "Chapter 5-3. Merging Layouts" (page 58) .)

Exit － Quits SWDraw3. (See "Chapter 5-4. Exit" (page 60) .)

Laser Control Control Sends layout files performs welding, and sets control devices.
(See "Chapter 6-1. Control" (page 61) .)

Schedule Sets the laser emission time and laser output parameters.
(See "Chapter 6-3. Schedule" (page 74) .)

Batch Transfer Transfers layout files to the laser control unit.
(See "Chapter 6-4.1. Layout File Transfer" (page 92) .)
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Laser Control
(continued)

Adjust
－

Sets the scanner operating conditions.
(See "Chapter 6-5. Scanner Adjust" (page 98) .)

Camera Moni-
tor

Operates the camera live image and the scanner.
Calls the [Capture] screen.
(See "Chapter 6-6. Camera Monitor" (page 100) .)

System 
Parameters

Specifies basic laser equipment operating conditions.
(See "Chapter 6-7. System Parameters  (Setting Laser 
Equipment Operating Conditions)" (page 101) .)

RS232C Setting

－

Making communication settings on the laser control unit side 
in RS-232C communication between the control computer and 
the laser control unit.
(See "Chapter 6-8. RS232C Setting" (page 106) .)

Event 
Information －

Displays the contents of events.
(See "Chapter 6-9. Event Information" (page 107) .)

External I/O 
Monitor Test

Monitors the I/O signals connected to the external I/O connec-
tor.
(See "Chapter 6-10. External I/O Monitor Test" (page 108) .)

Edit Undo
－

Undoes the previous action.
(See "Chapter 8-1. Undo (Undoing an Operation)" (page 149) .)

Redo
－

Repeats the action that was undone.
(See "Chapter 8-2. Redo (Redoing an Operation)" (page 149) .)

Delete
－

Deletes the selected figures.
(See "Chapter 8-3. Delete (Deleting a Figure)" (page 149) .)

Copy
－

Creates a copy of the figures.
(See "Chapter 8-4.1. Copy (Arranging Copied Objects)" (page 
150) .)

Copy and 
Rotate －

Copies and rotates figures.
(See "Chapter 8-4.2. Copy and Rotate (Arranging Rotated 
Copies)" (page 151) .)

Copy and 
Invert －

Copies and inverts figures.
(See "Chapter 8-4.3. Copy and Invert (Arranging Inverted 
Copies)" (page 152) .)

Move
－

Moves figures.
(See "Chapter 8-5.1. Move (Moving Figures)" (page 153) .)

Move and 
Rotate －

Moves and rotates figures.
(See "Chapter 8-5.2. Move and Rotate (Moving and Rotating 
Figures)" (page 154) .)

Move and 
Invert －

Moves and inverts figures.
(See "Chapter 8-5.3. Move and Invert (Moving and Inverting 
Figures)" (page 155) .)

Edit Comment
－

Edits the created comment.
(See "Chapter 8-6. Comment (Editing a Comment)" (page 157) 
.)

Resize Sketch
－

Adjusts sketch size.
(See "Chapter 8-5.4. Resize Sketch" (page 156) .)

Drawing Screen Functions (2 / 6)

Menu Submenu Button Function
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Edit
(continued)

Array
-> Create

Copies the figure to create an array.
(See "Chapter 8-7.1. Creating Arrays" (page 158) .)

Array
-> Cancel

Clears arrays and returns it to the original figure.
(See "Chapter 8-7.2. Canceling Arrays" (page 159) .)

Adjustment Trim
－

Removes or extends a portion of lines.
(See "Chapter 9-1.1. Trim (Deleting Parts of Lines)" (page 160) 
.)

Trim Junction
－

Trims unneeded lines from intersection of two lines.
(See "Chapter 9-1.2. Trim Junction (Deleting Extra Lines from 
Junctions)" (page 161) .)

Selection Mode Switches to Selection Mode.
(See "Chapter 9-2.1. Selection Mode (Switching to Selection 
Mode)" (page 162) .)
Displays the properties of selected figures.
(See "Chapter 9-3.1. Using Properties" (page 164) .)

Rotation Mode Rotates line segments in Selection Mode.
(See "Chapter 9-2.2. Rotation Mode (Rotating Line Segments in 
Selection Mode)" (page 163) .)

Poly Resolve

－

Splits polylines created at their construction points into line 
segments.
(See "Chapter 9-4. Poly Resolve (Splitting Figures)" (page 175) 
.)

Square Resolve
－

Splits squares into line segments or arcs.
(See "Chapter 9-5. Square Resolve (Splitting Squares)" (page 
176) .)

Divide
－

Divides figures created at any point.
(See "Chapter 9-6. Divide (Dividing Figures)" (page 177) .)

Arc to Poly
－

Divides arcs into polylines in the specified number.
(See "Chapter 9-7. Arc to Poly" (page 179) .)

Unite
－

Joins two line segments or arcs into one.
(See "Chapter 9-8. Unite (Joining Two Figures into One)" (page 
180) .)

Unite Poly
-> Auto －

Joins two line segments into one automatically.
(See "Chapter 9-9.1. Auto (Joining Lines into One 
Automatically)" (page 182) .)

Unite Poly
-> Manual －

Joins two line segments into one manually.
(See "Chapter 9-9.2. Manual (Joining Lines into One 
Manually)" (page 183) .)

Fillet
－

Rounds off corners created with two line segments or polyline 
in the specified radius.
(See "Chapter 9-10. Fillet" (page 184) .)

Add Const. Pt
－

Adds a construction point.
(See "Chapter 9-11. Add Const. Pt" (page 186) .)

Delete Const. 
Pt －

Deletes a construction point.
(See "Chapter 9-12. Delete Const. Pt" (page 187) .)

Drawing Screen Functions (3 / 6)

Menu Submenu Button Function
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Adjustment
(continued)

Hatch to Poly
－

Converts hatching set in circles or squares into polylines.
(See "Chapter 9-13. Hatch to Poly" (page 188) .)

Scanning Order 
-> Auto

－

Automatically sets the scanning order and direction of the 
continuous objects in contact with the selected object.
(See "Chapter 10-2. Automatic Scanning Order Function" (page 
190) .)

Scanning Order 
-> Reverse －

Switches the start and end points for the selected object.
(See "Chapter 10-3. Reverse Scanning Order Function" (page 
195) .)

Scanning Order 
-> Check

－

Indicates the continuous objects in contact with the selected 
object and the scanning direction.
(See "Chapter 10-4. Scanning Order Confirmation Function" 
(page 198) .)

Draw Line Drawing 
Commands:
[Line] button

Draws a line.
(See "Chapter 11-1. Line (Drawing Lines)" (page 202) .)

Polyline Drawing 
Commands:
[Polyline] 
button

Draws a polyline (polyline: a continuous line of multiple line 
segments; e.g., a zig-zag).
(See "Chapter 11-2. Polyline (Drawing Polylines)" (page 203) .)

Parallel Lines Drawing 
Commands:
[Parallel 
Lines] button

Draws a line parallel to the current line.
(See "Chapter 11-3. Parallel Lines (Drawing Parallel Lines)" 
(page 217) .)

Square Drawing 
Commands:
[Square] but-
ton

Draw a rectangle.
(See "Chapter 11-4. Square (Drawing Rectangles)" (page 218) .)

Circle [Manual] Drawing 
Commands:
[Circle 
[Manual]] 
button

Draws a circle with overlap.
(See "Chapter 11-5.1. Drawing Circles with Overlap (Manual)" 
(page 221) .)

Arc
－

Draws an arc of specific radius.
(See "Chapter 11-6. Arc (Specifying a Radius to Draw an Arc)" 
(page 225) .)

3-Point Arc Drawing 
Commands:
[3-Point Arc] 
button

Draws an arc from three specific points on a circle.
(See "Chapter 11-7. 3-Point Arc (Specifying 3 Points to Draw an 
Arc)" (page 227) .)

Spot Drawing 
Commands:
[Spot] button

Draw a dot.
(See "Chapter 11-8. Spot (Drawing Dots for Spot Welding)" 
(page 228) .)

Axis Control Drawing Com-
mands:
[Axis Control] 
button

Arranges the axis control command.
(See "Chapter 11-9. Axis Control (Communicates with External 
Devices)" (page 229) .)

Circle [Auto] Drawing 
Commands:
[Circle [Auto]] 
button

Draws a conventional circle.
(See "Chapter 11-5.2. Drawing Conventional Circles (Auto)" 
(page 223) .)

Comment
－

Adds a comment for layout data regardless of scanning.
(See "Chapter 11-10.1. Creating a Comment" (page 232) .)

Layout Align Left
－

Aligns figures to the left.
(See "Chapter 12-1. Align Left" (page 235) .)

Drawing Screen Functions (4 / 6)

Menu Submenu Button Function
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Layout
(continued)

Align Right － Aligns figures to the right.

Align Top － Aligns figures to the top.

Align Bottom － Aligns figures to the bottom.

Center 
Horizontally －

Centers figures horizontally.

Center 
Vertically －

Centers figures vertically.

Justify 
Horizontally －

Justifies figures horizontally.

Justify 
Vertically －

Justifies figures vertically.

View Zoom Extents
－

Narrows view to the area containing the figures.
(See "Chapter 13-1. Zoom Extents" (page 239) .)

Zoom All Restores the default view.

Zoom In Zooms in the full view.

Zoom Selection － Zooms in on the selected area.

Zoom Out Zooms out the full view.

Pan － Shifts the field of view to focus on specific coordinates.

Show/Hide Grid
－

Shows or hides grid lines.
(See "Chapter 13-7. Show/Hide Grid" (page 242) .)

Refresh － Updates the screen display.

Show/Hide 
Sketch －

Shows or hides the sketch.
(See "Chapter 13-9. Show/Hide Sketch" (page 242) .)

Edit Sketch
－

Switches Sketch Edit mode on or off.
(See "Chapter 13-10. Edit Sketch" (page 242) .)

Show/Hide 
Overlap －

Shows or hides the overlap portion of square object.
(See "Chapter 13-11. Show/Hide Overlap" (page 242) .)

Show/Hide 
Gridwork Area －

Shows or hides the Gridwork area specified in the layout.
(See "Chapter 13-12. Show/Hide Gridwork Area" (page 243) .)

Show/Hide 
Landmark －

Shows or hides the landmark in the layout.
(See "Chapter 13-13. Show/Hide Landmark" (page 243) .)

Grid Grid Spacing
－

Specifies grid spacing.
(See "Chapter 14-1. Grid Spacing" (page 244) .)

Grid Origin
－

Positions the grid.
(See "Chapter 14-2. Grid Origin" (page 245) .)

Snap Setting
－

Allows selection of elements to snap to the grid.
(See "Chapter 14-3. Snap Setting" (page 246) .)

Drawing Screen Functions (5 / 6)

Menu Submenu Button Function
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Grid
(continued)

Angle 
Correction －

Activates or deactivates angle correction.
(See "Chapter 14-4. Angle Correction" (page 247) .)

Distance Mea-
surement －

Measures the distance between specified two points.
(See "Chapter 14-5. Distance Measurement" (page 247) .)

Setting Preferences Used to specify operation involving basic application functions.
(See "Chapter 15-1. Preferences" (page 248) .)

Help About 
SWDraw3

Displays SWDraw3 version information.
(See "Chapter 17-1. About SWDraw3  (Checking SWDraw3 
Version Information)" (page 257) .)

About the Con-
troller －

Displays the Laser Control Unit Software Version.
(See "Chapter 17-2. About the Controller  (Checking the Laser 
Control Unit Software  Version)" (page 257) .)

－ － Toolbars:
[Refresh] but-
ton

Updates the figures in the layout area.

Drawing Screen Functions (6 / 6)

Menu Submenu Button Function
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1. Creating, Saving and Transferring Files

1.1. New (Creating New Layout Files)

The layout and welding conditions for figure data for welding are saved in a layout
file. You must prepare a new layout file to create new welding data.
Follow the steps given below to create layout files.

1 Click the [New Layout] button from the toolbar or select [File] -> [New Layout] from 
the menu.
The new layout file is created with a blank layout area.

2 If you do not save the file, it will not be stored as a layout file in the work folder. You 
must save the file after creating the layout.
For details of how to save files, refer to "Chapter 5-1.3. Save (Saving Layout Files)" 
(page 50) .

Chapter 5 File

Only one layout file can be open at any time. Save and close any layout files you 
are in the process of creating before opening others.

CAUTION
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1.2. Open (Editing an Existing Layout File)

Follow the steps given below to edit existing layout files.

1 Click the [Open Layout File] button from the toolbar or select [File] -> [Open Layout] 
from the menu.
This displays the [Open Layout] screen.

2 Select the file to edit.

3 Click the [OK] button.
After the layout file opens, the welding data is displayed in the layout area.

Only one layout file can be open at any time. Save and close any layout files you 
are in the process of creating before opening others.

Click the [Switch View] button to view a list of filenames instead of thumbnails.

CAUTION

Select the file.

�
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1.3. Save (Saving Layout Files)

You can save layout files as shown below.
1 With the layout file open, click the [Save Layout] button from the toolbar or, from the 

menu, select [File] -> [Save Layout].
The layout file has now been overwritten, and you will see a message confirming that the layout has 
been saved. Click the [OK] button to close.

1 The message “Transfer layout file?” is displayed.
Click the [Yes] button to perform operation from layout data transfer to laser scan-
ning. (For details, refer to "Chapter 5-1.6. Layout File Transfer" (page 53) .)
Click the [No] button to return to the Drawing screen.
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1.4. Save As (Saving Layout Files under a New Name)

Save layout files as follows.
1 From the menu, select [File] -> [Save Layout As].

The [Save Layout As] dialog is displayed.

2 Enter the filename in [Filename].

3 Click the [OK] button.
The layout file has now been overwritten, and you will see a message confirming that the layout has 
been saved. Click the [OK] button to close.

4 The message “Transfer layout file?” is displayed.
Click the [Yes] button to perform operation from layout data transfer to laser 
scanning. (For details, refer to "Chapter 5-1.6. Layout File Transfer" (page 53) .)
Click the [No] button to return to the Drawing screen.

• Enter up to 255 single-byte characters (including drive name and path 
information) for the filename.

• Symbols (\/:*?"<>|), one-byte space, CON, AUX, COM1 to COM9, LPT1 to 
LPT9, PRN, and NUL may not be used in filenames.

Click the [Switch View] button to view a list of filenames instead of thumbnails. 
The setting remains even after restarting SWDraw3.

Enter the filename.

CAUTION

�

[OK] button
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1.5. Save Layout PrevVer
(Saving Layout Files in the Format of the Previous Version)

Save layout files in the format of the previous version as follows.
1 From the menu, select [File] -> [Save Layout PrevVer].

2 If hatching exists, a message is displayed.
Click the [Yes] button to convert hatching into polylines. (For details, refer to "Chapter 
9-13. Hatch to Poly" (page 188) .) Click the [No] button to delete hatching.
Repetition is also initialized.
The [Save Layout PrevVer] dialog is displayed.

3 Enter the filename in [Filename].

4 Click the [OK] button.
The layout file has now been overwritten, and you will see a message confirming that the layout has 
been saved. Click the [OK] button to close.

• Enter up to 255 single-byte characters (including drive name and path 
information) for the filename.

• Symbols (\/:*?"<>|), one-byte space, CON, AUX, COM1 to COM9, LPT1 to 
LPT9, PRN, and NUL may not be used in filenames.

Click the [Switch View] button to view a list of filenames instead of thumbnails. 
The setting remains even after restarting SWDraw3.

Enter the filename.

CAUTION

�

[OK] button
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1.6. Layout File Transfer

This step transfers the created layout file to the laser control unit. The laser control
unit manages layout files by file numbers. You must assign a number to the file.
The layout file can be transferred to the laser control unit as follows.
1 The message “Transfer layout file?” is displayed after file saving. Click the [Yes] but-

ton.

The following sequence differs according to the status of layout file and layout number. The sequence 
is explained in 1.6.1 to 1.6.4.

2 Click the [Yes] button to display the [Control] screen. In the [Control] screen, you can 
control the laser such as laser scan. (For details, see "Chapter 6-1. Control" (page 
61) .)
You will return to the Drawing screen by clicking the [No] button.

1.6.1. Layout File is Transferred and Layout Number is the Same

1 The message “File transfer complete” is displayed. Click the [OK] button.

1.6.2. Layout File is Transferred and Layout Number is Different

1 To transfer the layout file, click the [Yes] button.

You will return to the Drawing screen without transferring the layout file to the laser control unit by 
clicking the [No] button.

[Yes] button

[Yes] button
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2 After transfer is complete and the message that the layout number has been changed 
to that of the transferred layout file, click the [OK] button.

1.6.3. Layout File is Not Transferred and Layout Number is the Same

1 The [Batch Transfer] screen is displayed.

2 Select the layout file from the thumbnail at the left, and double-click the layout 
number to be assigned to the layout file from the list at the right.

3 Click the [Upload] button.
The message “File transfer complete” is dipalyed. Click the [OK] button to close.

4 Click the [Close] buton to close the [Batch Transfer] screen.

When [Control Mode] is [Remote], the layout number (active layout) of the laser control unit is not switched. (For details, refer to "Chapter 6-4. Dara Transfer (Transferring, Deleting, and Copying Layout File)" (page 91) .)

[OK] button

CAUTION

Select the layout file. Select the layout 
number.
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1.6.4. Layout File is Not Transferred and Layout Number is Different

Operation is the same as 1.6.3.
After transfer is complete and the message that the layout number has been changed
to that of the transferred layout file, click the [OK] button.

When [Control Mode] is [Remote], the layout number (active layout) of the laser 
control unit is not switched. (For details, refer to "Chapter 6-4. Dara Transfer 
(Transferring, Deleting, and Copying Layout File)" (page 91) .)

[OK] button

CAUTION
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2. Importing Files

2.1. Import DXF (Importing DXF Files)

DXF files created with CAD software can be imported and arranged in layout files.

Follow these steps to import a DXF file. Imported DXF files can be used as sketches.
1 From the menu, select [File] -> [Import] -> [Import DXF].

You will see the [Open] screen.

2 Select the DXF file to import.
To use the imported DXF file as a sketch, select [Import As Sketch].

3 Click the [Open] button.

The DXF file is imported and displayed in the layout area.

Only DXF files created using AutoCAD are supported.

• DXF data that can be imported: lines, circles, arcs, ellipses, elliptical arcs, bro-
ken lines, text, curves, blocks (parts), and dots.

• When a DXF file is imported, the origin specified within the CAD program is 
used as the center coordinate for welding. Thus, adjust the origin accordingly 
within the CAD program before you import the file.

• Use DXF files in ASCII format. Binary files are not supported.

CAUTION

�

Check this box to use 
the file as a sketch.
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2.2. Import GWH (Importing GWH Files)

Files created with other laser equipment software can also be imported and arranged
in layout files.
1 From the menu, select [File] -> [Import] -> [Import GWH].

You will see the [Open] screen.

2 Select the GWH file to import.

3 Click the [Open] button.
This displays a message that confirms that you have imported. Also, the offset values set in GWH 
files are displayed. Record the values accordingly. Click the [OK] button to close.

The GWH file is imported and displayed in the layout area.
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3. Merging Layouts

Import a plurality of existing layout files to newly create a merged layout.

3.1. Merged Elements

Elements are as follows.

3.2. Merge Layout (Merging Existing Layout Files)

1 Select [File] -> [Merge Layout] from the menu.
This displays the [Merge Layout] screen.

2 Select the file to merge.

Type Availability Remarks

Line ○

Circle ○ Including hatching
Arc ○

Square ○ Including hatching
Polyline ○

Spot ○

Axis Control ○

Comment ○

Sketch ×

○ : Available   ×: Unavailable

Select the file.
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3 Click the [OK] button.

When the number of use elements is less than 1000 including the file to merge, the selected welding 
data is displayed in the layout area. When it is 1000 or more, the message “The number of the object 
is the limit. Is it continued?” is displayed.

Click the [Yes] button to merge up to 1000 objects. Click the [No] button to close the screen without 
merging layouts.

The scanning order of the merged elements is added after the last object currently created.

4 Save the created merged layout file as new file accordingly.

Click the [Switch View] button to view a list of filenames instead of thumbnails.�
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4. Exit

1 To exit SWDraw3, select [File] -> [Exit] from the menu or click the Close box ([x] 
button) in the top-right corner of the screen.

For system shutdown, refer to "Chapter 3- (6) Stopping system operations" (page 38) .

Close box
([x] button)
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1. Control

The [Control] screen allows layout files to be sent, welding to be performed, and
control devices to be set. This section provides an overview of the [Control] screen.

(1) [Online]/[Offline] Button

Click the [Online] button to enable LAN communication.
Click the [Offline] button to disable LAN communication.

Chapter 6 Laser Control

Reboot SWDraw3 if the model set when SWDraw3 is offline is different from the 
model connected when it is online.

(1)

(2)

(4)

(11)

(3)

(7)

(5)

(6)

(9)

(10)

(8)

CAUTION
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(2) Scanner
Confirms the scanner status and sets the scanner.

• Scanner
Selects the layout number for welding.

• Thumbnail 
Displays the thumbnail for the selected layout number.

• Layout Filename
Displays the filename for the selected layout number.

• [Batch Transfer] button
This button is used to transfer layout files to the laser control unit and per-
form file maintenance such as deleting and copying of the layout file on the 
laser control unit. Click this button to display the [Batch Transfer] screen. 
(For details, refer to "Chapter 6-4. Dara Transfer (Transferring, Deleting, and 
Copying Layout File)" (page 91) .)

(3) Transferred Layouts [Controller(Memory Card)]
Displays the layout information transferred to the memory card on the controller.

• [Upload] button
Click this button to upload the selected layout to the PC software.

• [Schedule] button
Click this button to call the [SCHEDULE INPUT] screen. (For details, refer to 
"Chapter 6-3. Schedule" (page 74) .)

(4) Status Laser Control
Displays the system status as detected through the network.

• [Local]/[Remote] button
When the [Local] button is clicked in the remote control, the laser control unit 
becomes controlled locally.
When the [Remote] button is clicked in the local control, the laser control unit 
becomes controlled remotely.

(5) Start

Performs scanning. Click the [Start Scan] button to output the laser or the [Test 
Scan] button not to output the laser.

The [Start Scan] button is enabled only when the LD is on. The [Test Scan] but-
ton is enabled even when the LD is off.

To check the scan locus with the guide beam, execute the [Test Scan] button with 
the LD turned off for safety.

Status indications

Item Indication Meaning

Control 
Device

Panel The laser equipment is controlled independently.

External The laser equipment is controlled by the laser control unit.

Control 
Mode

Local The laser control unit is controlled locally.

Remote The laser control unit is controlled remotely.
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The above contents are enabled with the controller version V00-02F or later. With 
the earlier version, scanning fails even when test scanning is performed unless 
the LD is turned on.

• [Test Scan] button
Click this button to display the [Test Scanning Ready] screen.

Click the [Start] button to start test welding. Laser is not output. Once test 
welding starts, the button cannot be used until welding ends. Welding stops 
automatically when there are no more figures to scan. However, when the guide 
beam is turned on, the scanning operation is repeated until the [STOP] button is 
clicked.

The [Test Scan] button is enabled even if the LD is off, but disabled when the con-
troller is in an error state.

The following sequence is recommended to output the interlock signal to the laser 
device.

To perform test scanning remotely, use TSR/TSW of the RS-232C commands. For 
details, refer to the operation manual for the laser control unit CL-E100A.

• [Start Scan] button
Click this button with the guide beam turned off to display the [Laser 
Scanning Ready] screen.

External signals and the schedule-switching signal of the laser equipment are 
output whether laser is output or not.
In the operation status, “A.P.A. manual mode” is displayed when the A.P.A. man-
ual is performed and “Normal mode” is displayed at normal times. In the scan sta-
tus, “A.P.A. offset scan” is displayed when the A.P.A. result is valid and “Normal 
scan” is displayed at normal times.

CAUTION

Interlock signal (out)

Laser device

Interlock signal (in)

User device

Device 
interlock

Emer-
gency 
stop

LD
(in)
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Click the [Start] button to start welding. Once welding starts, the button cannot 
be used until welding ends. Welding stops automatically when there are no more 
figures to scan.

• [Origin Position] button
Click this button to return the scanner to the origin.

When 5 seconds has passed while the mouse cursor is placed over the [Start] 
button on the [Laser Scanning Ready] screen or immediately after completion 
of laser scanning, the screen is locked for safety and the following screen 
appears. Click the [OK] button to return to the [Laser Scanning Ready] 
screen.

When the [Start Scan] button is clicked with the <Enter> key or the <Space> 
key on your keyboard pressed, the following screen appears. To start welding 
from a keyboard, press the <Enter> key or the <Space> key with pressing the 
<Shift> key and click the [Start Scan] button.

�

�
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(6) Status Display Palette

Displays the system status as detected through the network in the left. The laser 
equipment can be controlled using the buttons in the right.

• [LD ON]/[LD OFF] button
Click the [LD ON] button to turn on the laser equipment. A message is 
displayed while the system is starting up.
Click the [LD OFF] button to stop the laser equipment. A message is 
displayed while the system is stopped.

• [Guide ON]/[Guide OFF] button
Click the [Guide ON] button to turn on the guide beam. The guide beam will 
be emitted when scanning. The laser beam is not emitted with a state where 
the [Guide ON] button is clicked.
Click the [Guide OFF] button to turn off the guide beam. The guide beam will 
not be emitted when scanning.

• [Main Shutter] button
Click the [Main Shutter] button to open the safety shutter built in the laser 
equipment.
Click the [Main Shutter] button to close the safety shutter built in the laser 
equipment.

• [Shutter 1 to 3] button
Click the [Shutter 1 to 3] button to open the branch shutter built in the laser 
equipment.
Click the [Shutter 1 to 3] button to close the branch shutter built in the laser 
equipment.

(7) Power Monitor

Displays the average of the power monitor value from the scan start to the scan 
end of a single layout.

(8) [LOG] Button

Click this button to display the power monitor screen. (For details, refer to 
"Chapter 6-2. Power Monitor" (page 67) .)

Do not shut off the power while a message is displayed. Otherwise, the life of the 
laser equipment may be significantly reduced.

Depending on a workpiece or the lens configuration, the position of the guide 
beam may be difficult to see. In such a case, move the guide beam to the origin 
once and check the position with a white paper.

• The power monitor value is calculated based on the power monitor signal from 
the laser equipment.

• Depending on quality of the power monitor signal output from the laser equip-
ment, the value may be different from that of a measuring instrument such as 
power meter.

• Due to the difference in the method of calculating the power monitor from the 
laser equipment, the value may be different.

• To measure more accurate output, we recommend to install a power meter or 
use our MM-L300A together.

CAUTION

�

CAUTION
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(9) Error
• [Hard Error] lamp

Lights if an error occurs in the laser control unit or laser equipment.
• [Error Reset] button

Click this button to reset errors. You cannot resume welding unless you clear 
the error status using this button.

• [RAS] button
Clicking this button displays the [RAS Status] screen to check the error 
details.

Click the [Save] button on the [RAS Status] screen to save the error details as 
CSV data. Click the [OK] button to close.

(10) Hardware Information

Displays the information of the connected equipment.

(11) [Close] Button
Click this button to close the [Control] screen.

Limitations on filenames when saving data
• Enter up to 255 single-byte characters (including drive name and path 

information) for the filename.
• Symbols (\/:*?"<>|), one-byte space, CON, AUX, COM1 to COM9, LPT1 to 

LPT9, PRN, and NUL may not be used in filenames.
CAUTION
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2. Power Monitor

Click the [LOG] button to display the power monitor screen. Two major functions are
as follows.

• Graphically displaying the power monitor value after being displayed on a screen
• Turing OFF the LD of the laser equipment when the power monitor value exceeds 

an arbitrarily value set by a customer

The displayed power monitor value is displayed based on the laser equipment’s power
monitor signal from the scan start to the scan end of a layout. Therefore, it may be dif-
ferent from the power monitor value of the laser equipment or the measured value of
the power meter.

Please consider use in combination with a power meter to measure more accurate out-
put or our MM-L300A to acquire the state of the processing end or envelope.

The following three types of graphs can be displayed.

• Average power: average output of an overall layout
• CW Peak power: output peak value of waveform set in CW or CW2 included in a 

layout
• Pulse Peak power: output peak value of waveform set in FIX or FLEX included in a 

layout

The error output detection function using the power monitor value is also enabled or
disabled on this screen.

This function cannot be used when the laser equipment does not have the power 
monitor signal.

Layout

Laser equipment’s 
power monitor signal

Measuring range of 
power monitor

Scan start Scan end

CAUTION
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(1) Engine Info

Information on the engine.

(2) Monitor value type

Type of the power monitor value used for a graph. There are the following two 
types.

(3) Latest power

The latest measured value.

Item Function

Max output Possible maximum output

CW Max output Maximum value which can be output as CW waveform

Model Model name of the selected engine.

Item Function

Average power Average output of an overall layout

Peak hold Peak output of a layout

(9)

(7)
(8)

(13)(12)(11)(10)

(6)

(1) (3)(2) (4) (5)
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(4) Alarm level

The state of the error output detection function using the power monitor value.

(5) Measure Data Info

Minimum / maximum / average data plotted after a graphically display starts or 
the [Clear] button is clicked.

(6) Always on Top

When this is enabled, this screen is always displayed on top of other windows.

(7) Total count

The number of scans performed after this screen is displayed. This is reset by 
clicking the [Clear] button or closing this screen.

(8) View window
• CW Monitor

When this is enabled, a graph for the CW Peak power is displayed. The peak 
power of the CW waveform (CW, CW2) in the layout is displayed. To close the 
graph screen, disable this.

Item Function

Alarm detection Displays ON or OFF of the error output detection function.

High Upper limit to judge as abnormal

Low Lower limit to judge as abnormal
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• Pulse Monitor
When this is enabled, a graph for the Pulse Peak power is displayed. The peak 
power of the pulse waveform (FIX, FLEX) in the layout is displayed. To close 
the graph screen, disable this.

(9) Graph Area

The graph screen of the power monitor. The power monitor value is plotted in 
light blue on the graph. When pointing a mouse cursor to the plotted power mon-
itor value, the detailed information of the power monitor value is displayed.

• Y axis upper
Sets the maximum value of the vertical axis of a graph. The setting range is 0 
to twice of the maximum output.

• Y axis lower
Sets the minimum value of the vertical axis of a graph. The setting range is 0 
to twice of the maximum output.

When the error detection function is enabled, the alarm border (red) and the 
warning border (yellow) are displayed in the graph. When the value exceeds the 
warning border, the plot is displayed in yellow. When the power monitor value 
exceeds the alarm border, the plot is displayed in red.

(10) [Clear] Button

Deletes the data displayed in the graph.
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(11) X axis scale

Sets the maximum number of points displayed on the horizontal axis (up to 
1000).

(12) [Setting] Button

Click this button to display the [Setting] screen to enable or disable the error 
detection function using the power monitor value.

When the error detection function is enabled, following values can be set.

Item Function Range

Upper alarm limit Arbitrarily value set by a 
customer for alarm border to 
judge it as abnormal. When 
this value is exceeded, it is 
judged as abnormal.

Average, Pulse Peak:
Upper warning limit <= Input value 
<= Twice of Max output
CW Peak:
Upper warning limit <= Input 
value<= Twice of CW Max power

Upper warning limit Arbitrarily value set by a 
customer for warning border 
to judge it as a warning state. 
When this value is exceeded, 
the plot is displayed in yel-
low.

Lower warning limit < Input value 
<= Upper alarm limit

Lower warning limit Lower arlarm limit <= Input value 
< Upper warning limit

Lower alarm limit Arbitrarily value set by a 
customer for alarm border to 
judge it as abnormal. When 
this value is exceeded, it is 
judged as abnormal.

0 <= Input value <= Lower warning 
limit

[Save] button Transfers the set value to the 
controller.

－

[Cancel] button Returns to the previous 
screen.

－
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When each alarm limit is exceeded, the controller turns off the LD and records the
error contents of the power monitor value error and the laser equipment error. The
details of error can be checked by clicking the [RAS] button. Perform an error reset-
ting for recovery.

(13) [View log] Button

Click this button to display the history of the power monitor values saved in the 
controller.

• Update data
The time when the power monitor log information is aquired from the control-
ler.

• The number of data
The amount of data recorded in the currently selected log file.

• File info
The list of the power monitor log files saved in the controller. Files are saved 
as shown below. The maximum number of log files is 10.

Values set in Upper warning limit and Lower warning limit are for a graph display. 
This is different from Pin 43 “Warning” on the User I/O (output signal) of the con-
troller.

When displaying or operating this screen during welding, the timing of the welding 
start may change.

CAUTION

CAUTION
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pmudata0.log (the latest data)
　 　 　 　 　 　 :
pmudata9.log (the oldest data)

• [Update] button
For updating the history information of the power monitor. The latest 
log data is acquired.

• [Save] button

For saving the power monitor log. The log file selected in File info is 
saved. Click this button, select a location to save files, and click the 
[Save] button.

• Power monitor history
The contents of the log file selected in File info. Up to 10000 pieces of data are 
saved in the log file.
Up to 50 pieces are displayed at once in the history field. To display other 
data, change the page number with the [<<]/[>>] buttons.

Power monitor history indications

Indication Meaning

Index The higher the number, the more recent data.

Date Date and time when the log is recorded. This time information is 
converted from the local time of the computer which is SWDraw3 is 
installed based on the time set in the controller.

Layout Layout number which is used.

Average Average of the average output of the overall layout.

Unit Unit of Average.

CW Peak Peak output of the CW or CW2 waveform in the layout. "-------" is 
displayed when the CW or CW2 waveform is not set in the layout.

Unit Unit of CW Peak

Pulse Peak Peak output of the FIX or FLEX waveform in the layout. "-------" is 
displayed when the FIX or FLEX waveform is not set in the layout.

Unit Unit of Pulse Peak.

Processing time Weld time.

Unit Unit of the weld time.

Cancel 1 is recorded when welding has not been is completely processed by 
being canceled by user, etc.
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3. Schedule

Before starting welding, the waveform creation method, the laser emission time, and
laser output parameters must first be set.
The laser output parameters for this system are referred to as a schedule. The
schedule is displayed on the [SCHEDULE INPUT] screen.

For the setting ranges of schedules, refer to the operation manual for the laser
equipment.

3.1. [SCHEDULE INPUT] Screen Arrangement

(1) Menu

・ The [SCHEDULE INPUT] screen appears only when the laser equipment is 
online.

・ When changing the settings, the schedule settings on the laser equipment 
immediately change.

Item Setting Details

FILE Import Displays the dialog to select a JSON file to import. Reads the selected 
schedule data and transmits it as schedule data. After transmission, 
reaquires the schedule data to display it.

Export Displays the dialog to select a file to export. After entering the file-
name, schedule data in JSON format and waveform image (bitmap) 
are created. Values of acquired schedule data are output in JSON for-
mat.

(1)

(2)

(3)

CAUTION
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*1 Copy and Paste functions can be used only in SWDraw3. For data interaction with other 
applications, use Import and Export functions.

(2) Output conditions

(3) Graph display

In the FIX/FLEX/CW forms, the set waveform is displayed as a graph.

In a graph, the set waveform (input waveform) is displayed by a blue dash line, 
the actual output waveform is displayed by a yellow solid line, and the minimum 
output value (low) is displayed by a white dashed line.

In the FIX/FLEX/CW forms, when the set output falls below the minimum output 
value, the minimum output value is output. The minimum output value differs 
depending on MODEL.

EDIT Copy *1 Copies the schedule data of the specified number and form to the 
clipboard.

Paste *1 Acquires the schedule data stored in the clipboard and transmits it as 
schedule data. After transmission, reaquires the schedule data to dis-
play it.

Reset Resets the schedule data of all forms of the specified number. After 
reset, reaquires the schedule data to display it.

Item Setting Details

SCHEDULE Selects the schedule number (0 to 255) to display or edit.

MODEL The model name of the selected engine is displayed.

CW MAX POWER The possible maximum output value (output when set to 100%) 
in CW/CW2 is displayed.

PW MAX POWER The possible maximum output value (output when set to 100%) 
in FIX/FLEX is displayed.

FORM Specifies the welding method (FIX / FLEX / CW / CW2).

Item Setting Details

Actual output waveform

Min. output value (low)

Set waveform
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3.2. Setting Schedule using FIX Form

The FIX form is a welding method that generates the waveform using pulse laser
excitation and setting the three particular combinations of laser output time and peak
output. Gradients can be added for the waveform start-up and drop-off sections.
The schedule can be set as follows.
1 From the menu, select [Laser Control] -> [Schedule].

The [SCHEDULE INPUT] screen appears.

2 Set the desired schedule number in the [SCHEDULE] box, and then select "FIX" in 
the [FORM] box.

The FIX form screen appears.

3 Enter the laser output time and output values referring to the table below. The graph 
is automatically updated to show the values set here.

FIX Form Settings (1 / 2)

Item Setting Details Range

SET POWER Set the reference value for the laser output 
peak value. The actual laser output is set as a 
percentage of this value.

Depends on laser 
equipment.

RESOL Set the resolution (0.1 ms / 0.01 ms). The laser 
output time is displayed with the specified res-
olution.

－

REFERENCE VALUE Displays the reference value of the laser 
output energy for the displayed graph. －
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*1 The difference between single-shot and repeated output
The difference between single-shot and repeated output is described below.

Schedule setting is now complete.

In the FIX form, the laser beam is output as shown below.

When the set value falls below the minimum output value (low), the actual laser out-
put value becomes the minimum output value as indicated by a red line in the follow-
ing figure.

↑ SLOPE Set the time for the increase (laser output 
increases gradually) to the output value set in 
FLASH1. This increase is included in the 
FLASH1 time. Set so that ↑ SLOPE <= 
FLASH1. Set FLASH1 before setting ↑
SLOPE.

Depends on laser 
equipment.

FLASH1 to 3 Set the laser output time (TIME) and output 
values (POWER). POWER is set as percentage 
of SET POWER.

Depends on laser 
equipment.

COOL1 to 2 Set the time (TIME) for which the laser is not 
output.

Depends on laser 
equipment.

↓ SLOPE Set the time for the decrease (laser output 
decreases gradually) from the output value set 
in the last FLASH. The decrease is included in 
the last FLASH time. Set so that ↓SLOPE <= 
last FLASH.

Depends on laser 
equipment.

REPEAT*1 Set the number of laser output cycles per 
second.

Depends on laser 
equipment.

SHOT*1 Set the number of laser output cycles. Set 
SHOT to "1" for single output.

Depends on laser 
equipment.

PRE-OSCILLATION Outputs the laser with the set time (TIME) 
and output values (POWER) before the 
FLASH output. POWER is set as percentage of 
SET POWER.
The resolution of TIME in this setting does not 
change according to the RESOL setting. Also, 
the modulation setting does not work for this 
output.

Depends on laser 
equipment.

MODULATION When the checkbox is checked, the screen is 
displayed to make the modulation setting. －

SEAM When the checkbox is checked, the screen is 
displayed to make the seam setting. －

Single-shot 
output

The system stops after a single laser shot output.

Repeated output Laser output is repeated. The system stops once the number of cycles 
reaches the value set in SHOT. For details, refer to the operation manual 
for the laser equipment.

FIX Form Settings (2 / 2)

Item Setting Details Range
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00

Actual laser output
Set value

↑ SLOPE

                           FLASH1          COOL1     FLASH2     COOL2        FLASH3

↓ SLOPE TIME

1 count         2 count          3 count         4 count           5 count                           SHOT count

(1/REPEAT) s

TIME

Output repeated until the set SHOT count, set object end or scan end

Laser output (POWER)

100.00%

FLASH1

FLASH2

FLASH3

 Laser output equivalent to (PW MAX POWER × SET POWER / 100) [W]

Laser output

Min. output value (low)
PRE-

OSCILLATION

PRE-
OSCILLATION
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3.3. Setting Schedule using FLEX Form

The FLEX form is a welding method that generates the waveform using pulse laser
excitation and setting the peak output values for each laser output time. Up to 20
different output times can be set.
The schedule can be set as follows.
1 From the menu, select [Laser Control] -> [Schedule].

The [SCHEDULE INPUT] screen appears.

2 Set the desired schedule number in the [SCHEDULE] box, and then select "FLEX" in 
the [FORM] box.

The FLEX form screen appears.

3 Enter the laser output time and output values referring to the table below. The laser 
output time is set from the previous POINT. The graph is automatically updated to 
show the values set here.

FLEX Form Settings

Item Setting Details Setting Range

SET POWER Set the reference value for the laser output 
peak value. The actual laser output is set as a 
percentage of this value.

Depends on laser 
equipment.

RESOL Set the resolution (0.1 ms / 0.01 ms). The laser 
output time is displayed with the specified res-
olution.

－

REFERENCE VALUE Displays the reference value of the laser 
output energy for the displayed graph. －
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*1 The difference between single-shot and repeated output
The difference between single-shot and repeated output is described below.

Schedule setting is now complete.

In the FLEX form, the laser beam is output as shown below. (In the example below,
POWER and TIME settings of POINT06 and after are 0.)

When the set value falls below the minimum output value (low), the actual laser out-
put value becomes the minimum output value as indicated by a red line in the follow-
ing figure.

POINT01 to 20 Set the laser output time (TIME) and laser 
output peak values for each corresponding 
output time (POWER). POWER is set as 
percentage of SET POWER.

• TIME:
Depends on laser 
equipment.

• POWER:
Depends on laser 
equipment.

REPEAT*1 Set the number of laser output cycles per 
second.

Depends on laser 
equipment.

SHOT*1 Set the number of laser output cycles. Set 
SHOT to "1" for single output.

Depends on laser 
equipment.

PRE-OSCILLATION Outputs the laser with the set time (TIME) 
and output values (POWER) before the POINT 
output. POWER is set as percentage of SET 
POWER.
The resolution of TIME in this setting does not 
change according to the RESOL setting. Also, 
the modulation setting does not work for this 
output.

Depends on laser 
equipment.

MODULATION When the checkbox is checked, the screen is 
displayed to make the modulation setting. －

SEAM When the checkbox is checked, the screen is 
displayed to make the seam setting. －

Single-shot 
output

The system stops after a single laser shot output.

Repeated output Laser output is repeated. The system stops once the number of cycles 
reaches the value set in SHOT. For details, refer to the operation manual 
for the laser equipment.

FLEX Form Settings

Item Setting Details Setting Range
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Actual laser output
Set value

                     POINT01         POINT02          POINT04         POINT05

POINT03

TIME

1 count         2 count          3 count         4 count           5 count                           SHOT count

(1/REPEAT) s

TIME

Output repeated until the set SHOT count, set object end or scan end

Laser output (POWER)

100.00%

POINT01

POINT02

POINT03,04
POINT05

 Laser output equivalent to (PW MAX POWER × SET POWER / 100) [W]

Laser output

Min. output value (low)
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OSCILLATION

PRE-
OSCILLATION
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3.4. Setting Schedule using CW Form

The CW form is a welding method that generates the waveform using continuous laser
excitation and setting the peak output values for each laser output time. Up to 20
different output times can be set. Unlike the FIX and FLEX forms, SEAM settings and
repeated/single output cannot be set, reducing output time, but a clean weld is
achieved since welding is performed continuously.
The schedule can be set as follows.
1 From the menu, select [Laser Control] -> [Schedule].

The [SCHEDULE INPUT] screen appears.

2 Set the desired schedule number in the [SCHEDULE] box, and then select "CW" in 
the [FORM] box.

The CW form screen appears.

3 Enter the laser output time and output values referring to the table below. The graph 
is automatically updated to show the values set here.

CW Form Settings

Item Setting Details Setting Range

SET POWER Set the reference value for the laser output 
peak value. The actual laser output is set as a 
percentage of this value.

Depends on laser 
equipment.

RESOL Set the resolution (1 s / 0.1 s / 0.01 s / 0.001 s). 
The laser output time is displayed with the 
specified resolution.

－
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Schedule setting is now complete.

In the CW form, the laser beam is output as shown below. (In the example below,
POWER and TIME settings of POINT06 and after are 0.)

When the set value falls below the minimum output value (low), the actual laser out-
put value becomes the minimum output value as indicated by a red line in the follow-
ing figure.

POINT01 to 20 Set the laser output time (TIME) and laser 
output peak values for each output time 
(POWER). POWER is set as percentage of SET 
POWER.

• TIME:
Depends on laser 
equipment.

• POWER:
Depends on laser 
equipment.

PRE-OSCILLATION Outputs the laser with the set time (TIME) 
and output values (POWER) before the POINT 
output. POWER is set as percentage of SET 
POWER.
The resolution of TIME in this setting does not 
change according to the RESOL setting. Also, 
the modulation setting does not work for this 
output.

Depends on laser 
equipment.

MODULATION When the checkbox is checked, the screen is 
displayed to make the modulation setting. －

CW Form Settings

Item Setting Details Setting Range

00

Actual laser output
Set value

                     POINT01         POINT02          POINT04         POINT05

POINT03

TIME

Laser output (POWER)

100.00%

POINT01

POINT02

POINT03,04
POINT05

Laser output equivalent to (PW MAX POWER × SET POWER / 100) [W]

Min. output value (low)

PRE-
OSCILLATION

PRE-
OSCILLATION
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3.5. Setting Schedule using CW2 Form

In the CW2 form, upslope and downslope of laser output can be set according to the
line length of layout.
The schedule can be set as follows.
1 From the menu, select [Laser Control] -> [Schedule].

The [SCHEDULE INPUT] screen appears.

2 Set the desired schedule number in the [SCHEDULE] box, and then select "CW2" in 
the [FORM] box.

The CW2 form screen appears.

3 Enter the laser output time and output values referring to the table below.

CW2 Form Settings

Item Setting Details Setting Range

SET POWER Sets the power (in %) of a single object of the 
layout at the normal scan. This is set as 
percentage of the CW maximum output.

Depends on laser 
equipment.

START POWER Sets the power (in %) of a single object of the 
layout at the scan start. This is set as 
percentage of the CW maximum output.

Depends on laser 
equipment.

END POWER Sets the power (in %) of a single object of the 
layout at the scan end. This is set as 
percentage of the CW maximum output.

Depends on laser 
equipment.

UP SLOPE DST Sets the distance (in mm) applying upslope for 
the normal (line) layout.

Depends on laser 
equipment.

DOWN SLOPE DST Sets the distance (in mm) applying downslope 
for the normal (line) layout.

Depends on laser 
equipment.

MODULATION When the checkbox is checked, the screen is 
displayed to make the modulation setting. －
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Schedule setting is now complete.

In the CW2 form, the laser beam is output as shown below.

Upslope and downslope are output according to the length of the object in the layout.
Even if the schedule settings are the same, output times of upslope, downslope and set
power differs depending on the length of the object.

・ When the total length of upslope and downslope exceeds that of the object 
during scanning, an error occurs and scanning stops.

・ When the CW2 schedule is set for a spot object, the output of SET POWER 
becomes steady.

CAUTION

00 TIME

Laser output [%]

100.00

SET POWER

START POWER

END POWER

Layout

DOWN SLOPE DST

Scan direction

UP SLOPE DST

Upslope Downslope
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3.6. Setting Modulation Form in Schedule

The modulation form is a welding method that modulates the pulse width by setting a
constant modulation width and frequency and realizes various processes.
Set the modulation degree and modulation cycle among the ON/OFF, the rectangular
wave (RECT), the triangular wave (TRI), and the sinusoidal wave (SINE) to generate
a waveform.

In the FIX/FLEX/CW forms, RECT, TRI or SINE can be set. ON/OFF cannot be set. In
the CW2 form, options other than ON/OFF cannot be set.

• ON/OFF

• Rectangular wave (RECT)

• Triangular wave (TRI)

• Sinusoidal wave (SINE)
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The modulation form can be set as follows.
1 Check the checkbox for the [MODULATION].

2 Enter the modulation width and the frequency referring to the table below.

Modulation form setting is now complete.

When modulation is enabled, the laser beam is output as shown below.

Modulation Form Settings

Item Setting Details Setting Range

WAVE Set the type of modulation waveform from ON/
OFF, rectangular wave (RECT), triangular 
wave (TRI), or sinusoidal wave (SINE).

－

DUTY Set the duty ratio. Depends on laser 
equipment.

MODULATION Set the modulation width. Depends on laser 
equipment.

FREQUENCY Set the frequency. Depends on laser 
equipment.
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3.7. Setting Seam Function in Schedule

The fade function increases or decreases the laser energy in a gently-sloping form to
obtain a continuous waveform suitable for seam welding. As a result, the finished
status of seam welding is made beautiful.
The seam function can be set as follows.
1 When "FIX" or "FLEX" is selected in the [FORM] box, check the checkbox for the 

[SEAM].

2 Enter the laser output count and a percentage for [SET POWER] referring to the table 
below.

*1 SHOT for POINT01 is fixed to 1. The value larger than the previous POINT can be input, for 
example POINT02 < POINT03.

Seam function setting is now complete.

When the seam function is enabled, the laser beam is output as shown below.

Seam Function Settings

Item Setting Details Setting Range

POINT01 to 20 Set the laser output count (SHOT) and a 
percentage of laser output (POWER).

• SHOT:
2 to 9999 counts*1

• POWER:
0 to 150%



3. Schedule

90

SWDraw3

00

1 count          2 count          3 count
POINT02
SHOT count

(1/REPEAT) s

TIME

Laser output at 100% of each FLASH (POINT for FLEX)

Laser output (x PW MAX POWER x SET POWER / 100 [W])

POINT02+
POINT03
SHOT countPOINT02

POINT01
POINT03



 4. Dara Transfer (Transferring, Deleting, and Copying Layout File)

91

SWDraw3

C
hapter 6

　
Laser C

ontrol

4. Dara Transfer
(Transferring, Deleting, and Copying Layout File)

This step transfers the created layout file to the laser control unit. The laser control
unit manages layout files by file numbers. You must assign a number to the file.
The layout file can be transferred to the laser control unit as follows.

Open the [Batch Transfer] screen with any of the following methods.

• Click the [Batch Transfer] button on the toolbar.
• From the menu, select [Laser Control] -> [Batch Transfer].
• From the right-click menu, select [Laser Control] -> [Batch Transfer].
• Click the [Batch Transfer] button on the [Control] screen.
The [Batch Transfer] screen is displayed.

The procedure to transfer the layout file and each operation is as follows.

[Batch Transfer] Screen Function List

Button Function

Select All Selects all files.

Delete Deletes the selected files. Multiple files can be selected.

Copy Copies the selected layout figure to a file. (Save As)

Upload Transfers the file.

Used Schedule Displays the used schedule number.

View Switches the file display between thumbnail display and filename 
list display.

Close Closes the [Batch Transfer] screen.

Click the [Switch View] button to view a list of filenames instead of thumbnails. 
The setting remains even after restarting SWDraw3.�
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4.1. Layout File Transfer

This step transfers the created layout file to the laser control unit. The laser control
unit manages layout files by file numbers. You must assign a number to the file.
1 Select a layout file from the [Layouts Available For Transfer] on the left, and a layout 

number to be assigned to a layout file from the [Transferred Layouts] on the right. To 
select them, there are two ways:
• Click and double-click

Single-click the desired layout file in [Layouts Available For Transfer] on the 
left, and then double-click the desired number in [Transferred Layouts] on the 
right.

• Drag and drop
Select a file from [Layouts Available For Transfer] on the left (shown with a 
red frame in thumbnail display) and drag it. After successful file dragging, the 
mouse cursor changes. (The layout file is displayed around the mouse cursor.) 
Then, a red frame is displayed when the mouse is placed over the desired 
number in [Transferred Layouts] on the right. Drag it there.

2 Repeat step 2 to assign layout numbers to all files to be transferred.
Files to be transferred are identified by a check mark next to the filename in the list on the right.

Uncheck the file names if you decide not to transfer particular files. For clearing, refer to "Chapter 6-
4.2. Clearing Transfer of Layout File and Changing the Transfer Reservation Number" (page 94) .

3 Click the [Upload] button.

When the layout number does not change, a confirmation message is displayed after successful file 
transfer. When the layout number changes, the message which shows layout numbers of [Before 
transfer] and [After transfer] for the layout number (active layout), and the layout number which is 
ready for laser scanning via the [Control] screen or the external I/O is newly set for [Scanner] on the 
[Control] screen as a layout number of [After transfer]. Click the [OK] button to close the dialog.

To transfer the transferred file again, double-click the desired number in 
[Transferred Layouts] on the right with selecting nothing in [Layouts Available For 
Transfer] on the left. When transfer is reserved, a check mark is placed. The file 
to be transferred again should be displayed on [Layouts Available For Transfer]. If 
not, you cannot transfer it again. (A check mark is not placed.)

The transferred file cannot be transferred to the other number. For example, 
when “A.LMB” has been transferred to No. 1, “A.LMB” cannot be transferred to 
the number other than No. 1.

�

CAUTION

[OK] button
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4 Click the [Close] button to close the [Batch Transfer] screen.

5 A message that asks whether or not to perform laser scanning is displayed.
When the [Yes] button is clicked, the [Control] button is displayed. (For details, refer 
to "Chapter 6-1. Control" (page 61) .)
You will return to the Drawing screen by clicking the [No] button.

All selected layout files have now been transferred to the laser control unit.

The transferred layout file is saved in the ZIP folder in the memory card of the laser
equipment as a compressed file (ZIP format). The layout data with extensions INF,
LID, LMB, and LOS are compressed. Also, the current SWDraw3 version is copied in
the version information of INF file. The filename of compressed file is the same as that
of transferred layout file.

If the ZIP folder does not exist, it is automatically created.

When a layout file transferred to the laser control unit is deleted, the ZIP file is also
deleted. However, the created ZIP folder is not deleted even if all transferred layout
files are deleted.

When two or more layout files are transferred, the layout file with the biggest 
number is set as the layout number (active layout).

When [Control Mode] is [Remote], the layout number (active layout) is not 
switched since the control by the external I/O has priority.
When the layout number of the transferred layout file and the current layout num-
ber set for the laser control unit are different, a message that the layout number 
does not change is displayed.

CAUTION

CAUTION
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4.2. Clearing Transfer of Layout File and Changing the Transfer Res-
ervation Number

4.2.1. Clearing Selection of [Layouts Available For Transfer]

The selected layout file in [Layouts Available For Transfer] on the left can be cleared
as follows.

Thumbnail display:

• Click the selected file again.
• Click a blank thumbnail.

List display:

• Click the selected file again.

4.2.2. Clearing Transfer Reservation of [Transferred Layouts]

To clear transfer reservation of “reserved” layout file which has a check mark in
[Transferred Layouts] on the right, double-click the desired file. At this time, opera-
tion differs according to whether the file selected in [Layouts Available For Transfer]
on the left is the same or different.

When nothing is selected in [Layouts Available For Transfer] on the left or the file
[Layouts Available For Transfer] on the left and the filename selected in [Transferred
Layouts] on the right is the same, transfer reservation is cleared by double-clicking
the desired layout file in [Transferred Layouts] and a check mark is taken off.

But, the files selected in [Layouts Available For Transfer] on the left and [Transferred
Layouts] on the right are different and the file selected in [Layouts Available For
Transfer] on the left has not been transferred, transferring the file selected in
[Layouts Available For Transfer] on the left is reserved by double-clicking. (A new lay-
out file transfer is reserved.)

For example, when “A.LMB” is selected in [Layouts Available For Transfer] on the left
and “B.LMB” is selected in [Transferred Layouts] on the right, “A.LMB” transfer is
reserved by double-clicking “B.LMB.” Since the files in [Layouts Available For
Transfer] on the left and [Transferred Layouts] on the right are the same, transfer res-
ervation is cleared by double-clicking “A.LMB” again with this state.

Also, transfer reservation can be cleared with dragging and dropping. Drag the
reserved layout file and drop it outside the frame of [Transferred Layouts] on the
right. A confirmation message appears. Click the [Yes] button to clear transfer reser-
vation or click the [No] button to cancel.
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4.2.3. Changing Transfer Reservation Number of [Transferred Layouts]

The transfer reservation number can be changed with dragging and dropping.

When the layout file is displayed in [Layouts Available For Transfer] on the left and
reserved (checked) but not yet transferred to the laser control unit, its transfer reser-
vation number can be changed with dragging and dropping it to the other number.

For example, “A.LMB” transfer is reserved at No. 10. To change it to No. 15, drag
“A.LMB” at No. 10 and drop it at No. 15. It can also be dropped to the transferred lay-
out file. (It is overwritten.)

However, the transfer number of the layout file already transferred to the laser
control unit cannot be changed in this way. You need to transfer the file to a new num-
ber again after deleting it.

Reservation cannot be cleared depending on sequence of transfer reservation. 
Transfer reservation cannot be cleared under the condition that a layout file with 
the same name is transferred to two numbers.

Example) “A.LMB” and “B.LMB” are displayed in [Layouts Available For Transfer], 
and “A.LMB” has been reserved at No. 1.

1. Reserve “B.LMB” transfer at No. 1. (“A.LMB” overwrites “B.LMB.”)
2. Reserve “A.LMB” transfer at No. 2.
3. Clear transfer reservation of No. 1.

After the above procedures, the following message appears and transfer reserva-
tion in step 3 cannot be cleared. This is because “A.LMB” is restored at No. 1 by 
clearing transfer reservation of No. 1 and the contradiction of transferring “A.LMB” 
to both No. 1 and No. 2 is generated.

In this case, you can also clear No. 1 by clearing “A.LMB” at No. 2 in first.

CAUTION
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4.3. Layout File Delete

This step deletes the layout file.

4.3.1. Layouts Available For Transfer

1 Select a layout file to be deleted from the [Layouts Available For Transfer] and click 
the [Delete] button.

The layout file saved on the computer is deleted.

In thumbnail display, only a file can be selected at a time. The selected layout file is displayed with a 
red frame.

In list display, click the file to be deleted. Two or more files can be selected by clicking them with 
pressing the <Ctrl> or <Shift> key. The selected layout file is displayed in blue background.

4.3.2. Transferred Layouts

1 Select the layout file to be deleted from the [Transferred Layouts] and click the 
[Delete] button.

The layout file which has been transferred to the laser control unit is deleted. The layout file saved in 
CF (compact flash) in a compressed way is also deleted.

Click the file to be deleted. Two or more files can be selected by clicking them with pressing the <Ctrl> 
or <Shift> key. The selected layout file is displayed in blue background.

The layout file reserved in [Transferred Layouts] cannot be deleted. Two or more 
layout files can be deleted when all of them are not reserved.

If a reserved file exists, the file cannot be deleted. (The [Delete] button is dis-
abled.) To delete it, you need to clear all transfer reservations.

CAUTION

CAUTION
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4.4. Layout File Copy

This step copies the layout file.
1 Select the layout file to be copied from the [Layouts Available For Transfer] and click 

the [Copy] button.

The [Copy file] screen is displayed.

2 Specify where to save it and filename and click the [Save] button.

The layout file saved on the computer is copied.

・ If the location where the file is saved is changed, if becomes unreadable from 
SWDraw3. Do not change it unless you need to. Also, do not change the file 
extension. If an extension other than INF, LID, LMB, and LOS is set, you will fail 
to copy it.

・ Files with same name cannot be copied. For example, “A.LMB” cannot be cop-
ied as “A.LMB.”

・ If two or more files are selected in list display, the files cannot be copied.

CAUTION
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5. Scanner Adjust

Select [Laser Control] -> [Adjust] on the menu to set the scanner operating conditions.
First, the [Enter Password] screen is displayed.

No password is set by default, and so clicking the [OK] button opens the [Scanner
adjust] screen.
The following items can be set on the [Scanner adjust] screen.

Scanner Adjust Settings

Item Setting Details Setting Range
Scanner 1 to 3
*1

Control Sets whether or not to use the 
corresponding number scanner. Check 
the checkbox for the scanner number to 
be used to set the scanner operating 
parameters.

－

Lens Sets the lens type. －

Gain X Sets the scaling factor for the X-
coordinate output values.

0 to 10000000

Gain Y Sets the scaling factor for the Y-
coordinate output values.

0 to 10000000

Test Gain X Sets the scaling factor for the X-
coordinate output values in a test start.

0 to 10000000

Test Gain Y Sets the scaling factor for the Y-
coordinate output values in a test start.

0 to 10000000

Guide Gain 
X

Sets the scaling factor for the X-
coordinate output values when the 
guide beam function is on.

0 to 10000000
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*1 The setting is effective for the connected scanner (controller) only.
*2 Input the value in view of the value set in the [System Parameters] screen.

Note: To set (or change) the password, click the [Change] button on the [Enter
Password] screen, and set the new password on the [Change Password] screen.

Scanner 1 to 3
*1
(continued)

Guide Gain 
Y

Sets the scaling factor for the Y-
coordinate output values when the 
guide beam function is on.

0 to 10000000

Distortion X Sets the X-coordinate lens distortion 
correction coefficient.

-32767 to 32767

Distortion Y Sets the Y-coordinate lens distortion 
correction coefficient.

-32767 to 32767

Axis Sets the scanner X/Y-axis intersection 
angle correction value.

-45° to 45°

Offset X*2 Sets the distance moved in the X-axis. -280.00 to 280.00

Offset Y*2 Sets the distance moved in the Y-axis. -280.00 to 280.00

Scanner Adjust Settings

Item Setting Details Setting Range
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6. Camera Monitor

When the camera monitor is used, the [Capture] screen for operating the camera live
images and scanner is called. The Gridwork can be performed from the [Capture]
screen. For details, refer to “Chapter 7. Gridwork and Auto Position Alignment.”

This function can be used only when CL-E100A is connected to a computer and 
the Camera Unit (option) is connected.

CAUTION
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7. System Parameters
(Setting Laser Equipment Operating Conditions)

Follow these steps to specify basic laser equipment operating conditions.
1 From the menu, select [Laser Control] -> [System Parameters].

The [System Parameters] screen is displayed. In online mode, the current laser equipment 
parameters will appear.

2 To load system parameters saved in the computer, click the [Import] button.
System parameters saved on the computer are loaded.

3 Specify basic laser equipment operating conditions, referring to the following table.

System Parameters Settings (1 / 3)

Item Setting Details Range
(Default) Pitch

Sp
ee

d

Jump Speed Specifies the transfer speed after welding one line 
until reaching the starting point of the next. Lens dependant 1 mm/s

Standby After Jump Specifies the time for the welding to restart after 
one line is drawn and the laser is repositioned at 
the starting point for the next line.

0.0 to 1000.0 ms
(10 ms) 0.1 ms
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Le
ns

 O
ffs

et
 *2

Angle of Rotation Rotates the layout file by the specified amount 
before welding.

0 to 360°
(0°) 0.000001°

X Offset*1 Moves the X axis of the layout file by the specified 
amount before welding.

Lens dependant
(0 mm) 0.001 mm

Y Offset*1 Moves the Y axis of the layout file by the specified 
amount before welding.

Lens dependant
(0 mm) 0.001 mm

Return 
to Origin

Yes Returns the scanner to the origin after each 
welding session. － －

No The scanner remains in place after welding, 
without returning to the origin. (Default setting) － －

Sh
ut

te
r

Shutter Open Delay
*3*4

Adjusts the timing for laser emission. -100.00 to 
100.00 ms

(0 ms)
0.01 ms

Shutter Close Delay
*3*4

Adjusts the timing when laser emission stops. -100.00 to 
100.00 ms

(0 ms)
0.01 ms

Safety 
Shutter 
Ctrl*5

Always 
Open

The shutter is always open when LD is ON.
－ －

Scanning 
Interlock

Open during welding, closed otherwise.
－ －

Tr
an

sf
er

 U
ni

t C
on

tr
ol Strobe Output Delay 

Time
Specify the timing for strobe signal output to the 
transfer unit. 0 to 999 ms

(999 ms) 1 ms

ACK Response Wait 
Time

Specify the wait time for the timer regarding 
transfer unit error monitoring. When 0 is set, no 
timeout is set.

0 to 99.9 s
(10.0 s) 0.1 s

W
ob

bl
in

g*6

Mode None The wobbling does not function. － －

Spiral Performs scanning spirally. － －

Sine curve Performs scanning sinusoidally. － －

Eight Performs scanning in the shape of a figure eight. － －

Triangle 
curve

Performs scanning triangularly.
－ －

Wobbling Width Specify the width (line width) of the wobbling. 
When Eight is selected for Mode, specify the width 
of the upper circle of a figure eight.

0.01 to 5 mm
(1.000 mm) 0.001 mm

Wobbling Freq. Specify the frequency for the wobbling operation. 1 to 1000 Hz
(100 Hz) 1 Hz

Wobbling Width 2 When Eight is selected for Mode, specify the width 
of the lower circle of a figure eight.

0.01 to 5 mm
(1.000 mm) 0.001 mm

Tilt Scans the start point when Spiral is selected for 
Mode or the figure eight when Eight is selected for 
Mode by inclining it by the set angle.

0 to 180°
(0°) 1°

Wobbling Direction When Spiral or Eight is selected for Mode, specify 
the wobbling direction.

CW or CCW
(Drawing data 

dependant)
－

System Parameters Settings (2 / 3)

Item Setting Details Range
(Default) Pitch
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*1 Input the value in view of the value set in the [Scanner adjust] screen.
*2 Lens Offset

Before welding, the absolute origin C is repositioned along the X-axis by the distance specified in [X Offset].
Before welding, the absolute origin C is repositioned along the Y-axis by the distance specified in [Y Offset].
The layout for welding is rotated counterclockwise around the absolute origin C by the angle specified in 
[Angle of Rotation].

Ca
m

er
a 

m
on

ito
r Camera No The camera is disabled.

－ －

Yes The camera is enabled. Set when using the 
Gridwork function. － －

La
se

r Model Displays the laser equipment connected to the 
controller. This can be operated by our service per-
son.

－ －

Te
st

 s
ca

n 
sp

ee
d Valid Select whether to perform test scan speed control.

－ －

Speed Specify the test scan speed (in mm/s).
Lens dependant

(500 mm/s) 1 mm/s

Ed
ge

 C
on

tr
ol Edge Control Select whether to perform edge control. No, yes －

Start Distance Adj Specify the adjustment distance (lead distance, in 
mm) before marking.

Lens dependant
(0.070 mm) 0.001 mm

End Distance Adj Specify the adjustment distance (lead distance, in 
mm) after marking.

Lens dependant
(0.070 mm) 0.001 mm

La
ng

ua
ge

Lan-
guage

OS 
Language

Sets the language for SWDraw to process to the 
OS language. － －

English Sets the language for SWDraw to process to 
English. － －

Sy
st

em
 D

at
e Current Date Inputs the system date. － －

Auto Automatically adjusts [Current Date] to date and 
time of the computer. － －

Set Changes the date into that set in [Current Date]. － －

System Parameters Settings (3 / 3)

Item Setting Details Range
(Default) Pitch

Start coordinate 
(on the layout screen)

Origin, as displayed on the screen 
(on the layout details screen)

Absolute origin 
(on the offset screen)



7. System Parameters  (Setting Laser Equipment Operating Conditions)

104

SWDraw3

*3 The shutter open delay and shutter close delay are parameters for setting the timing of laser output 
for scanner operation. When the interface unit is connected, set the following recommended values.
The timing of laser output needs to be changed depending on the actually used conditions (schedule 
waveform of laser equipment, etc.). Specify conditions according to welding status.

*4 [Shutter Open Delay] and [Shutter Close Delay] are invalid for SPOT layouts.
*5 Not used normally.
*6 Wobbling

Scanning is performed as shown below by setting [Wobbling Width] and [Wobbling Frequency].

Outputs the laser and then waits for a set time.
(No change in appearance. Takt simply extends 
by a set time.)

Shutter Open Delay (positive value) Shutter Close Delay (positive value)

Waits for a set time and then outputs the laser.
(A line changes in the direction of shrink.)

Waits for a set time and then stops the laser.
(A line changes in the direction of extension.)

Stops the laser and then waits for a set time.
(No change in appearance. Takt simply extends 
by a set time.)

Shutter Open Delay (negative value) Shutter Close Delay (negative value)

Laser emission

Jump

• Spiral mode

Wobbling Frequency

Wobbling Width

Wobbling Frequency

Wobbling Width

• Sine curve mode
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4 Click the [Save] button to save the settings.
The settings values for system parameters are saved on the computer.

5 You must now transfer the settings details to the system. Click the [Transfer] button.

* The [Transfer] button can be used only when the system is online.

6 Click the [Close] button when you have finished setting.

・ The wobbling may not work as being set depending on the combination of set 
values.

・ The wobbling does not function for the spot object.
・ In the sine curve mode, the laser is interrupted at the point where the angle of 

the trajectory changes.

If you have not saved the settings details described in step 4, the changes you 
have made will not be applied.

CAUTION

CAUTION
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8. RS232C Setting

Follow these steps to making the RS-232C communication settings.
1 When online and the welding is not done (the [Start Scan] button cannot be used), 

select [Laser Control] -> [RS232C Setting] from the menu.
The [RS232C Setting] screen is displayed.

2 Make RS-232C communication settings, referring to the following table.

3 Click the [OK] button to save the settings.

RS232C Settings

Item Setting Range

Baud Rate 4800bps, 9600bps, 19200bps,
38400bps, 57600bps, 115200bps

Stop Bit 1bit, 2bit

Parity None, Even, Odd

Checksum Disable, Enable

DelimiterETX Disable, Enable
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9. Event Information

Follow these steps to check the contents of events.
1 When online, select [Laser Control] -> [Event Information] from the menu.

The [Event Information] screen is displayed.

2 Click the [Save] button to save the event details as CSV data. Click the [OK] button to 
close.

Limitations on filenames when saving data
• Enter up to 255 single-byte characters (including drive name and path 

information) for the filename.
• Symbols (\/:*?"<>|), one-byte space, CON, AUX, COM1 to COM9, LPT1 to 

LPT9, PRN, and NUL may not be used in filenames.
CAUTION
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10. External I/O Monitor Test

With the external I/O monitor test tool, you can monitor the input/output status of I/O
signals connected to the external input/output connector and the extended external
input/output connector.
Also, you can use the simulate mode that can manually change the status of output
signals to check the connection with external devices such as sequencer.
1 When online, select [Laser Control] -> [External I/O Monitor Test] from the menu.

A dialog box is displayed for the external I/O monitor test. The external I/O monitor test dialog box 
shows ON/OFF status of I/O signals on the external input/output connector and the extended external 
input/output connector.

2 Click [Simulator] to switch to the mode to the simulate mode. In the simulate mode, 
you can turn ON/OFF the I/O output with button operation. The external I/O can be 
monitored even during the simulate mode.
To exit the simulate mode, click [Monitor].
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3 Click the [CANCEL] button during the monitor mode to finish the external I/O monitor 
test.
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1. Gridwork

The Gridwork is the function to image the whole of scanning area by the specified divi-
sion number (horizontally and vertically), combine them, save it as a single picture,
and use it as a sketch of SWDraw3. To perform the Gridwork, call the [Capture]
screen.

To perform the Gridwork, use the following buttons on the toolbar in the Drawing
screen.

Chapter 7 Gridwork and Auto Position 
Alignment

The [Capture] screen can be used only when CL-E100A is connected to the 
computer and the Camera Unit (option) is connected.

Toolbars in the Drawing Screen Functions

Button name Button Function

Camera monitor Displays the [Capture] screen.
Used for live display and parameter settings.

Perform Gridwork Images and combines the whole of the lens area to display it 
as a sketch.

Perform Gridwork Specified 
Area

Images and combines the specified area to display it as a 
sketch.

Specify Gridwork Area Edits and saves the specified area on the CAD software.
Up to thirty-six areas can be specified and areas can be 
overlapped.

Live display start Displays live images of camera.
Since this is for seeing images during process, the display 
position cannot be operated.

Live display stop Stops displaying live images of camera.

CAUTION
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1.1. [Capture] Screen Arrangement

Select [Laser Control] -> [Camera Monitor] from the menu or click the [Camera Moni-
tor] button on the toolbar.

(1) Toolbar

For camera operation. The following functions can be used.

*1 Keep the highest value when adjusting the focus.

Toolbar Indications

Item Function Operation 
possibility during 

live display

Live display start Displays the live image from a camera. －

Live display stop Stops the live image from a camera. 〇

One shot Captures a still image and displays it. ×

Save displayed 
image

Saves the displayed image in the specified folder 
with the specified filename.

×

View crossed line Displays the crossed line. 〇

Hide crossed line Hides the crossed line. 〇

Parameter setting Calls the parameter setting screen. This can be 
operated by our service person.

×

Gridwork start Performs the Gridwork.
After performing, a message asking whether the 
image is saved as a sketch or not is displayed. 
When saved, the Image folder is created and the 
Gridwork images are saved in the Image folder. 
The saved images are displayed as a sketch in the 
Drawing area of SWDraw3.

×

Focus level *1 Used for the focus adjustment. 〇

(1)

(2)

(5)

(3)

(4)

(6)

(7)
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(2) Camera image display

Displays the image from the camera.

(3) Operation log display
Displays the operation log on the screen.

(4) Layout name

Displays the filename of the layout number selected in [Scanner] on the [Control] 
screen.

(5) Scanner position

Displays the scanner mirror position.

Scanner Position Indications

Item Function Operation 
possibility during 

live display

Pan/Zoom Select [Pan/Zoom] and move the mouse to the dis-
play window. The image can be zoomed in or out 
by scrolling the mouse wheel up and down and 
moved by moving by holding down the left mouse 
button and dragging it.
Double-click the right mouse button to bring the 
image back to the initial size and position.

〇

Measure Select [Measure] and click two arbitrary points on 
the display window with the mouse to display the 
distance between them.
It is displayed in the unit of pixel when [Pix] is 
selected or in the unit of μm when [μm] is 
selected. Also, the display color can be changed by 
the color button.
The display is deleted by clicking the right mouse 
button and measured again with the above opera-
tions.

〇

Center Offset Select [Center Offset] and click an arbitrary point 
on the display with the mouse to display the dis-
tance from the camera center.
It is displayed in the unit of pixel when [Pix] is 
selected or in the unit of μm when [μm] is 
selected. Also, the display color can be changed by 
the color button.
The display is deleted by clicking the right mouse 
button and measured again with the above opera-
tions.

〇

Scanner Position Indications

Item Function Operation  
possibilityduring 

live display

X axis Displays the X-axis position of the scanner mirror. －

Y axis Displays the Y-axis position of the scanner mirror. －
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(6) Abs Move possibility

Moves the scanner mirror position at the specified position. The moving range is 
within the effective range of the specified lens.

(7) Index Move

Moves the scanner mirror position at a constant pitch. The moving range is 
within the effective range of the specified lens.

[Landmark] button Adds a landmark with making the current scan-
ner coordinate value as a sketch of SWDraw3. The 
snap functions can be used. (Refer to "Chapter 14-
3. Snap Setting" (page 246) .)
The position of the set landmark can be changed 
on the Drawing screen of SWDraw3. After 
selecting the landmark on the Drawing screen, 
change [X Coordinate] and [Y Coordinate] in the 
properties on the right and click the [Update] 
button. This is can be input in the unit of 0.001. 
The input range is within the range of the set 
lens.

〇

Abs Move Indications

Item Function Operation  
possibilityduring 

live display

X axis Specifies the X-axis position of the scanner mirror. 〇

Y axis Specifies the Y-axis position of the scanner mirror. 〇

[Move] button Moves the scanner mirror position to the set value 
of [X axis] and [Y axis].

〇

Index Move Indications

Item Function Operation  
possibilityduring 

live display

X axis Specifies the X-axis moving distance. 〇

Y axis Specifies the Y-axis moving distance. 〇

Cursor buttons Moves the scanner mirror position by the set 
value of [X axis] and [Y axis] in the direction of the 
button.

〇

Scanner Position Indications

Item Function Operation  
possibilityduring 

live display
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1.2. Using All Ranges as Sketch

Follow these steps to perform the Gridwork.
1 Select [Laser Control] -> [Camera Monitor] from the menu or click the [Camera Moni-

tor] button on the toolbar.

The [Capture] screen appears.

2 Click the [Start Gridwork] button on the toolbar.

3 A message confirming that the Gridwork is performed is displayed. Click the [OK] 
button.

4 Start the Gridwork. After performing, a message asking whether the image is saved 
as a sketch or not is displayed. Click the [Yes] button.

[OK] button

[Yes] button
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5 When the [Capture] screen is open, click the [x] button to close the screen.

6 The sketch is displayed in the Drawing screen.

The sketch is also saved when the layout saved.

[×] button
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1.3. Using Partial Range as Sketch

The vicinity of the specified area (square) can be imaged and combined to display it as
a sketch. When utilizing this function effectively, the processing time of Gridwork can
be shortened.

To perform the Gridwork specified area, it is necessary to add a specified area to the
layout.

Follow these steps to add, delete and edit the specified area and perform the Gridwork
specified area.

The specified area can be set up to thirty-six areas in a single layout.
CAUTION
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1.3.1. Adding the Specified Area

1 Click the [Specify Gridwork Area] button on the toolbar.

The [GRIDAREA] screen appears.

2 Click the [Add] button.

3 Specify the end point of the area.

[Specify Gridwork Area] button

[Add] button



1. Gridwork

118

SWDraw3

4 Specify the size of the area.

When the mouse moves, the square size changes. When it becomes an appropriate size, click the left 
mouse button at the point.

5 The specified area is displayed and an item is added to the [GRIDAREA] screen.

6 Click the title bar of SWDraw3 and then press the <Esc> key to close the 
[GRIDAREA] screen.



 1. Gridwork

119

SWDraw3

C
hapter 7

　
G

ridw
ork and A

uto Position A
lignm

ent

1.3.2. Deleting the Specified Area

1 Click the [Specify Gridwork Area] button on the toolbar.

The [GRIDAREA] screen appears.

2 Select the item from the list and click the [Delete] button.

3 After the specified area is deleted, click the title bar of SWDraw3 and then press the 
<Esc> key to close the [GRIDAREA] screen.

[Specify Gridwork Area] button

[Delete] button
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1.3.3. Editing the Specified Area

Like figures, the specified area can be selected ( "Chapter 9-2. Selecting Figures" (page
162) ) and changed the properties ( "Chapter 9-3. Changing Figure Properties" (page
164) ).

The properties of the specified area are as follows.

1.3.4. Performing the Gridwork Specified Area

Click the [Specify Gridwork Area] button on the toolbar.

The Gridwork area is specified by performing step 3 and later of “1.2. Using All
Ranges as Sketch.”
The Gridwork is performed at the part where the specified area is included in the
imaging range.

Properties Settings

Type Item Setting specifics Range Pitch

Specified area Object type Displays the type of the specified area 
(object).

GRIDAREA －

Left-Top X Specifies the X coordinate of the start 
point where the Gridwork is 
performed, which is the X coordinate at 
the upper left of the Gridwork range.

Lens dependant 0.001 mm

Left-Top Y Specifies the Y coordinate of the start 
point where the Gridwork is 
performed, which is the Y coordinate at 
the upper left of the Gridwork range.

Lens dependant 0.001 mm

Width Specifies the horizontal length from 
the Gridwork origin when performing 
the Gridwork.

0.001 to Lens 
dependant

0.001 mm

Height Specifies the vertical length from the 
Gridwork origin when performing the 
Gridwork.

0.001 to Lens 
dependant

0.001 mm

Boundary color Specifies the color of the boundary of 
the specified area.

0 to 15 1

ID Displays the number assigned to the 
specified area.

001 to 036 －
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2. Auto Position Alignment (Option)

The Auto position alignment is the function to perform pattern matching the compos-
ite image aquired by the Gridwork function and a template (image, circle or line serv-
ing as a mark) and automatically move the processing point set as the reference layout
data associated with a template.

For the moving distance, a difference information (X-coordinate moving distance, Y-
coordinate moving distance and rotation angle) between the reference position
information set when a template is registered and the position detected at pattern
matching is used. To perform the Auto position alignment, call the [A.P.A. Editor]
screen or the [Auto position alignment manual (A.P.A Manual)] button or the [Auto
position alignment automatic (A.P.A. Auto)] button in the toolbar.

This function is available when the following conditions are satisfied.

• CL-E100A and a computer are connected.
• [Camera Monitor] is set to “Yes” on the [System Parameters] screen.
• The license dongle of Matrox Imaging Library (option) is connected to a computer.

To perform the Auto position alignment, following buttons on the toolbar in the
Drawing screen are used.

Toolbars in the Drawing Screen Functions

Button name Button Function

Auto position alignment edit
(A.P.A. Edit)

Resisters patterns and sets the search area to perform the 
Auto position alignment.

Auto position alignment man-
ual
(A.P.A. Manual)

Used when the laser output of the Auto position alignment 
is performed from the computer.

Auto position alignment auto-
matic
(A.P.A. Auto)

Used when the laser output of the Auto position alignment 
is performed from the external control device such as PLC.



2. Auto Position Alignment (Option)

122

SWDraw3

2.1. [Select Template] Screen Arrangement

Click the [Auto position alignment edit (A.P.A. Edit)] button on the toolbar.

(1) [New Create] button

Creates a template for performing the Auto position alignment. Click this button 
to display a dialog for entering the template name.

(2) Template Name

Displays the created templates in a list. Double-click the displayed template 
name to open the created template.

(3) [Delete] button

Deletes the selected template from the template name display. When clicking the 
[Delete] button with selecting the template name to delete, a confirmation dialog 
is displayed. Click the [Yes] button to delete the template.

(4) [Copy] button

Copies the selected template from the template name display. When clicking the 
[Copy] button with selecting the template name to copy, a screen for entering the 
name after copying is displayed. After entering a name, click the [Execute] 
button.

(5) [Rename] button

Renames the selected template from the template name display. When clicking 
the [Rename] button with selecting the template name to rename, a screen for 
entering the name after renaming is displayed. After entering a name, click the 
[Execute] button.

(6) [Cancel] button

Closes the [Select Template] screen.

(1)

(2)

(6)

(3) (5)

(4)
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2.2. Creating a New Template

Follow these steps to create a new template.
1 Click the [New Create] button on the [Select Template] screen.

2 Enter the template name for performing the Auto position alignment. The number of 
characters that can be entered is up to 32767 single-byte characters or 16383 dou-
ble-byte characters.

The entered template name is displayed on the [A.P.A. Editor] screen described later.

3 Click the [Next] button to display the [A.P.A. Editor] screen. To display the screen, a 
template name should be entered.
To cancel, click the [Back] button.

Symbols (\/:*?"<>|) may not be used in template names.

[New Create] button

CAUTION
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2.3. [A.P.A. Editor] Screen Arrangement

(1) Template name

Displays the template name entered when the template has been created.

(2) Align ID and Model Name

To perform the Auto position alignment, it is necessary to set the alignment ID 
associated with the model (type of search method). Up to thirty-six Align IDs can 
be set per template.

There are three types of models, and each feature is as follows.

Model Type Functions

IMAGE Compares a shape matched with the registered image and performs 
pattern matching.
Used for correcting the layout data position and tilt with reference to 
the characteristic figure (logo mark or parts, etc.).

CIRCLE Searches the circle matched to the set radius of the circle.
Used for correcting the layout data position with reference to the 
position of the specific circle.

LINE Searches the line edge (boundary).
Used for correcting the layout data position and tilt with reference to 
the line existing at the specific position.

(2)

(7)

(4)

(3)(1)

(5)

(6)

(8) (9) (10)
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(3) Parameter

Sets parameters of the model. The following table lists the items that can be set 
in Parameter.

Parameter Settings

Type Item Setting Details Range
(Default)

Parameter Param1

Smoothness*1 Reduces noises at the time of search. Values closer to 0 do 
not reduce noises and values closer to 100 reduce noises.

0.0 to 100.0
(50.0)

Edge Level*2 Sets the accuracy of the image edge extraction. The accuracy 
becomes higher in the order of MEDIUM, HIGH and VERY 
HIGH, and more information about the image edge can be 
acquired. This is effective when acquiring more feature 
points for workpiece having less edge information. This can-
not be set when LINE is selected for Model.

MEDIUM, 
HIGH, VERY 

HIGH
(MEDIUM)

Alignment ID ID (alignment ID) to perform the currently selected Auto 
poisition alignment. Set it for objects in a layout on the lay-
out drawing screen of SWDraw3. 

－
(0001)

Param2

Rotation*3 Sets the angle during template matching. Used when chang-
ing the template angle or limiting the allowable angle. This 
cannot be set when CIRCLE or LINE is selected for Model.

0.0 to 180.0°
(Angle: 0.0°, 
Delta Pos: 

180.0°, Delta 
Neg: 180.0°)

Scaling*4 Sets the scaling factor during template matching. Used 
when scaling the template or limiting the allowable scaling 
factor at the time of search. This cannot be set when LINE is 
selected for Model.

0.500 to 2.000
(Scale: 1.000, 
Max: 2.000, 
Min: 0.500)

Time out Sets the upper limit of the search time during template 
matching. Used when limiting the time during template 
matching or taking longer time for template matching. This 
cannot be set when LINE is selected for Model.

1 to 10000 ms
(2000 ms)

Param3

Score*5 Determines the matching state when the matching degree 
acquired as a result of the conditions used for search and the 
actual pattern matching is higher than the set value. When 
the value is closer to 100, a matching condition becomes 
severe. This cannot be set when LINE is selected for Model.

1 to 100
(60)

Speed Sets the search speed during template matching algorithm. 
The search speed becomes faster in the order of LOW, 
MEDIUM, HIGH, and VERY HIGH, and template matching 
can be performed at high speed. However, the higher the 
search speed, the less the search accuracy. Be careful when 
performing high-precision template matching. This cannot 
be set when CIRCLE or LINE is selected for Model.

LOW, 
MEDIUM, 

HIGH, VERY 
HIGH

(MEDIUM)

Accuracy Sets the search accuracy during template matching. The 
search accuracy becomes higher in the order of LOW, 
MEDIUM and HIGH, and template matching can be per-
formed in subpixel accuracy. However, the more the search 
accuracy, the lower the search speed. Be careful when per-
forming high-speed template matching. This cannot be set 
when CIRCLE or LINE is selected for Model.

LOW, 
MEDIUM, 

HIGH
(MEDIUM)
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*1 When Smoothness is changed to 70 for the left image (Smoothness 50), feature points are empha-
sized by reducing noises shown in the right image (Smoothness 70). However, when the value is set 
too high, feature points to search for may be also smoothed. Adjust it using test matching so that 
extra feature points are not detected.

*2 In the Edge Level setting, the edge information (green line) acquired from image changes as shown 
below. The edge information (red line) can be used as feature points of image. However, the edge 
information may contain noise. When setting Edge Level high, be careful not to extract extra edges.

*3 The angle setting during template matching and upper/lower limits of the allowable angle are as 
shown below. The angle can be set in the unit of 0.1°.

*4 Settings of the scaling factor during template matching and maximum/minimum scaling factor at 
the time of search are as shown below. The scaling factor can be set in the range of 0.500 to 2.000 
and in the unit of 0.001.

Smoothness 50                                    Smoothness 70

   EDGE LEVEL                        EDGE LEVEL                       EDGE LEVEL
        MEDIUM                                 HIGH                                VERY HIGH
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*5 A threshold for judging as a matching state corresponding to the result of pattern matching can be 
set in Score. By setting Score to a lower value, they are determined to be matched even if a part of 
Target image is different from the registered template due to the influence such as a reflected light 
by illumination and dirt. However, when the value is too low, a possibility of erroneous recognition 
becomes high. Also, because Score is not the matching rate (%), it does not become 100 even if the 
same image is used.

(4) Registration template

Sets and displays the template information. The following table lists the set and 
displayed items. Items displayed in gray rows cannot be input directly.

Registration Template Settings

Type Item Setting Details Range*1

Registra-
tion 
template

Model IMAGE Registers the model featuring the model image 
information. When the model is registered by 
IMAGE, the model image information is dis-
played.

16×16 to 
4096×4096 

pixel

CIRCLE Registers the model featuring the radius value 
of the circle. When the model is registered by 
CIRCLE, a geometric shape of the circle cre-
ated with the specified radius value is dis-
played.

16×16 to 
4096×4096 

pixel

LINE Registers the model featuring the line edge 
information. When the model is registered by 
LINE, the image indicating that it is regis-
tered by LINE is displayed.

－

Origin X axis Displays the center position (X coordinate) of 
the setting range in subpixels.

Lens dependant

Origin Y axis Displays the center position (Y coordinate) of 
the setting range in subpixels.

Lens dependant

Area width Displays the width of the setting range in 
subpixels.

Lens dependant

Area height Displays the height of the setting range in 
subpixels.

Lens dependant

Edge polar-
ity*2

White to Black Sets when the color from the outside to the 
inside in the search direction changes from 
white to black (bright to dark).

－

Black to White Set when the color from the outside to the 
inside in the search direction changes from 
black to white (dark to bright).

－

[Setting] button Sets the items required for search of each 
model.

－

[Regist] button Saves the reference position information and 
the parameter setting of each model as a 
template.

－

Model image                                        Target image
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*1 Indicates an area or a search range which can be registered as template. (Refer to "Chapter 7-2.6. 
Setting the Auto Position Alignment" (page 134) .)

*2 Performs searching toward the center from the outer circumference of a search range when Model is 
CIRCLE or toward the rotation handle from the opposite side of a search area when Model is LINE.

*3 Mask processing can be set only when Model is IMAGE.

(5) Search area

Displays the information of area where a model is searched. The following table 
lists the displayed items. Effective only when Model is IMAGE. Items displayed 
in gray rows cannot be input directly.

Registra-
tion 
template
(continued)

[Mask] button*3 Performs template matching with setting cor-
relation with the specific part of the model 
image information. By performing mask pro-
cessing, matching can be performed even with 
image that contains partially different infor-
mation.

－

Search Area Settings

Type Item Setting Details Range

Search area X axis Displays the X coordinate at the center position of the 
area set in Target image in pixels.

Lens dependant

Y axis Displays the Y coordinate at the center position of the 
area set in Target image in pixels.

Lens dependant

Area width Displays the width of the area set in Target image in pix-
els.

Lens dependant

Area height Displays the height of the area set in Target image in 
pixels.

Lens dependant

[Setting] button Specifies the range of the search area. －

[Regist] button Registers the specified search area. －

[Full area] button Specifies the search area to the whole area. －

Registration Template Settings

Type Item Setting Details Range*1

Search direction of CIRCLE                    Search direction of LINE
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(6) Test matching

Performs matching with the target image to check if the set template operates 
correctly and displays the result. The following table lists the displayed items.

(7) Target image

Selects the target image and displays it. Click the [Select image] button and 
select the target image to display the selected image in the Target image area. 
Also, the coordinate point of image indicated by a mouse cursor is displayed at 
the lower left of the area. (The upper left is X=0 and Y=0.)

(8) [Regist to layout] button

Displays the [Select Layout] screen to associate the created template with the 
layout number. After setting the Auto position alignment, specify the align ID for 
the figure in layout data. (Align ID can be set in advance.)

(9) [Remove from layout] button

Displays the [Select Layout] screen to delete the combination of template and 
layout data (number) associated in the past. Template is not deleted.

(10) [Close] button

Ends the Auto position alignment setting. Click the [Close] button to close the 
[A.P.A. Editor] screen and return to the screen of SWDraw3.

Test Matching Settings

Type Item Setting Details Range

Test match-
ing

X axis Displays the X coordinate at the matching center posi-
tion in Target image when the matching is successful.

Lens dependant

Y axis Displays the Y coordinate at the matching center posi-
tion in Target image when the matching is successful.

Lens dependant

θ Displays the matching angle in Target image when the 
matching is successful.

0 to 360.0°

Score Displays the matching degree in Target image when the 
matching is successful.

1 to 100.0

[Execute] button Performs matching with the target image with the set 
template.

－
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2.4. [Select Layout] Screen Arrangement

Click the [Regist to layout] button or the [Remove from layout] button on the [A.P.A.
Editor] screen to register or delete a template to/from the layout.

(1) Selected layout number

Displays the number selected from the layout number list. Two or more layout 
numbers can be selected.

(2) Layout number list

Displays the template name associated with the layout data. Layout numbers 
0001 to 1023 can be registered.

(3) [Cancel] button

Closes the [Select Layout] screen.

(4) [OK] button

Registers a template set on the [A.P.A. Editor] screen to the selected layout num-
ber when the [Register to layout] button is clicked on the [A.P.A. Editor] screen. 
When registration is complete, the template name is displayed for the selected 
layout number.
Deletes a template name displayed for the selected layout number when the 
[Remove from layout] button is clicked on the [A.P.A. Editor] screen. When dele-
tion is complete, the template name of the selected layout number is deleted and 
the association with the layout number is released.

(1)

(2)

(3) (4)
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2.5. [MaskSet] Screen Arrangement

Click the [Mask] button on the [A.P.A. Editor] screen to add mask processing to the
IMAGE model.

(1) Template image

Displays the registered template image. The area of mask processing can be spec-
ified by dragging the displayed image with the left mouse button. The image is 
scaled by scrolling the mouse wheel up and down. To fit the frame, press the 
mouse wheel. Also, when Pan mode is checked, the image can be moved by drag-
ging the mouse.

(2) Display Options

Sets the display contents of the template image. By putting a check in Show 
Edges, the edge information of the image can be displayed in a red line. Also, by 
putting a check in Show Image, the image information of the template images 
displayed.

(3) Brush Size

Specifies the line width of mask to draw. Specifies the line width with 1 to 1000 
pixel by a slide bar or text box.

(4) Draw Mask / Draw Clear

Selects whether drawing or canceling mask. When Draw Mask is selected, draw 
mask processing by dragging the template image. When Draw Clear is selected, 
the drawn mask processing part is canceled by dragging the template image.

(5) Mask

Selects a mask processing to draw in the template image. There are the following 
three options. In each option, there are the [Undo] button and the [Clear] button. 
Click the [Undo] button to reverse the last action. Click the [Clear] button to can-
cel all processes drawn on the template image.

(1)

(2)

(3)

(5)

(7) (8)

(4)

(6)
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• Ignore the specified area.

Skips the part where mask processing is drawn on the template image during 
template matching. This function allows matching with similar image.
The draw color can be changed. The default color is green.

• Decreases the correlation rate with the specified area.

Decreases correlation with the part where mask processing is drawn on the tem-
plate image. This function reduces the probability of error detection.
The draw color can be changed. The default color is blue.
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• Specify the correlation rate of the specified area.

Sets correlation with the part where mask processing is drawn on the template 
image. This function allows template matching with additionally processed parts. 
In this function, a black-to-white 255 of gradations (-127 to 127) can be set by a 
slide bar (or text box). The lower the value, the higher the effect to lower correla-
tion.

(6) Pan mode

Sets to allow or to not allow the displayed image move. When checked, the image 
moves by dragging the left mouse button without specifying the area for mask 
processing.

(7) [OK] button

Adds mask processing to the registered template image.

(8) [Cancel] button

Closes the [MaskSet] screen.
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2.6. Setting the Auto Position Alignment

Follow these steps to set the Auto position alignment.

In the Auto position alignment, images aquired by the Gridwork are used. If they have
not been aquired, see "Chapter 7-1.2. Using All Ranges as Sketch" (page 114) or
"Chapter 7-1.3. Using Partial Range as Sketch" (page 116) to aquire images.
1 Click the [Auto position alignment edit (A.P.A. Edit)] button on the toolbar.

2 A dialog for creating a template is displayed. Click the [New Create] button.

3 Enter a desired template name and click the [Next] button.

The [A.P.A. Editor] screen is displayed.

[Auto position alignment edit (A.P.A. Edit)] button

[New Create] button

[Next] button
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4 Click the [Select image] button to display the image aquired by the Gridwork in the 
Target image area.

5 Associate the alignment ID with the model. Select an alignment ID in the list display-
ing Align ID and Model Name by clicking it. To delete the set alignment ID, click the 
right mouse button and choose Delete.

The currently selected alignment ID is displayed in Alignment ID in Parameter.
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6 Select a model and make setting of it. Select a model to use for pattern matching in 
the Registration template area. After selection, click the [Setting] button to display the 
setting contents corresponding to each model.

• When IMAGE is selected

When the [Setting] button is clicked, the area to register as a template is dis-
played. Specify the area to register with a drag operation. When the [Regist] 
button in the Registration template area is clicked with the area set, image and 
its positions, area width and area height used for pattern matching are displayed 
and registered as the reference position information.
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• When performing mask processing

When the [Mask] button is clicked, the [MaskSet] screen for setting correlation to 
the specific part of the image is displayed. By painting the part to set correlation 
to the image in the screen, mask processing is added to the registered IMAGE 
model.

• When CIRCLE is selected

When the [Setting] button is clicked, a dialog for inputting the radius of the circle 
is displayed. Input the radius of the circle (in mm) and click the [OK] button. To 
cancel, click the [Cancel] button.

After inputting the radius of the circle, the search range of the reference circle is 
displayed at the upper left of Target image. Specify the search range, and then 

The minimum value of radius that can be input is 1. The maximum value depends 
on the image size of the Target image area.

CAUTION
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select a search method in Edge polarity under Registration template. After selec-
tion, click the [Regist] button to display the radius value to register at area width 
and area height.

• When LINE is selected

When the [Setting] button is clicked, the search range of LINE is displayed. Spec-
ify the search range as the range where a desired line appears. The angle can be 
changed by the rotation handle. After specifying the range, select the edge polar-
ity. After selection, when the [Regist] button under Registration template is 
clicked, positions, area width and area height of the set search area are displayed 
and registered as the reference position information. Also, the search angle of 
LINE is ±30 degree.
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7 When IMAGE is selected for Model, set the search area and register it. Click the 
[Setting] button to display the area to register as a search area. Specify the area to 
register with a drag operation. To register the entire Target area, click the [Full area] 
button. When the area is set and the [Regist] button under Search area is clicked, 
positions, area width and area height of the set search area are displayed and regis-
tered as the search area. When the search area is set, the time used for pattern 
matching can be reduced. To cancel the area setting, right-click during setting.

8 Performs test matching. In test matching, you can check that the registered template 
and search area operate as set. To perform test matching, click the [Execute] button. 
When pattern matching is successful from the range registered in the search area in 
Target image, the detection result is displayed in Target image. The detection result is 
also displayed in the Test matching area. When LINE is selected for Model, Score is 
not displayed.

9 Performs parameter settings. By operating Smoothness and Score displayed in the 
Parameter area, noise reduction at the model detection and the threshold of the 
matching degree with template can be set. When LINE is selected for Model, Score 
cannot be set.
When changing parameters, click the [Regist] button under Registration template to 
reflect them to the template information.

Search angle of LINE

Rotation handle

30°

30°



2. Auto Position Alignment (Option)

140

SWDraw3

10 Associate a template with the layout name. Click the [Regist to layout] button to dis-
play a list of the associated layout number and template name.
Select the layout number to associate and click the [OK] button. (To select multiple 
numbers, click the button while pressing the <Ctrl> key.)

The alignment ID in the associated layout and the specified Align ID in the tem-
plate are associated. When the Auto position alignment manual (A.P.A. Manual) 
or the Auto position alignment automatic (A.P.A. Auto) described later is per-
formed, the processing position including pattern matching can be corrected.

When the [Regist] button under Registration template is not clicked, values in 
Parameter are not reflected in the template.

CAUTION

[OK] button
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2.7. Performing the Auto Position Alignment Manual (A.P.A. Manual)

Follow these steps to perform the Auto position alignment manual (A.P.A. Manual).

• The Auto position alignment manual (A.P.A. Manual) is available in a laser start 
state.

• Create a template with the Auto position alignment setting in advance.

For creating a template, see "Chapter 7-2.6. Setting the Auto Position Alignment"
(page 134) .
1 Set the Align ID for the object to perform the Auto position alignment. When the 

object is selected, the combo box to set the Align ID is displayed in the properties.

2 After selecting the Align ID specified in the Auto position alignment setting and click-
ing the [Update] button, save and transfer the layout by [File / Save (or Save as)] 
from the menu. Set Align ID to 0 for a figure that you do not want to correct the posi-
tion by the Auto position alignment.

3 Transfer data and reflect the layout data to CL-E100A. Data is transferred to the lay-
out number set when the layout is registered in the Auto position alignment setting.

Note that the position is not corrected to an intended position when the layout is 
not saved and transferred with the specified Align ID.

CAUTION
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4 Click the [Auto position alignment manual (A.P.A. Manual)] button on the toolbar.

5 The capture image is displayed. When a message confirming that the Gridwork is 
performed is displayed, select the [OK] button.

6 When pattern matching is successful in the Auto poisition alignment after performing 
the Gridwork, the object in layout is moved. When the Auto position alignment setting 
is wrong or the detection is failed, the object is not moved. When any AlignID in a 
template fails to pattern matching, execution of subsequent AlignIDs is interrupted.

The pattern matching is applied to all Align IDs in the created template. When 
multiple patterns are detected in an image that the Gridwork is performed, the 
result of Align ID not registered in the object in the Drawing screen may be dis-
played in the operation history of SWDraw3.

[Auto position alignment manual (A.P.A. Manual)] button

[OK] button

CAUTION
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7 A message asking whether to perform scanning is displayed. Select the [Yes] button.

8 Scanning is performed at the position specified in the Auto position alignment setting.

Data obtained by the Auto position alignment is not cleared even if the [No] button 
is selected. When selecting the [No] button, perform scanning or test scanning 
from the [Control] screen.

[Yes] button

CAUTION
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2.8. Performing the Auto Position Alignment Automatic (A.P.A. Auto)

Follow these steps to perform the Auto position alignment automatic (A.P.A. Auto).

• The Auto position alignment automatic (A.P.A. Auto) is available in a laser start 
state.

• Create a template with the Auto position alignment in advance.

For creating a template, see "Chapter 7-2.6. Setting the Auto Position Alignment"
(page 134) .
1 Set the Align ID for the object to perform the Auto position alignment. When the 

object is selected, the Align ID can be selected from the properties.

2 Select the Align ID specified in the Auto position alignment setting and clicking the 
[Update] button, and save and transfer the layout.

3 Transfer data and reflect the layout data to CL-E100A. Data is transferred to the lay-
out number set when the layout is registered in the Auto position alignment setting.

Note that the position is not corrected to an intended position when the layout is 
not saved and transferred with the specified Align ID.

CAUTION
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4 Click the [Auto position alignment automatic (A.P.A. Auto)] button on the toolbar.

5 A system becomes a waiting state of the scan start signal of the external I/O. When 
the scan start signal is sent from the external I/O, the Auto position alignment auto-
matic (A.P.A. Auto) is performed after the Gridwork is performed.

6 When pattern matching is successful as a result of the Auto position alignment, the 
object in layout is moved. When the Auto position alignment setting is wrong or the 
detection is failed, the object is not moved. When any AlignID in a template fails to 
pattern matching, execution of subsequent AlignIDs is interrupted.

The pattern matching is applied to all Align IDs in the created template. When 
multiple patterns are detected in an image that the Gridwork is performed, the 
result of Align ID not registered in the object in the Drawing screen may be dis-
played in the operation history of SWDraw3.

[Auto position alignment automatic (A.P.A. Auto)] button

CAUTION
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2.9. Deleting the Template in the [Select Template] Screen

Follow these steps to delete the template set on the [A.P.A. Editor] screen.
1 Select the created template on the [Select Template] screen and click the [Delete] 

button.

2 A dialog for confirming deletion is displayed. Click the [Yes] button.

[Delete] button

[Yes] button
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2.10. Copying the Template in the [Select Template] Screen

Follow these steps to copy the template set on the [A.P.A. Editor] screen.
1 Select the created template on the [Select Template] screen and click the [Copy] 

button.

2 A dialog for copying template is displayed. Enter the template name and click the 
[Execute] button.

3 A dialog confirming the completion of the copying is displayed. Click the [OK] button.

4 The copied template name is displayed in the template list on the [Select Template] 
screen.

[Copy] button

[Execute] button

[OK] button
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2.11. Renaming the Template in the [Select Template] Screen

Follow these steps to rename the template set on the [A.P.A. Editor] screen.
1 Select the created template on the [Select Template] screen and click the [Rename] 

button.

2 A dialog for renaming template is displayed. Enter the template name and click the 
[Execute] button.

3 A dialog confirming the completion of the renaming is displayed. Click the [OK] 
button.

4 The renamed template name is displayed in the template list on the [Select Template] 
screen.

[Rename] button

[Execute] button

[OK] button
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1. Undo (Undoing an Operation)

You can undo unintended actions by selecting [Edit] -> [Undo] from the menu.

2. Redo (Redoing an Operation)

You can also redo actions that you have undone. Select [Edit] -> [Redo] from the menu
to redo the action.

3. Delete (Deleting a Figure)

Delete selected figures as follows:
1 From the menu, select [Edit] -> [Delete].

2 Select the object to delete.
Select by specifying the start and end points of the area containing the object.

The selected figure is deleted.

Chapter 8 Edit

Artifacts (unwanted images) from a previous action may remain on the screen 
after the previous action has been undone. (This does not affect the editing data.)
Select [View] -> [Refresh] from the menu to redraw the screen.

All elements in the bounded area including the object are selected if you marked 
the area without selecting [Edit] -> [Delete] from the menu. The process can be 
time-consuming in cases involving complex figures such as imported DXF files. 
Thus, always select [Delete] from the menu before deleting figures.

CAUTION

CAUTION
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4. Copying Figures

4.1. Copy (Arranging Copied Objects)

Duplicate created figures as follows:

1 From the menu, select [Edit] -> [Copy].

2 Select the object to copy.
Select by specifying the start and end points of the area containing the object.

3 Specify a position as the reference point.

A position relative to the object to be copied and the cursor is specified as the reference point. 
Normally, specify the object to be copied as the reference point.

4 Specify the position to copy to.

A copy of the figures is produced.

Specify the reference point.

Specify the 
position to copy to.
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4.2. Copy and Rotate (Arranging Rotated Copies)

Copies of figures can be rotated as follows:

1 From the menu, select [Edit] -> [Copy and Rotate].

2 Select the object to copy.
Select by specifying the start and end points of the area containing the object.

3 Specify a point as the center of rotation.

4 In the command field, enter the angle of rotation and press the <Enter> key.

The copied figure is rotated.

• This function does not handle square objects.
• Large figures that fill the layout area cannot be rotated, as they will protrude 

from the area while being rotated.CAUTION

Specify the center point.

The copy is rotated.
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4.3. Copy and Invert (Arranging Inverted Copies)

Copies of figures can be inverted as follows:

1 From the menu, select [Edit] -> [Copy and Invert].

2 Select the object to copy.
Select by specifying the start and end points of the area containing the object.

3 Specify a line as the axis for inversion.
If you have already arranged a line to serve as this axis, select that line.
If not, specify the axis start and end points.

The copied figures are arranged inverted relative to the axis.

• This function does not handle square objects.
• Large figures that fill the layout area cannot be inverted, as they will protrude 

from the area while being inverted.CAUTION

Specify the axis.

The copy is inverted.
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5. Moving Figures

5.1. Move (Moving Figures)

Move figures as follows:

1 From the menu, select [Edit] -> [Move].

2 Select the object to move.
Select by specifying the start and end points of the area containing the object.

3 Specify a position as the reference point.

A position relative to the object to be moved and the cursor is specified as the reference point. 
Normally, specify the object to be moved as the reference point.

4 Specify the destination.

The figure is moved.

All elements in the bounded area including the object are selected if you marked 
the area without selecting [Edit] -> [Move] from the menu. The process can be 
time-consuming in cases involving complex figures such as imported DXF files.
Thus, always select [Move] from the menu before moving figures.CAUTION

Specify the reference point.

Specify the 
destination.



5. Moving Figures

154

SWDraw3

5.2. Move and Rotate (Moving and Rotating Figures)

Move and rotate figures as follows:

1 From the menu, select [Edit] -> [Move and Rotate].

2 Select the object to move.
Select by specifying the start and end points of the area containing the object.

3 Specify a point as the center of rotation.

4 In the command field, enter the angle of rotation and press the <Enter> key.

The figures are moved and rotated.

• This function does not handle square objects.
• Large figures that fill the layout area cannot be rotated, as they will protrude 

from the area while being rotated.CAUTION

Specify a point as the 
center for rotation.

Move and rotate.
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5.3. Move and Invert (Moving and Inverting Figures)

Move and invert figures as follows:

1 From the menu, select [Edit] -> [Move and Invert].

2 Select the object to move.
Select by specifying the start and end points of the area containing the object.

3 Specify a line as the axis for inversion.
If you have already arranged a line to serve as this axis, select that line.
If not, specify the axis start and end points.

The figures are moved inverted relative to the axis.

• This function does not handle square objects.
• Large figures that fill the layout area cannot be inverted, as they will protrude 

from the area while being inverted.CAUTION

Specify the axis.

The figure is inverted.
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5.4. Resize Sketch

In Sketch Edit mode, follow these steps to enlarge or reduce sketches.
1 From the menu, select [Edit] -> [Resize Sketch].

2 To identify a line as a guideline for resizing, specify two points as desired on the 
sketch.

3 Enter the new length (for enlarging or reducing) between the two points designated in 
step 2 in the command field using single-byte numbers.

Enter a larger number for the length of the line selected in step 2 to enlarge the
sketch. Enter a smaller number to reduce it.
For example, if the length of the line in step 2 is 20, entering 60 in the command field
triples this length, so the area becomes nine times larger.

Entering 60 in the command field 
increases the guideline length to 60 mm.

6020
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6. Comment (Editing a Comment)

Edit comments created as follows:
1 From the menu, select [Edit] -> [Edit Comment].

2 Select the comment to edit.
The [Comment] screen is displayed.

3 Make a change and click the [OK] button. To cancel the change, click the [Cancel] 
button. See "Chapter 11-10. Comment (Entering Comments)" (page 232) .
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7. Arranging and Canceling Arrays

Use this command to copy character figures in the drawing area to create an array as
follows:

7.1. Creating Arrays

1 From the menu, select [Edit] -> [Array] -> [Create].
A dialog box is displayed for array settings.

2 Complete the array settings.

*1 [Rows] x [Columns] should be 10000 or less.
*2 The maximum value varies depending on the lens.

3 Click the [OK] button.
The array is arranged under these conditions.

• After an array is arranged, the figures cannot be edited until the array is can-
celed.

• After an array is created, other figures cannot be arranged in the drawing area.
• Processing may take a long time for arrays larger than 50x50.

Array Settings

Item Setting Details

Rows *1 Specify the number of rows to arrange vertically.

Columns *1 Specify the number of rows to arrange horizontally.

Row Pitch *2 Specify vertical spacing (in mm).

Col Pitch *2 Specify horizontal spacing (in mm).

Angle To arrange copies of the original item at an angle, specify the 
angle (in a range from -179.999 to 180.000).

Row priority/
Col priority

Select whether to use columns or rows as the basis for 
determining the scanning order.

Array Properties

Item Setting Details Range (Default) Pitch

Row Indicates the number counted 
vertically of the selected array.

－ －

Column Indicates the number counted 
horizontally of the selected array.

－ －

CAUTION
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7.2. Canceling Arrays

1 From the menu, select [Edit] -> [Array] -> [Cancel].

A confirmation message is displayed.

2 Click the [OK] button.

The array is canceled, and the figure is restored to its original state.

Rows Indicates the number of rows 
arranged vertically.

－ －

Columns Indicates the number of columns 
arranged horizontally.

－ －

Row Pitch Indicates vertical spacing (in mm). － －

Col Pitch Indicates horizontal spacing (in 
mm).

－ －

X Offset Specify the X coordinate at the 
reference position (lower-left 
position) of the selected element (in 
mm).

Lens dependant 0.001

Y Offset Specify the Y coordinate at the 
reference position (lower-left 
position) of the selected element (in 
mm).

Lens dependant 0.001

Angle of Rotation To arrange arrays at an angle, 
specify the angle.

-179.999 to 
180.000

0.001

Delete
(Hide/Show)

Indicates whether scanning is 
performed.

Hide, Show
(Show)

－

Scanning Order Indicates the order of scanning. 1  to 1000 －

If you attempt to arrange an array again immediately after it was cleared, the 
dialog box for array settings is displayed with the array parameters still intact. 
Clicking the [OK] button without changing the values in the dialog box at all will 
restore the array to the state it was before you cleared it, including offset values 
for array elements.

Array Properties

Item Setting Details Range (Default) Pitch

CAUTION
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1. Deleting Unneeded Lines

1.1. Trim (Deleting Parts of Lines)

You can reduce or increase parts of lines.

1 From the menu, select [Adjustment] -> [Trim].

2 Select the line to trim.

3 Specify the start and end points on the line for deletion.

The specified segment is deleted.

Chapter 9 Adjustment

Specify the start and end 
points of the line for deletion.

The specified line segment 
is deleted.
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1.2. Trim Junction (Deleting Extra Lines from Junctions)

Trim unneeded lines from junctions as follows. You can create attractive corners by
deleting all unnecessary lines from these junctions.

1 From the menu, select [Adjustment] -> [Trim Junction].

2 Select the line to delete extending from the junction.

The line is deleted all the way to the junction.

Select the line to delete 
extending from the junction.

The line is deleted up to the 
junction.
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2. Selecting Figures

2.1. Selection Mode (Switching to Selection Mode)

Functions in the [Edit] and [Adjustment] menus are normally used to edit the figures
you created. The mouse can also be used for rough repositioning and resizing. The
following section describes how to edit figures with the mouse after clicking the
[Selection Mode] button in the toolbar to switch to Selection mode.
To alter the properties of a figure or move or resize a figure using the mouse, use one
of the following methods to switch to Selection mode.

• From the toolbar, click the [Selection Mode] button.
• Click the <Esc> key several times to exit the command.
• From the menu, select [Adjustment] -> [Selection Mode].
• From the right-click menu, select [Selection Mode] with no figure selected.
Selecting a figure by clicking on it with the mouse in Selection mode displays a gray or
red frame around the figure with a blue move handle and white resize handles. When
a polyline is selected alone, however, the [Poly] screen is displayed. For details of the
[Poly] screen, refer to "Chapter 11-2.2. [Poly] Screen Arrangement" (page 204) .

To select multiple figures, hold the <Ctrl> key while clicking.

2.1.1. Resizing figures in Selection mode

Selecting a figure by clicking on it with the mouse in Selection mode displays a gray or
red frame around the figure with resize handles. Figures can be resized as desired by
dragging these handles.

Figures can also be resized by changing their properties.

Resize handle

Move handle

Drag the resize handle.
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2.1.2. Moving figures in Selection mode

Selecting a figure by clicking on it with the mouse in Selection mode displays a gray or
red frame around the figure with a blue move handle in the center. Reposition figures
by dragging this handle.

Figures can also be moved using the menu.

2.2. Rotation Mode (Rotating Line Segments in Selection Mode)

In Selection mode, select a line segment using the mouse and click the [Rotation
Mode] button on the toolbar or select [Adjustment] -> [Rotation Mode] from the menu
to display the rotation handles at the both ends of the line segment. Rotate the line
segment as desired by dragging these handles. Also, the center of rotation can be
changed by moving the central handle.

Drag the move 
handle.

Drag the rotation 
handle.
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3. Changing Figure Properties

3.1. Using Properties

Properties are detailed information on arranged figures.
In Selection Mode, you can display the properties on the Drawing screen in the
properties field by clicking on the figures. Modify the values in the properties field to
change the shape, welding schedules, and other aspects of the figures.
The following example describes how to change the properties to edit and reposition a
spot.
Example Conditions

• Change the open time from 10 ms to 5 ms.
• Change the coordinates to the origin (0,0).

1 Click the [Selection Mode] button in the toolbar or press the <ESC> key repeatedly to 
escape the current command mode.
The screen switches to Selection Mode.

2 Click to select the spot.

3 Change the values for both [X-Coordinate] and [Y-Coordinate] in properties to 0.
Change [Open Time] to 5.

Edit the 
properties field 
directly
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4 Click the [Update] button.

The changes to the spot content and position are applied.

If your entry exceeds the properties setting range, the previous values will 
automatically be restored when you click the [Update] button.

Confirm your 
choices with the 
[Update] button

CAUTION
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3.2. Properties Items

The following table lists the items in the properties field. The specific items available
depend on the particular figure and its shape.

Items displayed in gray rows (such as the object type) cannot be edited.
Properties Setting Items (1 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch

Common to all 
types

Scanning Order Displays the scanning order. 1-4294967295 1

Scanning Standby
*1

Specifies the time period from the jump 
to the start point of the laser output to 
the start of the laser output after the 
wait time.

0-30000 ms
(0 ms)

1 ms

Square Object type Displays the type of the figure (object). SQUARE －

Object name 
(default)

Specifies the name of the figure 
(object).

SQUAREx 256 
characters 

max.

Laser type
Overlap1

Displays the laser type for Overlap1. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Overlap1

Displays the number of the schedule 
data to use for Overlap1. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Overlap1

Displays the waveform method for 
Overlap2. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Laser type
Overlap2

Displays the laser type for Overlap2. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Overlap2

Displays the number of the schedule 
data to use for Overlap1. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Overlap2

Displays the waveform method for 
Overlap2. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Laser type
Line

Displays the laser type for Line. The 
contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Line

Displays the number of the schedule 
data to use for Line. Double-clicking 
this item displays the [Schedule Win-
dow] screen in 5.3. according to the set 
schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Line

Displays the waveform method for 
Line. The contents of this item changes 
depending on the schedule number.

FIX or FLEX －
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Square
(continued)

Laser type
Chamfer

Displays the laser type for Chamfer. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Chamfer

Displays the number of the schedule 
data to use for Chamfer. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Chamfer

Displays the waveform method for 
Chamfer. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Scanning Speed
*2

Specifies the moving speed of the 
scanner.

1-Lens 
dependant
(100 mm/s)

1 mm/s

Left-Bottom X Specifies the X coordinate from the ori-
gin.

Lens dependant 0.001 mm

Left-Bottom Y Specifies the Y coordinate from the ori-
gin.

Lens dependant 0.001 mm

Width Specifies the width of side. Lens dependant 0.001 mm

Height Specifies the height of side. Lens dependant 0.001 mm

Scan Start Specifies the scanning start point 
among four corners.

Left-Top, 
Left-Bottom, 
Right-Top or 
Right-Bottom
(Drawing data 

dependant)

－

Scanning 
Direction

Specifies the scanning direction. Clockwise or 
Counterclockwise

(Drawing data 
dependant)

－

Chamfer Type Specifies the chamfer type. None, Chamfer 
or Radius

(None)

－

Chamfer Size Specifies the chamfer dimension. Drawing data 
dependant
(0.000 mm)

0.001 mm

Overlap Length Specifies the length of overlap portion. Drawing data 
dependant
(0.000 mm)

0.000 mm

Length Displays the total of the perimeter of 
the figure (object) and the overlap 
length.

－ 0.001 mm

Time Calculates the approximate scanning 
time by Length, Scanning Speed.

－ 0.1 ms

Repeat Repeatedly scans the figure (object) by 
the specified times.

1-5000
(1)

1

Hatching Specifies whether or not to set hatch-
ing.

Enable or Disable
(Disable)

－

Properties Setting Items (2 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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Square
(continued)

Laser type
Hatching

Displays the laser type for Hatching. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Hatching

Displays the number of the schedule 
data to use for Hatching. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment 

(0)

1

Wave form
Hatching

Displays the waveform method for 
Hatching. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Offset Specifies the distance between outer 
figure and the hatching range.

0.000-max. Y 
coordinate value 
of drawing range

(0.000)

0.001

Pitch Specifies the interval of hatching lines. 0.01-max. Y coor-
dinate value of 
drawing range

(1.00)

0.01

Angle Specifies the hatching angle. This is an 
absolute angle regardless of the outer 
figure.

0.000-360.000
(0.000)

0.001

Line Object type Displays the type of the figure (object). LINE －

Object name 
(default)

Specifies the name of the figure 
(object).

LINEx 256 
characters 

max.

Laser type Displays the laser type. The contents of 
this item changes depending on the 
schedule number.

SPOT, SEAM, 
or CW

－

Schedule Displays the number of the schedule 
data to use. Double-clicking this item 
displays the [Schedule Window] screen 
in 5.3. according to the set schedule 
number.

0-Depends on 
laser equipment

(0)

1

Wave form Displays the waveform method. The 
contents of this item changes 
depending on the schedule number.

FIX or FLEX －

Scanning Speed
*2

Specifies the moving speed of the 
scanner.

1-Lens 
dependant
(100 mm/s)

1 mm/s

Starting X-Coord / 
X-Coordinate

Specifies the X coordinate for the start 
point.

Lens dependant 0.001 mm

Starting Y-Coord / 
Y-Coordinate

Specifies the Y coordinate for the start 
point.

Lens dependant 0.001 mm

Ending X-Coord Specifies the X coordinate for the end 
point.

Lens dependant 0.001 mm

Ending Y-Coord Specifies the Y coordinate for the end 
point.

Lens dependant 0.001 mm

Properties Setting Items (3 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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Line
(continued)

Length Displays the length of the figure 
(object).

Lens dependant 0.001 mm

Time Calculates the approximate scanning 
time by Length, Scanning Speed.

－ 0.1 ms

Circle (Auto) Object type Displays the type of the figure (object). Auto_CIRCLE －

Object name 
(default)

Specifies the name of the figure 
(object).

CIRCLEx 256 
characters 

max.

Laser type Displays the laser type. The contents of 
this item changes depending on the 
schedule number.

SPOT, SEAM, 
or CW

－

Schedule Displays the number of the schedule 
data to use. Double-clicking this item 
displays the [Schedule Window] screen 
in 5.3. according to the set schedule 
number.

0-Depends on 
laser equipment

(0)

1

Wave form Displays the waveform method. The 
contents of this item changes 
depending on the schedule number.

FIX or FLEX －

Scanning Speed
*2

Specifies the moving speed of the 
scanner.

1-Lens 
dependant
(100 mm/s)

1 mm/s

Central X-Coord Specifies the X coordinate at the center. Lens dependant 0.001 mm

Central Y-Coord Specifies the Y coordinate at the center. Lens dependant 0.001 mm

Radius Specifies the radius of the circle. Lens dependant
(20 mm)

0.001 mm

Angle Specifies the angle formed by the start 
point and at the center of the circle.

0-360°
(0°)

0.001°

Scanning 
Direction

Specifies the scanning direction. Clockwise or 
Counterclockwise

(Drawing data 
dependant)

－

Length Displays the perimeter for the figure 
(object).

－ 0.001 mm

Time Calculates the approximate scanning 
time by Length, Scanning Speed.

－ 0.1 ms

Run-up angle Calculates and displays the run-up 
angle by shutter open delay time and 
Scanning Speed.

－ 0.01°

Repeat Repeatedly scans the figure (object) by 
the specified times.

1-5000
(1)

1

Hatching Specifies whether or not to set hatch-
ing.

Enable or Disable
(Disable)

－

Laser type
Hatching

Displays the laser type for Hatching. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Properties Setting Items (4 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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Circle (Auto)
(continued)

Schedule
Hatching

Displays the number of the schedule 
data to use for Hatching. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment 

(0)

1

Wave form
Hatching

Displays the waveform method for 
Hatching. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Offset Specifies the distance between outer 
figure and the hatching range.

0.000-max. Y 
coordinate value 
of drawing range

(0.000)

0.001

Pitch Specifies the interval of hatching lines. 0.01-max. Y coor-
dinate value of 
drawing range

(1.00)

0.01

Angle Specifies the hatching angle. This is an 
absolute angle regardless of the outer 
figure.

0.000-360.000
(0.000)

0.001

Circle 
(Manual)

Object type Displays the type of the figure (object). CIRCLE －

Object name 
(default)

Specifies the name of the figure 
(object).

CIRCLEx 256 
characters 

max.

Laser type
Overlap1

Displays the laser type for Overlap1. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Overlap1

Displays the number of the schedule 
data to use for Overlap1. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Overlap1

Displays the waveform method for 
Overlap2. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Laser type
Overlap2

Displays the laser type for Overlap2. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Overlap2

Displays the number of the schedule 
data to use for Overlap1. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Overlap2

Displays the waveform method for 
Overlap2. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Properties Setting Items (5 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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Circle 
(Manual)
(continued)

Laser type
Circle

Displays the laser type for Circle. The 
contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Circle

Displays the number of the schedule 
data to use for Circle. Double-clicking 
this item displays the [Schedule Win-
dow] screen in 5.3. according to the set 
schedule number.

0-Depends on 
laser equipment

(0)

1

Wave form
Circle

Displays the waveform method for Cir-
cle. The contents of this item changes 
depending on the schedule number.

FIX or FLEX －

Scanning Speed
*2

Specifies the moving speed of the 
scanner.

1-Lens 
dependant
(100 mm/s)

1 mm/s

Central X-Coord Specifies the X coordinate at the center. Lens dependant 0.001 mm

Central Y-Coord Specifies the Y coordinate at the center. Lens dependant 0.001 mm

Radius Specifies the radius of the circle. Lens dependant
(20 mm)

0.001 mm

Overlap Start 
Angle

Specifies the start angle of overlap. 0-360°
(0°)

0.001°

Overlap End 
Angle

Specifies the end angle of overlap 0-360°
(0°)

0.001°

Scanning 
Direction

Specifies the scanning direction. Clockwise or 
Counterclockwise

(Drawing data 
dependant)

－

Length Displays the perimeter for the figure 
(object).

－ 0.001 mm

Time Calculates the approximate scanning 
time by Length, Scanning Speed.

－ 0.1 ms

Run-up angle Calculates and displays the run-up 
angle by shutter open delay time and 
Scanning Speed.

－ 0.01°

Repeat Repeatedly scans the figure (object) by 
the specified times.

1-5000
(1)

1

Hatching Specifies whether or not to set hatch-
ing.

Enable or Disable
(Disable)

－

Laser type
Hatching

Displays the laser type for Hatching. 
The contents of this item changes 
depending on the schedule number.

SPOT, SEAM, 
or CW

－

Schedule
Hatching

Displays the number of the schedule 
data to use for Hatching. Double-click-
ing this item displays the [Schedule 
Window] screen in 5.3. according to the 
set schedule number.

0-Depends on 
laser equipment 

(0)

1

Wave form
Hatching

Displays the waveform method for 
Hatching. The contents of this item 
changes depending on the schedule 
number.

FIX or FLEX －

Properties Setting Items (6 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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Circle 
(Manual)
(continued)

Offset Specifies the distance between outer 
figure and the hatching range.

0.000-max. Y 
coordinate value 
of drawing range

(0.000)

0.001

Pitch Specifies the interval of hatching lines. 0.01-max. Y coor-
dinate value of 
drawing range

(1.00)

0.01

Angle Specifies the hatching angle. This is an 
absolute angle regardless of the outer 
figure.

0.000-360.000
(0.000)

0.001

Arc/3-Point Arc Object type Displays the type of the figure (object). ARC －

Object name 
(default)

Specifies the name of the figure 
(object).

ARCx 256 
characters 

max.

Laser type Displays the laser type. The contents of 
this item changes depending on the 
schedule number.

SPOT, SEAM, 
or CW

－

Schedule Displays the number of the schedule 
data to use. Double-clicking this item 
displays the [Schedule Window] screen 
in 5.3. according to the set schedule 
number.

0-Depends on 
laser equipment

(0)

1

Wave form Displays the waveform method. The 
contents of this item changes 
depending on the schedule number.

FIX or FLEX －

Scanning Speed
*2

Specifies the moving speed of the 
scanner.

1-Lens 
dependant
(100 mm/s)

1 mm/s

Central X-Coord Specifies the X coordinate at the center. Lens dependant 0.001 mm

Central Y-Coord Specifies the Y coordinate at the center. Lens dependant 0.001 mm

Radius Specifies the radius of the circle. Lens dependant
(20 mm)

0.001 mm

Angle Specifies the angle formed by the start 
point and at the center of the circle.

0-360°
(0°)

0.001°

End Angle Specifies the angle formed by the end 
point and at the center of the circle.

0-360°
(0°)

0.001°

Scanning 
Direction

Specifies the scanning direction. Clockwise or 
Counterclockwise

(Drawing data 
dependant)

－

Length Displays the length of the figure 
(object). Displays the perimeter for 
square and circle.

－ 0.001 mm

Time Calculates the approximate scanning 
time by Length, Scanning Speed.

－ 0.1 ms

Spot Object type Displays the type of the figure (object). SPOT －

Properties Setting Items (7 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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Spot
(continued)

Object name 
(default)

Specifies the name of the figure 
(object).

SPOTx 256 
characters 

max.

Laser type Displays the laser type. The contents of 
this item changes depending on the 
schedule number.

SPOT, SEAM, 
or CW

－

Schedule Displays the number of the schedule 
data to use. Double-clicking this item 
displays the [Schedule Window] screen 
in 5.3. according to the set schedule 
number.

0-Depends on 
laser equipment

(0)

1

Wave form Displays the waveform method. The 
contents of this item changes 
depending on the schedule number.

FIX or FLEX －

X-Coord / X-Coor-
dinate

Specifies the X coordinate. Lens dependant 0.001 mm

Y-Coord / Y-Coor-
dinate

Specifies the Y coordinate. Lens dependant 0.001 mm

Open Time Specifies the time to emit the laser. 
Pulse with of the schedule to use + 2 
ms.

0-20000000 ms
(10 ms)

0.01 ms

Polyline Object type Displays the type of the figure (object). POLY －

Object name 
(default)

Specifies the name of the figure 
(object).

POLYx 256 
characters 

max.

Laser type Displays the laser type. The contents of 
this item changes depending on the 
schedule number.

SPOT, SEAM, 
or CW

－

Schedule Displays the number of the schedule 
data to use. Double-clicking this item 
displays the [Schedule Window] screen 
in 5.3. according to the set schedule 
number.

0-Depends on 
laser equipment 

(0)

1

Wave form Displays the waveform method. The 
contents of this item changes 
depending on the schedule number.

FIX or FLEX －

Repeat Repeatedly scans the figure (object) by 
the specified times.

1-5000
(1)

1

Axis Control Object type Displays the type of the figure (object). AXIS －

Object name 
(default)

Specifies the name of the figure 
(object).

AXISx 256 
characters 

max.

Laser type Displays the laser type. The contents of 
this item changes depending on the 
schedule number.

SPOT, SEAM, 
or CW

－

Properties Setting Items (8 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch
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*1 Scanning Standby
If the OVERRATE error occurs when SPOTs are used, specify [Scanning Standby] in the properties field or 
[Shutter Close Delay] on the [System Parameters] screen and insert a wait time between SPOTs.

*2 A setting effect may not be obtained depending on the object shape in the layout.

Axis Control
(continued)

Schedule Displays the number of the schedule 
data to use. Double-clicking this item 
displays the [Schedule Window] screen 
in 5.3. according to the set schedule 
number.

0-Depends on 
laser equipment

(0)

1

Wave form Displays the waveform method. The 
contents of this item changes 
depending on the schedule number.

FIX or FLEX －

Axis Move Specifies whether or not to move the 
coordinates.

Yes or No
(No)

－

X-Coord / X-Coor-
dinate

Specifies the X coordinate of 
destination.

Lens dependant 0.001 mm

Y-Coord / Y-Coor-
dinate

Specifies the Y coordinate of 
destination.

Lens dependant 0.001 mm

Properties Setting Items (9 / 9)

Figure type Item Setting specifics Range
(Default)

Pitch

SPOT
(OpenTime)

Scanner Moving

Standby After Jump

Scanning
Standby

Shutter Close Delay
(Negative value is valid.)
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4. Poly Resolve (Splitting Figures)

Polylines created can be split at their construction points into line segments or arcs.
Only polylines can be split.

1 From the menu, select [Adjustment] -> [Poly Resolve].

2 Select the figure to split.

The figure is split into multiple line segments or arcs. Polylines are split at each con-
struction point.

Even if the Repeat has been set, it becomes invalid line when the figure is split. 
The original figure is split into line segments or arcs.

Split into multiple 
line segments or 
arcs.

CAUTION
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5. Square Resolve (Splitting Squares)

Squares created can be split into line segments and arcs.

1 From the menu, select [Adjustment] -> [Square Resolve].

2 Select the square to split.

The square is split into multiple line segments. When the square is created with
chamfer or radius specified, it is split into multiple line segments and arcs.

• When hatching is applied to the square, a message is displayed to confirm 
whether you convert hatching into polylines or delete hatching.

• Even if the Repeat has been set, it becomes invalid line when the figure is split. 
The original figure is split into line segments or arcs.

Split into multiple 
line segments and 
arcs.

CAUTION
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6. Divide (Dividing Figures)

Figures created can be divided at any point. Only line segments and arcs can be
divided.

1 From the menu, select [Adjustment] -> [Divide].

2 Select the figure to divide.

3 Specify the start and finish points for the divide. The figure is divided at the 
intersection with the line specified by the start and finish points.

The figure is divided into two separate figures.

Specify start and finish points.

 Divide at intersection.

Divided into two figures.
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• Dividing an arc
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7. Arc to Poly

Arcs created can be divided into the desired number of polylines.

1 From the menu, select [Adjustment] -> [Arc to Poly].

2 Select the figure to divide.

The [DivisionArc] screen is displayed.

3 Specify the number for dividing.

The arc is divided into the specified number of polylines.

Select a figure.

Specify the number for dividing.

Divided into the specified num-
ber.
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8. Unite (Joining Two Figures into One)

Two line segments or arcs can be joined into one. Line segments and arcs can be joined
with other line segments and arcs. Only line segments and arcs can be joined.

1 From the menu, select [Adjustment] -> [Unite].

2 Select the two figures to join and specify the join point (P1).

The two figures are joined forming a single figure.

• The specified figures cannot be joined if they are not convergent.
• Even if they are convergent, figures cannot be joined if the length of the 

extended line exceeds the maximum value. The length of the extended line can 
be set in [Setting] -> [Preferences] -> [Other] -> [Max. Combined] in the menu.

Select two figures.

Figures are joined 
forming a single figure.

CAUTION
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The join point (P1/P2) can be selected when joining a line segment with an arc.

• When joining at P1

• When joining at P2

The figure cannot be joined if the length to the join point (P1/P2) exceeds the 
maximum value. The length to the join point can be set in [Setting] -> 
[Preferences] -> [Other] -> [Max. Combined] in the menu.

Select join point (P1/P2).

CAUTION
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9. Unite Poly

Lines, polylines and arcs created can be joined into one automatically or manually.

9.1. Auto (Joining Lines into One Automatically)

1 From the menu, select [Adjustment] -> [Unite Poly] -> [Auto].

2 Select a figure.

3 Select a figure to join it with the figure selected in step 2. 

The two or more figures are joined forming a single polyline.

Select a figure.

Figures are joined 
forming a single polyline.
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9.2. Manual (Joining Lines into One Manually)

1 From the menu, select [Adjustment] -> [Unite Poly] -> [Manual].

2 Select a figure.

3 Select a figure to join it with the figure selected in step 2 and click the join point (P1).

The two or more figures are joined forming a single polyline.

Make sure that there is no small line segment between arc and line. If it is difficult 
to unite them, select [Adjustment] -> [Arc to Poly] from the menu to divide arcs 
into polylines.

Click joint point (P1).

Figures are joined 
forming a single polyline.

CAUTION
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10. Fillet

Corners created with two line segments or two elements of polyline can be rounded off
in the specified radius.

“Two elements” means:

* For polyline, a fillet can be canceled by specifying radius 0 or negative element.

1 From the menu, select [Adjustment] -> [Fillet].

2 Select the two line segments to be filleted.

3 Enter the connecting arc radius in the command field.

4 Press the <Enter> key.

The two line segments are connected with an arc.

An arc radius larger than the distance from the intersection to the ends of the 
lines cannot be entered.

Adjacent Two lines away

Select two line segments.

CAUTION
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The last specified arc radius will be used if the <Enter> key is pressed without
specifying the arc radius. The default value can be set in [Setting] -> [Preferences] ->
[Other] -> [Radius of Fillet] in the menu.

To undo the operation, select [Edit] -> [Undo] from the menu, change the arc radius,
and then select [Adjustment] -> [Fillet] again.

Two line segments are 
connected with an arc.



11. Add Const. Pt

186

SWDraw3

11. Add Const. Pt

Construction points can be added to line segments or polylines created.

1 From the menu, select [Adjustment] -> [Add Const. Pt].

2 Select the line segment or polyline to be added the construction point to.

3 Click the position at which you want to add the construction point.

The construction point is added at the specified position.

Specify the position at which 
the construction point is add.

The construction point is 
added.
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12. Delete Const. Pt

Construction points can be deleted from line segments or polylines created.

1 From the menu, select [Adjustment] -> [Delete Const. Pt].

2 Select the line segment or polyline to be deleted the construction point from.

3 Click the position of the construction point number which you want to delete.

The construction point at the specified position is deleted.

Click the construction point to 
delete.

The construction point is 
deleted.
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13. Hatch to Poly

Hatching set in circles or squares can be converted into polylines.

1 From the menu, select [Adjustment] -> [Hatch to Poly].

2 Select the hatched circle or square.

Hatching is converted into polylines.

Select a figure.

Hatching is converted into 
polylines.
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1. Scanning Direction Control Function

The following three scanning direction control functions in the [Adjustment] menu list
are available for scanning order.

• Automatic Scanning Order Function
• Reverse Scanning Order Function
• Scanning Order Confirmation Function

1.1. Applicable Objects and Caution Points

Applies to all objects except dots.
Note that this does not apply to objects with no contact points.

Caution points for individual objects

1.2. Determining Scanning Direction

If multiple contact points exist, the scanning order of the objects in contact is used
(lowest scanning number first).

Chapter 10 Scanning Control 
Specifications

Object Details

Line • The contact point with the previous object forms the start point.

Arc • The contact point with the previous object forms the start point.

Circle [Auto] • The contact point with the previous object forms the start point.
• The start and end angles are determined when the circle is drawn.
(1) When using the mouse for drawing, the start and end angles are the 

points clicked (or right-clicked) to specify the circle radius.
(2) When using the keyboard for drawing, the start and end angles are fixed 

at 0°.

Polyline • The contact point with the previous object forms the start point.
• The order of intermediate points will also be changed if the start and end 

points are switched for polyline objects.

Square • The contact point with the previous object forms the start point.
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1.3. Identifying Objects within the Program

For automatic scanning order and scanning order confirmation, unique object items
are controlled using SetTag() and GetTag() to identify that object when there are
multiple objects in contact with the initial one.

2. Automatic Scanning Order Function

This function sets the scanning order and direction of continuous objects with contact
points to allow objects arranged on the drawing screen to be drawn in the desired
sequence by the creator.

2.1. Automatic Scanning Order Function Operations

• From the menu, select [Adjustment] -> [Scanning Order] -> [Auto].

• The following message is displayed in the guidance bar.

This function does not handle circle (manual), square, and spot objects.
CAUTION

(1) Select Adjustment from menu.

(2) Select Scanning Order.

(3) Select 
Auto.
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2.2. Automatic Scanning Order Error Control

A message box appears for each specific error detected. Click the [OK] button in the
message box to continue using the automatic scanning function. (The guidance
message in section 2.1 is displayed.)

(1) The following message is displayed if a dot is selected as the starting object.

(2) The following message is displayed if more than one object is selected as the starting 
object.
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2.3. Automatic Scanning Direction Control

The scanning direction is determined as described below, and the scanning order is
applied to the connected objects with the object forming the starting point as 1.
Objects not selected here will be assigned subsequent scanning order.

(1) If an object is connected to the end point of the object forming the starting point 
selected, scanning order control is applied to all the continuous objects (with contact 
points at the start and end points). Objects subject to scanning direction control are 
indicated in red, with the scanning order assigned to continuous objects with the 
object forming the starting point as 1. Other objects will be assigned subsequent 
scanning order.
Note that when more than one object is connected at a contact point, scanning 
order is applied to the object with the lowest scanning number first. Objects not 
selected here will be assigned subsequent scanning order.
The Automatic Scanning Order function is continued even after processing is 
complete. (The guidance message in section 2.1 is displayed.)

(2) If no object is connected to the end point of the object forming the starting point 
selected, and an object is connected to the starting point, scanning order control is 
applied to all the continuous objects (with contact points at the start and end points). 
Objects subject to scanning direction control are indicated in red, with the scanning 
order assigned to continuous objects with the object forming the starting point as 1. 
Other objects will be assigned subsequent scanning order.
Note that when more than one object is connected, scanning order is applied to 
the object with the lowest scanning number first. Objects not selected here will be 
assigned subsequent scanning order.
The Automatic Scanning Order function is continued even after processing is 
complete. (The guidance message in section 2.1 is displayed.)

(3) If no object is connected to the end point or start point of the object forming the 
starting point selected, the message "No connected object could be found" (see 2.2 
(2)) is displayed. Click the [OK] button to continue using the automatic scanning 
function. (The guidance message in section 2.1 is displayed.)
The figure below shows the situation after automatic control is complete. The 
scanning direction is indicated at the start point of the object forming the start 
point.
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(4) Automatic scanning example 1

Ex 1: Confirming the scanning direction and order for the figures shown below.

a.) The connected objects are shown as follows when sequence object 3 is 
selected.

b.) Reorder the scanning order as follows.
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(5) Automatic scanning example 2

Ex 2: Confirming the scanning direction and order for the figures shown below.

a.) The connected objects are shown as follows when sequence object 3 is 
selected.

b.) Reorder the scanning order as follows.
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3. Reverse Scanning Order Function

3.1. Reverse Scanning Order Function Operations

• From the menu, select [Adjustment] -> [Scanning Order] -> [Reverse].

• The following message is displayed in the guidance bar.

This function does not handle square and spot objects.
CAUTION

(1) Select Adjustment from menu.

(2) Select Scanning Order.

(3) Select 
Reverse.
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3.2. Reverse Scanning Order Error Control

A message box appears for each specific error detected. Click the [OK] button in the
message box to continue using the automatic scanning function. (The guidance
message in section 2.1 is displayed.)

(1) The following message is displayed if a dot is selected as the starting object.

(2) The following message is displayed if more than one object is selected as the starting 
object.
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3.3. Reverse Scanning Order Control

The Reverse Scanning Order function controls by switching the start and end points
for the object selected.

• The start and end points for the selected object are switched, and a blue triangle with 
the letter "S" (for Start) is displayed over the start point, with the top vertex indicating 
the scanning direction.

The Reverse Scanning Order function is continued. (The guidance message in 
section 3.1 is displayed.)

Ex: The figures below show the same line object with the start and end points 
switched.



4. Scanning Order Confirmation Function

198

SWDraw3

4. Scanning Order Confirmation Function

4.1. Scanning Order Confirmation Function Operations

• From the menu, select [Adjustment] -> [Scanning Order] -> [Check].

• The following message is displayed in the guidance bar.

(1) Select Adjustment from menu.

(2) Select Scanning Order.

(3) Select 
Check.
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4.2. Scanning Order Confirmation Error Control

A message box appears for each specific error detected. Click the [OK] button in the
message box to continue using the scanning order confirmation function. (The
guidance message in section 4.1 is displayed.)

(1) The following message is displayed if a dot is selected as the starting object.

(2) The following message is displayed if more than one object is selected as the starting 
object.



4. Scanning Order Confirmation Function

200

SWDraw3

4.3. Scanning Order Confirmation Direction Control

The scanning direction is determined as follows.

(1) If an object is connected to the end point of the selected object forming the start point 
(contact point forms end point of first object and start point of next object), it is 
indicated in red.

The object number becomes the scanning number of the previous object + 1.
(Searches for the object with scanning number + 1 even when there are multiple 
contact points.)
The Scanning Order Confirmation function is continued even after processing is 
complete. (The guidance message in section 4.1 is displayed.)

(2) If no object is connected to the end point of the object forming the starting point 
selected, the message "No connected object could be found" (see 4.2 (2)) is 
displayed. Click the [OK] button to continue using the automatic scanning function. 
(The guidance message in section 4.1 is displayed.)

The figure below shows the situation after confirmation is complete. The 
scanning direction is indicated at the start point of the object forming the start 
point.
The same scanning direction is indicated after automatic control is complete.

(3) Scanning order confirmation Ex 1

Ex 1: Confirming the scanning direction and order for the figures shown below.
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• The connected objects are shown as follows when sequence object 3 is selected.

(4) Scanning order confirmation Ex 2

Ex 2: Confirming the scanning direction and order for the figures shown below.

• The connected objects are shown as follows when sequence object 3 is selected.
No object is connected to the end point of the starting object here, so the "No 
connected object could be found" message box is displayed.
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1. Line (Drawing Lines)

Specify two points to draw a line.

1 Click the [Line] button, located in Drawing commands. Alternately, from the menu, 
select [Draw] -> [Line].

2 Specify the start and end points for the line.

A line connecting the start and end points is drawn automatically.
The content of the entered figures, size, and other details can be adjusted in
properties. Separate machining conditions can also be applied.

Chapter 11 Draw

Using commands other than those listed below while drawing will delete the 
object being drawn.
[Zoom Extents], [Zoom All], [Zoom In], [Zoom Selection], [Zoom Out], [Pan], and 
[Refresh] in the View menu.CAUTION

Specify the start and end points.
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2. Polyline (Drawing Polylines)

Polyline is an object that consists of multiple lines or arc.

Polylines with arc cannot be created from the start.

To create polylines with arc, the following operation is required.

• Making fillet at the line portion of polyline with [Fillet]
• Combining with arc with [Unite Poly]
• Pasting data including a radius value in the property

2.1. New Polyline

Draw polylines as follows:

1 Click the [Polyline] button, located in Drawing commands. Alternately, from the menu, 
select [Draw] -> [Polyline].

2 Specify the first and second points in the line.
A line connecting the first and second points is drawn automatically.

3 As you continue specifying points, lines are drawn connecting them to the polyline.

4 When drawing is complete, press the <Enter> key.

The polyline is now complete.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

Specify vertices of polyline.
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2.2. [Poly] Screen Arrangement

(1) Const. Pt

Cells for inputting parameter values of construction points.
The polyline requires at least start point of the first line, end point of the first 
line/start point of the second line, and end point of the second line, it consist of 
three lines or more.
The line requires start point and end point, it consist of two lines.
The arc requires start point, middle point and end point, it consist of three lines.

Const. Pt Settings

Item Setting Details Range
(Default)

Pitch

Const. Pt Displays the construction point 
number of polyline.

1 to 500 1

Speed Sets the moving speed of the scanner 
between construction points.

1 to Lens dependant
(100 mm/s)

1 mm/s

X-Coor Sets the X-coordinate of the 
construction point of polyline.

Lens dependant 0.001 mm

Y-Coor Sets the Y-coordinate of the 
construction point of polyline.

Lens dependant 0.001 mm

Radius Sets the radius of arc included in 
polyline.

Construction point 
coordinate dependant

0.001 mm

(3)

(1)

(7)

(5)
(6)

(8)

(2)

(4)
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• Displaying data at once
Displays speed, X-coordinate and Y-coordinate at once. When the number of 
construction points are large, drag the scroll bar to display the hidden data.

• Changing data directly
Changes values by numerical entry. The values are increased/decreased with 
the <PageUp>/<PageDown> key, and the drawing of polyline also changes 
simultaneously with the value. However, the drawing does not change if an 
error has occurred.

• Copying/pasting data
The data can be exchanged with a text editor such as “Microsoft Excel” to edit 
the polyline already created. Clicking the right mouse button on the table 
without selecting a row displays the copy/paste menu to copy/paste the whole 
table. The specified row cannot be copied and a row cannot be pasted in the 
specified row or later. For the data to be pasted, be careful of the followings.
・ The speed data with a decimal point is truncated at a decimal point.
・ The coordinate data with four or more decimal places is rounded off to four 
decimal places.
・When the polyline data having an arc is pasted in properties for the already 
created polyline, the radius is automatically calculated by three points (start 
point, middle point and end point) that make up an arc. With a value in radius 
field, the data is judged as an arc.

• An arc consists of three points (start point, middle point and end point). When 
the radius data continues, the second radius becomes invalid.
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• Since the radius data is the middle point of arc, the radius value of the first 
point or the end point becomes invalid.

or
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• Checking data
The background color of cell changes when a value is input in, and you can 
find that the value is changed. The background color is green for normal 
values and red for abnormal values.
In both cases of pasting and changing at once, the error check is carried out in 
a similar manner. An error occurs in the following cases.
・ A value outside the range is input.
・ No value is input.
・ Values of both X- and Y-coordinates are the same consecutively.
・ The number of construction point exceeds the limit (The maximum number 
of construction points per object is 500.)

• Adding/deleting construction point (row)
Just as adding/deleting construction points, construction points (rows) can be 
added/deleted. In case of addition, the coordinate of construction point is the 
center between the previous and next construction points (rows). However, for 
the first row, a construction point is added at the origin. 
When clicking the right mouse button while selecting a construction point 
(row) (or with pressing the <Delete> key or the <Insert> key), the add/delete 
menu is displayed. To add the bottom row, select the add menu with pressing 
the <Shift> key.

• Checking construction position by selecting construction point (row)
When a construction point is selected, the position can be checked in the lay-
out area.

• Selecting multiple construction points (rows)
To select any multiple rows, click them on with the mouse while pressing the 
<Ctrl> key.
To select multiple rows within the specified range, click them on with the 
mouse while pressing the <Shift> key.

(2) Total Length
Displays the reference value of distance of the whole polyline. However, this is 
not displayed if an error has occurred with the input coordinate.

(3) [Distance Time] button
Click this button to switch to the confirmation screen for the distance and the 
reference time between construction points. However, the button becomes 
grayout and cannot be clicked if an error has occurred with the input coordinate.
The following functions can be used on the confirmation screen.
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(4) Batch Edit
Changes a menu selected among offset, speed initialization, zoom, and rotation 
function at once.
Select a menu and click the [Batch Edit] button after inputting values. The 
values are reflected in cells for inputting parameter values of construction points.
When cell (row) is selected, the setting is valid for the selected row only. When no 
cell (row) is selected, the setting is valid for all rows. However, the zoom function 
is valid for all rows only.

• [Edit by offset]
Offsets speed, X-coordinate and Y-coordinate. ± setting is available. The range 
depends on the lens setting. Only speed can be set on the confirmation screen.

Confirmation Screen Settings

Item Setting Details

Const. Pt Displays the distance and the reference time for each 
construction point (except the arc middle point). Speed can be 
changed, but Distance and Time cannot be changed, only 
displayed. Also, they can be copied, but not pasted.

[Coordinates] button Switches to the screen to input coordinate values of 
construction points.

[measures 2 Points] 
button

Calculates the speed and the reference time between any two 
points.

Batch Edit Changes speed only.
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• [Speed initialization]
Initializes all speed settings at once.

• [Edit by expansion rate]
Zooms with reference to the coordinate of construction point 1. The range is -
100.0 to +100.0. This cannot be set on the confirmation screen.

• [Edit by rotate]
Rotates with reference to the XY coordinates of center point. The range is 
0.000 to 360.000.

(5) [Undo] / [Redo] button
Click the [Undo] button to undo an action that you have done.
Click the [Redo] button to redo an action that you have undone.
The [Undo] button can be clicked more than once, but the [Redo] button can be 
clicked only once.

(6) Edit prohibition with mouse
Check the checkbox to prohibit (lock) the drawing data from being moved with 
the mouse.

(7) [Cancel] button
Click this button to cancel all changes made after the [Poly] screen is displayed.

(8) [Edit Commit] button
Click this button to enter the data finally. However, the button cannot be clicked 
if an error has occurred with the input coordinate.
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2.3. Modifying Polyline

Polylines created can be modified with using the mouse or in properties.

2.3.1. Moving the Whole Polyline

Fine adjustment of construction points such as speed and coordinates can be made on
the dedicated screen for editing polylines displayed in the left side of the screen ([Poly]
screen). For the details of functions on the [Poly] screen, see "Chapter 11-2.2. [Poly]
Screen Arrangement"(page 204) .
1 When a polyline is selected, the [Poly] screen is displayed.

2 Specify an element to change or move.

3 Click the place where there is no construction point on the polyline to display "" at 
the construction point.

4 When "" is clicked, the whole polyline can be moved. Clicking the left mouse button 
after moving it to determine the position and update parameter values in the [Poly] 
screen in the left side of the screen.

The [Poly] screen is displayed only when a polyline is selected.
When multiple polylines are selected, the screen is not displayed.�

“” is displayed.
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5 When modification is complete, click the [Edit Commit] button.

Determine the 
position.

Click the [Edit 
Commit] but-
ton.
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2.3.2. Changing in Shape

Fine adjustment of construction points such as speed and coordinates can be made on
the dedicated screen for editing polylines displayed in the left side of the screen ([Poly]
screen). For the details of functions on the [Poly] screen, see "Chapter 11-2.2. [Poly]
Screen Arrangement"(page 204) .
1 When a polyline is selected, the [Poly] screen is displayed.

2 Specify an element to change or move.

3 Click around the place where there is a construction point on the polyline to display 
"O" at the construction point or select a line on the Object Browser. (The line start and 
end points, and arc start, end and middle points can be selected by clicking.)

4 When "O" is clicked, a construction point can be moved. Clicking the left mouse but-
ton after moving it to determine the position and update parameter values in the 
[Poly] screen in the left side of the screen.

The [Poly] screen is displayed only when a polyline is selected.
When multiple polylines are selected, the screen is not displayed.�

“O” is displayed.

Determine the 
position.
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5 When modification is complete, click the [Edit Commit] button.

You can also make modifications in properties.
However, the following rules are applied.

 Changing the coordinate value with the mouse (changing by directly entering the 
coordinates in the point coordinates list)

• When the start point is changed, its coordinate and radius is changed. The middle 
and end points are not changed. 

(The radius is automatically calculated by the start, middle and end points.)

• When the middle point is changed, its coordinate and radius is changed.

(The radius is automatically calculated by the start, middle and end points.)

Click the [Edit 
Commit] but-
ton.

Start point

Middle point
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• When the end point is changed, its coordinate and radius is changed.

　 (The radius is automatically calculated by the start, middle and end points.)

 Changing the radius in properties (changing by directly entering the radius in the point 
coordinates list)

• When the arc start and end points are connected smoothly.

The start and end points are adjusted to connect smoothly with a changed radius. 
However, the settable range of radius is displayed when an arc cannot be created 
with the input radius.

End point
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2.3.3. Adding/Deleting Construction Points

 Using the mouse

• Adding the construction point in drawing area

In addition to the conventional function that allows the construction point to be 
added to the line portion of polyline, the construction point can be added to the 
arc portion. When the construction point is added on an arc, the specified arc is 
divided into two.

• Deleting the construction point in drawing area

When the arc start point is deleted (viewed from the scanning direction), the arc 
middle point is also deleted.

When the arc end point is deleted (viewed from the scanning direction), an arc is 
created with the arc start point, the arc middle point, and the next point of the 
deleted point.

When the arc middle point is deleted, the arc start point and the arc end point 
are joined with a line.

スキャン方向 

削除点 Point to be 
deleted

Scanning 
direction

スキャン方向 

削除点 

Scanning 
direction

Point to be 
deleted
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 By setting in properties

• Adding the construction point in properties

• Deleting the construction point in properties

削除点 Point to be 
deleted

Select a line to 
add a construc-
tion point to and 
right-click the line.

When Insert is 
clicked, a con-
struction point is 
added.

The color of the 
inserted line changes.

Select a line to 
delete a construc-
tion point from and 
right-click the line.

When Delete is 
clicked, a con-
struction point is 
deleted.

A construction 
point is deleted.
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3. Parallel Lines (Drawing Parallel Lines)

Draw a line parallel to an existing line as follows:

1 Click the [Parallel Lines] button, located in Drawing commands. Alternately, from the 
menu, select [Draw] -> [Parallel Lines].

2 Select the line (line segment) to be used as the reference line to determine the angle 
of the parallel line.

3 Specify the start and end points of the line to draw.

A line is drawn parallel to the one chosen in step 2.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

Using any of the commands listed below while drawing a parallel line will delete 
the parallel line and draw a normal line.
[Zoom Extents], [Zoom All], [Zoom In], [Zoom Selection], [Zoom Out], [Pan], and 
[Refresh] in the View menu.CAUTION

Select the line.

Specify start and end points.
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4. Square (Drawing Rectangles)

Draw rectangles as follows:

1 Click the [Square] button, located in Drawing commands. Alternately, from the menu, 
select [Draw] -> [Square].

2 Specify the start point.

3 Specify the size of the rectangle.

Move the mouse to enlarge or reduce the rectangle. Click when the rectangle is the
desired size.

The [Square] screen is displayed.

4 Specify the values, referring to the table below. Click the [OK] button when finished.

Square Settings

Item Setting specifics Range (Default) Pitch

Si
ze

Width Specifies the width of side. Lens dependant 0.001 mm

Height Specifies the height of side. Lens dependant 0.001 mm

Move the mouse to determine 
the rectangle size.
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A rectangle is drawn.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

[Scanning Direction]

Scanning direction (clockwise or counter-clockwise) will be set depending on how the
rectangle is drawn. The scanning direction can be checked or changed in the
[Scanning Direction] field in Properties.

• When the end point is to the right of the start point:
Scanning will be in the clockwise direction.

Ch
am

fe
r

No Does not perform chamfering. － －

Chamfer Chamfers four corners by specifying the radius 
of arc. The setting is applied to all of the four 
corners.

0.01-Drawing 
data dependant

(0.000 mm)

0.001 mm

Radius Chamfers four corners by specifying the line 
length to cut. The setting is applied to all of the 
four corners.

0.01-Drawing 
data dependant

(0.000 mm)

0.001 mm

Sc
he

du
le

Overlap1 Specifies the number of the schedule data to use 
for the overlap portion starting from the start 
point.

0-Depends on 
laser 

equipment
(0)

1

Overlap2 Specifies the number of the schedule data to use 
for the overlap portion ending at the end point.

0-Depends on 
laser 

equipment
(0)

1

Line Specifies the number of the schedule data to use 
for the lines.

0-Depends on 
laser 

equipment
(0)

1

Chamfer Specifies the number of the schedule data to use 
for the chamfer portion.

0-Depends on 
laser 

equipment
(0)

1

Overlap Length Specifies the length of overlap portion. Drawing data 
dependant

(0 mm)

0.001 mm

Square Settings

Item Setting specifics Range (Default) Pitch

R

R

C

C



4. Square (Drawing Rectangles)

220

SWDraw3

• When the end point is to the left of the start point:
Scanning will be in the counter-clockwise direction.

Click the [Scanning Direction] field in Properties to change the scanning direction.
Click the [Update] button to apply the settings.

The settings will not be applied unless the [Update] button is clicked.

When changing the scanning direction of a rectangle, do not select [Adjustment] -
> [Scanning order] -> [Reverse] in the menu.

CAUTION

CAUTION
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5. Circle (Drawing Circles)

There are two types of circle. Select the function depending on the intended use.
Circle (Manual): The drawing start and end points can be arbitrarily set. Circles

with overlap* can be drawn.
Circle (Auto): The system calculates previous object to automatically decide the

drawing start point. Circles with overlap cannot be drawn.
* “Overlap” is the function to weld the welded portion again for hermetically closing the circular area.

5.1. Drawing Circles with Overlap (Manual)

Draw circles with overlap as follows:

1 Click the [Circle [Manual]] button, located in Drawing commands. Alternately, from 
the menu, select [Draw] -> [Circle [Manual]].

2 Specify the start point.

3 Specify the size of the circle.

• Using the mouse

Move the mouse to enlarge or reduce the circle. Click when the circle is the 
desired size.

• By specifying points

Enter the radius or diameter in the command field. (single-byte alphanumeric)
Add the prefix "D" when entering diameters.
The [Circle] screen is displayed.

Move the mouse to determine the 
circle size.
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4 Enter values, referring to the following table. Click the [OK] button when you have 
finished setting.

A circle is drawn based on these conditions.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

Schedule number to be used
① Schedule number set in Overlap1
② Schedule number set in Circle
③ Schedule number set in Overlap2

Circle Settings

Item Setting specifics Range (Default) Pitch

Si
ze Radius Specifies the radius of circle. Lens dependant 0.001 mm

O
ve

rl
ap

Start Angle Specifies the start angle for the overlap 
portion.

0-359.999° 0.001°

End Angle Specifies the end angle for the overlap 
portion.

0-359.999° 0.001°

Sc
he

du
le

 *
1

Overlap1 Sets the schedule number used for the 
first overlap portion.

0-Depends on laser 
equipment

(0)

1

Overlap2 Sets the schedule number used for the 
second overlap portion.

0-Depends on laser 
equipment

(0)

1

Circle Sets the schedule number used for the 
arc other than overlap portion.

0-Depends on laser 
equipment

(0)

1

Counter clockwise

(when [Start Angle] is 90° and [End Angle] is 180°)

Clockwise

(when [Start Angle] is 0° and [End Angle] is 270°)
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[Scanning Direction]

The scanning direction can be checked or changed in the [Scanning Direction] field in
Properties.

• When the end point is to the right of the center point:
Scanning will be in the clockwise direction.

• When the end point is to the left of the center point:
Scanning will be in the counter-clockwise direction.

5.2. Drawing Conventional Circles (Auto)

Draw conventional circles as follows:

1 Click the [Circle [Auto]] button, located in Drawing commands. Alternately, from the 
menu, select [Draw] -> [Circle [Auto]].

2 Specify a point as the center of the circle.

3 Specify the size of the circle.

• Using the mouse

Move the mouse to enlarge or reduce the circle. Click when the circle is the 
desired size.

• By specifying points

Enter the radius or diameter in the command field. (single-byte alphanumeric)
Add the prefix "D" when entering diameters.

A circle is drawn based on these conditions.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

Move the mouse to determine the 
circle size.
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[Scanning Direction]

The scanning direction can be checked or changed in the [Scanning Direction] field in
Properties.

• When the end point is to the right of the center point:
Scanning will be in the clockwise direction.

• When the end point is to the left of the center point:
Scanning will be in the counter-clockwise direction.
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6. Arc (Specifying a Radius to Draw an Arc)

A radius can be specified to draw an arc as follows:

1 From the menu, select [Draw] -> [Arc].

2 Specify a point as the center of the circle.

3 Specify the radius of a circle that includes the arc.

• Using the mouse

Move the mouse to lengthen or shorten the line representing the radius. Click 
when the radius is the desired size.

• By specifying points

Enter the radius in the command field. (single-byte alphanumeric)

4  Specify the start and end points of the arc.

The scanning area error may occur depending on the arranged figures such as 
those the center coordinate is positioned outside the marking area due to its large 
radius.
In such cases, change the arc object into the polyline object with Poly Resolve. It 
can be ready for scanning.

CAUTION

Move the mouse to 
determine radius length.
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An arc is drawn based on these conditions.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

[Scanning Direction]

Scanning direction (clockwise or counter-clockwise) will be set depending on how the
arc is drawn. The scanning direction can be checked or changed in the [Scanning
Direction] field in Properties.

• When the end point is in the clockwise direction from the start point:
Scanning will be in the clockwise direction.

• When the end point is in the counter-clockwise direction from the start point:
Scanning will be in the counter-clockwise direction.

Specify start and end 
points.
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7. 3-Point Arc (Specifying 3 Points to Draw an Arc)

Specify three points along a circumference to draw an arc, as follows:

1 Click the [3-Point Arc] button, located in Drawing commands. Alternately, from the 
menu, select [Draw] -> [3-Point Arc].

2 Specify the arc start point, middle point, and end point (in this order).

An arc is drawn based on these conditions.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

[Scanning Direction]

Scanning direction (clockwise or counter-clockwise) will be set depending on how the
3-point arc is drawn. The scanning direction can be checked or changed in the
[Scanning Direction] field in Properties.

• When the end point is in the clockwise direction from the start point:
Scanning will be in the clockwise direction.

• When the end point is in the counter-clockwise direction from the start point:
Scanning will be in the counter-clockwise direction.

The scanning area error may occur depending on the arranged figures such as 
those the center coordinate is positioned outside the marking area due to its large 
radius.
In such cases, change the arc object into the polyline object with Poly Resolve. It 
can be ready for scanning.

CAUTION

Specify the arc start point, 
middle point, and end point.
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8. Spot (Drawing Dots for Spot Welding)

The scanning laser welding system can perform seam welding along lines created
using SWDraw3. Spot welding can be performed by creating spots (dots for spot weld-
ing).
1 Click the [Spot] button, located in Drawing commands. Alternately, from the menu, 

select [Draw] -> [Spot].

2 Specify the position to place the dot.

Dots are arranged as specified.
The entered details and size can be adjusted in properties. Separate machining
conditions can also be applied.

The dot size displayed on the screen differs from the size when welded. You can 
adjust the welding size and the time the shutter remains open in [Preferences].

Specify dot.

CAUTION
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9. Axis Control (Communicates with External Devices)

This function (object) can be used for communicating with external devices.
Especially, this function is used for moving a scanner to the specific position and stop-
ping scanning at the position temporarily. For settings for the whole transfer control,
see "Chapter 6-7. System Parameters  (Setting Laser Equipment Operating Condi-
tions)"(page 101) .

9.1. Using the Axis Control Command

1 From the menu, select [Draw] -> [Axis Control] and arrange the axis control com-
mand.

2 When arranged, the object is displayed in gray.

3 The gray object is an axis control command without coordinate translation. The green 
object is one with coordinate translation.

When Axis Move is [No]. When Axis Move is [Yes].
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9.2. Example of Axis Control Command

Check the position (manipulate an image) at the side end.
1 From the menu, select [Draw] -> [Axis Control] and arrange the axis control com-

mand.
The command should be arranged within the area.

2 Select the arranged object and change the property.
Select “Yes” for [Axis Move] and input the coordinate value for moving the scanner.

3 Similarly, arrange axis control commands on other positions you need.

4 Change the order of executing the axis control command.
When an axis control command is added, it is added to the end of the scanning order.
Change the scanning order on the Object Browser.
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5 Save the layout as new file.

* The axis control command is executed in the scanning order of object. 
Take care of the order.
To stop the scanner at the position of orbiting scanning data, the axis 
control command needs to be arranged at the start point of orbiting 
object.
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10. Comment (Entering Comments)

The information for layout data can be added regardless of scanning.

As long as the comment is arranged within the area, it does not effect the scanning
even if it gets beyond the area.

10.1. Creating a Comment

1 From the menu, select [Draw] -> [Comment].

2 Enter the comment information, referring to the descriptions below.

(1) Input Text

Enter a comment.
For multiline comment, insert line feeds with the <Ctrl> + <Enter> keys.

(2) Color

Select the color used for displaying comments.

(3) Text Size

Specify the text size of comment.
The mutual text size assigned to large, medium and small is stored in 
SWDraw.INI to be described.

(4) Text Frame

Specify the character frame used for displaying comments.

(1)

(2)
(3)

(4)
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3 Click on the coordinate to place.
1 to 3 placement points can be input.
When 2 point or more is input, a lead line is created.
For 2-point lead line, press the <Enter> key after inputting the second point.

10.2. Initial Value of Comment Information

Parameters for inputting comments are stored in “Comment” section and later in
SWDraw.INI in the execution environment.

Key name Details

TextColor Color number which shows the comment color (0 to 31: descending order of 
pull-down list)
Initial value: 0

TextSize Text size 0 to 2 (0: Large 1: Midium 2: Small)
Initial value: 0

FrameType Text frame type FrameType 0 to 2 (0: None 1: Square 2: Oval)
Initial value: 0

LargeSize Text size of “Large” (in units of 0.1 mm)
Initial value: 90

MediumSize Text size of “Midium” (in units of 0.1 mm)
Initial value: 60

SmallSize Text size of “Small” (in units of 0.1 mm)
Initial value: 30

FontName Font name for single-byte “Courier New”
This font is used only when all texts are single-byte.
When using a text frame, be sure to specify a non-proportional font.

FontNameJP Font name for two-byte “MS Gothic”
This font is used when texts are two-byte or mix of single- and two- byte.
When using a text frame, be sure to specify a non-proportional font.

When placement point is 
clicked, a comment can 
be placed.
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Setting Example
[Comment]
TextColor=3
TextSize=0
FrameType=0
LargeSize=90
MediumSize=60
SmallSize=30
FontName=MS Gothic

10.3. Relation with Other Commands

All commands other than the Delete and the Move commands do not apply to com-
ments.

Also, comments are not displayed in thumbnail images, which is viewed with the
Open command after saved.
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1. Align Left

Figures can be aligned to the left as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Align Left].

The selected figures are aligned as specified.
* When the figures will overlap if aligned, they are automatically adjusted to prevent them from over-

lapping.

2. Align Right

Figures can be aligned to the right as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Align Right].

The selected figures are aligned as specified.

Chapter 12 Layout
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3. Align Top

Figures can be aligned to the top as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Align Top].

The selected figures are aligned as specified.

4. Align Bottom

Figures can be aligned to the bottom as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Align Bottom].

The selected figures are aligned as specified.
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5. Center Horizontally

Figures can be centered horizontally as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Center Horizontally].

The selected figures are aligned as specified.

6. Center Vertically

Figures can be centered vertically as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Center Vertically].

The selected figures are aligned as specified.
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7. Justify Horizontally

Figures can be justified horizontally as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Justify Horizontally].

The selected figures are aligned as specified.

8. Justify Vertically

Figures can be justified vertically as follows:
1 Access Selection mode. Hold the <Ctrl> key while selecting the figures for alignment.

2 From the menu, select [Layout] -> [Justify Vertically].

The selected figures are aligned as specified.
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1. Zoom Extents

To display only the area occupied by figures, from the menu select [View] -> [Zoom
Extents]. Only the area occupied by figures will be enlarged and displayed.

2. Zoom All

To return the display to the default view, from the toolbar, click the [Zoom All] button
or select [View] -> [Zoom All] from the menu. The screen reverts to a 100% view.

Chapter 13 View
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3. Zoom In

To zoom in, from the toolbar, click the [Zoom In] button. Or select [View] -> [Zoom In]
from the menu.

Clicking the [Zoom In] button from the toolbar zooms in for a closer view, focusing on
the center of the screen.

When selecting the command from the menu, click the left mouse button at a point to
display the point at the center of the screen (layout). After zooming, shift the layout so
that the specified point is located at the center.

4. Zoom Selection

To zoom in by specifying the viewing area, select [View] -> [Zoom Selection] from the
menu. Specify two points around the desired area in the layout area to display an
enlarged view of that area.

Specify two points defining the 
desired area.
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5. Zoom Out

To zoom out, from the toolbar, click the [Zoom Out] button. Or select [View] -> [Zoom
Out] from the menu.

Clicking the [Zoom Out] button from the toolbar zooms out for a broader view, focusing
on the center of the screen.

When selecting the command from the menu, click the left mouse button at a point to
display the point at the center of the screen (layout). After zooming, shift the layout so
that the specified point is located at the center.

6. Pan

To pan the view by specifying the center point, from the menu, select [View] -> [Pan].
Specify one point in the layout area to become the center of the viewing area.

Specify a point.
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7. Show/Hide Grid

The grid is a set of evenly spaced dots displayed in the active layout area to help in
figure arrangement. These dots are only displayed in the layout area. They are not
welded.
The grid can be used with the snap function to snap the cursor to the grid. In this way,
accurate drawings are possible even with rough mouse operations.
To show the grid, from the menu, select [View] -> [Show/Hide Grid].

For details, refer to "Chapter 14-1. Grid Spacing" (page 244) .

8. Refresh

Select [View] -> [Refresh] from the menu to clear artifacts (images inappropriately left
on the screen).

9. Show/Hide Sketch

To toggle between showing and hiding sketches, choose [Show/Hide Sketch] from the
[View] menu.

10. Edit Sketch

Sketches cannot be edited in regular Layout Edit mode. Instead, select Sketch Edit
mode from the menu. Select [View] -> [Edit Sketch] and then select the [Edit Sketch]
menu. Note that in Sketch Edit mode, you cannot edit figures other than sketches.
To exit Sketch Edit mode, select [Edit Sketch] again from the [View] menu.
Figures are edited using the same drawing operations used in regular drawing in the
layout area. The [Adjustment] menu can be operated only in the Selection mode.

11. Show/Hide Overlap

To toggle between showing and hiding overlap portions, choose [Show/Hide Overlap]
from the [View] menu.
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12. Show/Hide Gridwork Area

To toggle between showing and hiding the Gridwork area, choose [Show/Hide Grid-
work Area] from the [View] menu.

For details, refer to "Chapter 7-1.3. Using Partial Range as Sketch" (page 116) .

13. Show/Hide Landmark

To toggle between showing and hiding landmarks, choose [Show/Hide Landmark]
from the [View] menu.

For details, refer to "Chapter 7-1.1. [Capture] Screen Arrangement" (page 111) .
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1. Grid Spacing

Set the grid dot spacing as shown below.
1 From the menu, select [Grid] -> [Grid Spacing].

The [Grid Spacing] screen is displayed.

2 Specify the values, referring to the table below. Click the [OK] button when finished.

Chapter 14 Grid

Grid Settings

Item Setting Details Range (Default) Pitch

X Spacing Specifies the spacing along the 
horizontal axis.

0.1 to 100
(1.000)

0.1

Y Spacing Specifies the spacing along the vertical 
axis.

0.1 to 100
(1.000)

0.1
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2. Grid Origin

To draw with the cursor using the snap to grid function, follow these steps.
1 Display the grid.

1) From the menu, select [Grid] -> [Grid Origin].

2) Specify the grid origin in the layout area.

3) Specify the area in which to display the grid.
This can be selected by specifying the start and end points of the area.

The grid is displayed in the specified area.
To adjust the grid spacing, repeat this procedure from step 1.

2 Draw figures as desired. Draw lines here as an example.

The cursor snaps to the grid and cannot be clicked at other locations in the grid
display area. Figure defining points will therefore always be arranged on the grid
points.

The grid cannot be permanently removed.
It can be hidden, however, to deactivate grid functions and to permit free drawing. To
toggle the grid display on and off, select [View] -> [Show/Hide Grid] from the menu.

Grid is displayed
in area specified.

Endpoints are snapped 
to the grid.
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3. Snap Setting

Set the snap function for endpoints and center points to snap the cursor to the grid
when drawing lines using the mouse. In this way, accurate drawings are possible even
with rough mouse operations.
To have the cursor snap to specific points on objects as you draw, follow these steps.
1 Define the points to snap to.

1) From the menu, select [Grid] -> [Snap Setting].

The [Snap Setting] screen is displayed.

2) Select the points to snap to, referring to the table below. In this example, [Endpoint] is 
selected.

3) Click the [OK] button.

2 When the cursor is close to the specified point (in this example, an endpoint), right-
click. The cursor snaps to the point.

Snap Settings

Item Setting Details

Endpoint Snap to line endpoints.

Junction Snap to line intersections.

Midpoint Snap to the middle points of lines.

Central 
Point

Snap to the center point of circles or arcs.

When the cursor is at the middle of line, it snaps to the closer endpoint.

Right-click when the cursor is 
close to the endpoint to snap 
the cursor to the endpoint.

�
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4. Angle Correction

To restrict the angle of drawn lines automatically to 45-degree increments, from the
menu, select [Grid] -> [Angle Correction].

5. Distance Measurement

To measure the distance between specified two points, from the menu, select [Grid] ->
[Distance Measurement].

The cursor moves only in 
45-degree increments.
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1. Preferences

Follow these steps to specify operations for basic Drawing screen functions.
1 Click the [Preferences] button on the toolbar, or from the menu, select [Setting] -> 

[Preferences].
The [Preferences] screen is displayed.

2 Specify operations for basic Drawing screen functions, referring to the following table.

Chapter 15 Setting
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Preference Settings  (1 / 2)

Item Setting Details Range

Selection 
Figures

Color Selects the display color of selected figures. －

Line Type Selects the line type. －

Range Specifies the cursor size. 1 to 50

Selection Specifies the way in which objects are 
selected by specifying an area.
Part: Objects are selected when an area 

containing part of the object is 
selected.

All: Objects are selected when an area 
containing the entire object is 
selected.

Part/All

View Background Selects the layout area background color. －

Lines Selects the color of lines when drawing. －

Cursor Selects the cursor color. －

Dot Size Specifies the display size of dots to be 
welded using shutter control. 1 to 50

Exposure Time*1 Specifies the laser emission time from the 
moment the shutter is opened.

0.00 to 
20,000,000.00 ms

Beam Diameter (Overlap rate 
calculation)

Input the beam diameter to calculate the 
lap rate for reference when the object other 
than spot is selected alone. The lap rate 
depends on the laser equipment.

0.001 to 10 mm

Drawing 
Environment

Model Indicates the laser equipment type 
currently set in the laser control unit when 
online. This cannot be changed. The laser 
equipment can be set as desired when 
offline.

－

Drawing Area Indicates the drawing area currently set in 
the laser control unit when online. This 
cannot be changed. The drawing area can 
be set as desired when offline.

－

Figures Color Selects the figure color. －

Grid Color Selects the grid color. －

Size Specifies the grid point size. 0 to 50

Backup*2 Interval Backs up data at the specified interval. 1 to 32767

Commands Backs up data after the specified number of 
commands. 1 to 32767

Other Max. Combined Sets the permissible distance for two 
figures when joined together. Ignored when 
an arc is transformed into a circle.

1 to 9999 mm

Radius of Fillet Sets the default fillet radius for filleting. 0.0 to 99.9 mm

Language*3 Switches the language between Japanese 
and English when a Japanese operating 
system is used.

－
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*1 This setting becomes the default value for [Open Time] of spot.
*2 Open layout files and figure files are saved automatically during drawing to prevent accidental loss 

of data.
*3 When selecting English, set the setting of computer to the English mode not to garble characters.

3 Click the [OK] button to save the settings.
A message is displayed confirming that you have saved the preferences. Click the [OK] button to 
close.

4 Click the [Cancel] button or the Close box ([x] button) in the top-right corner of the 
screen when you have finished performing the settings.

System preferences settings are now complete.

Connection to Controller Specifies the way to connect between the 
computer and the laser control unit. (See 
"Chapter 2-2. Basic Settings" (page 25) .)
USB:Connects with the laser control unit 
by USB.
LAN:Connects with the laser control unit 
by LAN. Set the IP address.

USB/LAN

OverLap Shape Setting Select [Option-ON] to re-set the schedule 
and switch the schedule for the overlapped 
figure with successive same schedule num-
ber when the layout is saved.

－

Folder Log File Specifies the location in which the system 
log file is saved. Select a directory from the 
displayed dialog box after clicking the 
Browse button.

－

Work Folder Specifies the location in which user-created 
files (layouts, figures, machining 
conditions) are saved. Select a directory 
from the displayed dialog box after clicking 
the Browse button.

－

If you have not saved the settings details described in step 3, the changes you 
have made will not be applied.

Preference Settings  (2 / 2)

Item Setting Details Range

CAUTION
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1. Overview

The Object Browser is a function which lists all of the figures (objects) that are
currently arranged. It is useful for checking what figures make up a layout and for
checking and changing machining conditions by selecting individual figures.

2. Checking Object Properties in Object Browser

1 Select the [List] tab.

The Object Browser is displayed.

Chapter 16 Object Browser

Select [List] 
tab.
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2 Check the object list. The Object Browser lists the object scanning numbers, 
assigned names (object names), and object types. The object names are determined 
by the figure type.

3 To sort the list, click the list box at the top of the list, and select the sort criteria. The 
list can also be sorted in ascending or descending order depending on the sort type.
The list can be sorted according to the following types.

Object Browser Sort Item

Item Ascending Order Descending Order Remarks

List Object names are sorted in 
alphabetical order.

• Since the same name cannot be 
specified, the secondary key is 
not specified.

• Names are compared as charac-
ter strings. For example, the 
ascending order of names is 
[Line1, Line10, Line11, Line2].

The object list is 
displayed.

To check the object 
type, drag the scroll 
bar to the right.

Select sort type.
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*1 Ascending Order and Descending Order cannot be selected.

4 Select an object from the list to check its properties. Objects can also be selected on 
the layout area.
The object properties are displayed in the Properties box. The properties can be altered as necessary.

5 Select the [Draw] tab to return to the Drawing command.

Checking is now complete.

Type Objects are sorted by type. Objects of 
the same type are sorted in scanning 
order.

The ascending order of object type 
is as follows:
  Line
  Polyline
  Square
  Arc
  Circle [Auto]
  Spot
  Circle [Manual]
  Axis Control

Scanning order Sorted in scanning order.*1

Distance & Time Objects are sorted in scanning order 
and the distance and time from the 
previous object are displayed.*1

Object Browser Sort Item

Item Ascending Order Descending Order Remarks

Properties 
box.
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3. Changing Scanning Order in Object Browser

The scanning order can be checked and changed using Object Browser.
1 Select the [List] tab.

The Object Browser is displayed.

2 Select [Scanning order] in the list box at the top of the list.

Sorted in scanning order.

This cannot be selected while editing parts or sketches.

Select [List] 
tab.

CAUTION

Select [Scanning 
order].
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3 Select a figure to change its scanning order.

The object name selected in [Selected Object Name] is displayed and the corresponding figure is 
displayed in red on the layout area.

4 Change the scanning order.

• To increment or decrement the scanning order:

Click the [Move Up] or [Move Down] button to increment or decrement the 
scanning order.

Select object 
name.

Click button to 
change scanning 
order.
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• To specify the new scanning order:

Enter the scanning order in [Destination Scanning Number].

5 Click the [Update] button.
The scanning order is set and the [Scanning Order] is updated in the Properties box. Setting the 
scanning order increments or decrements the scanning order of the other objects accordingly.

Click the [Reload] button to return to the original Object Browser scanning order without setting the 
scanning order.

Enter scanning 
order.

Scanning 
order is 
updated.
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1. About SWDraw3
(Checking SWDraw3 Version Information)

1 Either click the [Help] button on the toolbar, or from the menu, select [Help] -> [About 
SWDraw3].
The [About SWDraw3] screen is displayed.

2 After confirming the version, click the [OK] button.
The version screen closes.

2. About the Controller
(Checking the Laser Control Unit Software
Version)

1 When online, select [Help] -> [About the Controller] from the menu.
The [About the Controller] screen is displayed.

2 After confirming the version, click the [OK] button.
The version screen closes.

Chapter 17 Help
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1. General Right-click Menu

The following table lists the general right-click menus and their corresponding
functions.

2. Right-click Menu When No Figure is Selected

The following table lists the right-click menus and their corresponding functions when
no figure is selected.

Chapter 18 Right-click Menus

General Right-click Menu Function List

Menu Submenu Function

Undo － Undoes the previous action.
<Ctrl> + <Z> also has the same action.

Redo － Repeats the action that was undone.
<Ctrl> + <Y> also has the same action.

Delete － Deletes the selected figures.

Right-click Menu List When No Figure is Selected (1 / 2)

Menu Submenu Function

Selection Mode － Switches to Selection Mode. Displays the properties 
of selected figures.

Copy － Creates a copy of the figures.

Move － Moves figures.

Laser Control Control Checks the laser equipment status, performs welding, 
and performs laser control.

Schedule Specifies the laser output conditions.

Batch Transfer Transfers layout files to the laser control unit.

Draw Line Draws a line.

Polyline Draws a polyline.

Parallel Lines Draws a line parallel to an existing line.

Square Draws a rectangle.

Circle [Manual] Draws a circle with overlap.

Arc Draws an arc of specific radius.

3-Point Arc Draws an arc from three specific points on a circle.
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3. Right-click Menu When a Figure is Selected

The following table lists the right-click menus and their corresponding functions when
one figure is selected.

*1 Right-click menu items used after selecting a figure
There are three ways to use right-click menu items such as Copy Selected and Move Selected after 
selecting figures, as shown below.
• Right-click on the figure to be selected.
• Right-click while pressing the <Ctrl> key with a figure selected.
• Right-click outside the drawing screen with a figure selected.
This enables only the required figures to be selected for setting. For example, using the normal Copy 
command selects the figures to be copied within an area, and so may also select unwanted figures. 
Copy Selected allows figures to be copied without including unwanted figures.

Draw
(continued)

Spot Draws points by controlling the shutter.

Axis Control Communicates with external devices.

Circle [Auto] Draws a conventional circle.

View Zoom Extents Narrows view to the area containing the figures.

Zoom All The screen reverts to a 100% view.

Zoom In After zooming, centers the point clicked on with the 
left mouse button.

Zoom Selection Zooms in on the selected area.

Zoom Out After zooming, centers the point clicked on with the 
left mouse button.

Show/Hide Grid Shows or hides grid lines.

Refresh Updates the screen display.

Setting Preferences Sets the operation of the basic application functions.

Right-click Menu List When One Figure is Selected

Menu Submenu Function

Rotation Mode － Rotates the line segment in Selection Mode.

Copy Selected*1 － Copies the figure currently selected.

Move Selected*1 － Moves the figure currently selected.

Adjustment Resolve Selected Splits the selected figure.

Divide Selected Divides the selected figure.

Unite Selected Transforms the selected arc into a circle.

Add Const. Pt 
Selected

Adds a construction point to the selected figure.

Delete Const. Pt 
Selected

Deletes a construction point of the selected figure.

Unite Poly Selected Transforms the selected figure into a polyline.

Right-click Menu List When No Figure is Selected (2 / 2)

Menu Submenu Function
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4. Right-click Menu When Multiple Figures are 
Selected

The following table lists the right-click menus and their corresponding functions when
multiple figures are selected. Multiple figures can be selected in one go by dragging
around the figures with the mouse.

*1 Right-click menu items used after selecting figures
There are two ways to use right-click menu items such as Select Copy and Move Selected after 
selecting figures, as shown below.
• Right-click while pressing the <Ctrl> key with a figure selected.
• Right-click outside the drawing screen with a figure selected.
This enables only the required figures to be selected for setting. For example, using the normal Copy 
command selects the figures to be copied within an area, and so may also select unwanted figures. 
Select Copy allows figures to be copied without including unwanted figures.

Right-click Menu List When Multiple Figures are Selected

Menu Submenu Function

Copy Selected*1 － Arranges copies of the selected figures.

Move Selected*1 － Moves the selected figures.

Adjustment Unite Selected*1 Joins the selected figures.

Unite Poly 
Selected*1

Joins the selected figures to create a polyline.

Layout Align Left Aligns figures to the left.

Align Right Aligns figures to the right.

Align Top Aligns figures to the top.

Align Bottom Aligns figures to the bottom.

Center 
Horizontally

Centers figures horizontally.

Center Vertically Centers figures vertically.

Justify 
Horizontally

Justifies figures horizontally.

Justify Vertically Justifies figures vertically.

Object (Displays the 
object names of the 
figures arranged.)

Selects the selected objects. Deselects the objects 
selected so far.
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bject*1 Parallel Lines is the same as Line after drawn.

*2 Arc and 3-Point Arc are the same properties after arranged.

Chapter 19 Available Functions 
Depending on Object Type

Line Polyline Parallel 
Lines *1

Square Circle 
[Manual]

Arc *2 3-Point 
Arc *2

Spot Axis 
Control

Circle
[Auto]

Comment

Delete ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○

Copy ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ×

Copy and 
Rotate ○ ○ ○ × ○ ○ ○ ○ ○ ○ ×

Copy and 
Invert ○ ○ ○ × ○ ○ ○ ○ ○ ○ ×

Move ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○

Move and 
Rotate ○ ○ ○ × ○ ○ ○ ○ ○ ○ ×

Move and 
Invert ○ ○ ○ × ○ ○ ○ ○ ○ ○ ×

Trim ○ × ○ × × × × × × × ×

Trim Junction ○ ○ ○ × ○ ○ ○ × × ○ ×

Selection 
Mode ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ×

Rotation 
Mode ○ × ○ × × × × × × × ×

Poly Resolve × ○ × × × × × × × × ×

Square 
Resolve × × × ○ × × × × × × ×

Divide ○ × ○ × × ○ ○ × × × ×

Arc to Poly × × × × × ○ ○ × × × ×

Unite ○ × ○ × × ○ ○ × × × ×

Unite Poly ○ ○ ○ × × ○ ○ × × × ×

Fillet ○ ○ ○ × × × × × × × ×

Add Const. Pt ○ ○ ○ × × × × × × × ×

Delete Const. 
Pt ○ ○ ○ × × × × × × × ×

Sc
an

ni
ng

 
O

rd
er

Auto ○ ○ ○ × × ○ ○ × × ○ ×

Reverse ○ ○ ○ × ○ ○ ○ × × ○ ×

Check ○ ○ ○ ○ ○ ○ ○ × × ○ ×

○ : Available   ×: Unavailable
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3-Point Arc 45, 227
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Open Layout File 49
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Parallel Line 217
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Quick Reference 30

R
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Redo 43, 149
Refresh 46, 242
Resize handle 162
Resize Sketch 43, 156
Return to Origin 102
Rotation handle 163
Rotation Mode 44
Run-up angle 169

S
Safety Shutter Control 102
Save 42, 50
Save As 42, 51
Save Layout PrevVer 42, 52
Scanning 45
Schedule 42
Seam 89
Selection Mode 44
Setting 47
Show/Hide Grid 46
Show/Hide Overlap 242
Show/Hide Sketch 46, 242
Shutter Close Delay 102
Shutter Open Delay] 102
SINE 86
Snap 246
Snap Setting 46, 246
Spot 45, 228
Square 45
Square Resolve 44
Standby After Jump 101
Status bar 41
System Parameters 43, 101

T
Toolbar 40
TRI 86
Trim 44, 160
Trim Junction 44, 161

U
Undo 43, 149
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V
Version information 47
View 46

X
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X Spacing 244

Y
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Zoom All 239
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Zoom In 46, 240
Zoom Out 46, 241
Zoom Selection 240, 242
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